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1. About this User Guide

This manual covers Lighthouse and is current as of 2020.Q1.0. When using a minor release, there may or may not be a
specific version of the user guide for that release. The current Lighthouse user guide can always be found here.

NOTE: OPERATIONS MANAGER support is partial for this release. Mass node enrollment using ZTP, enroliment via USB
drive, Access Web Ul functionality, and SNMP information are not currently supported for OPERATIONS MANAGER nodes.

All template types are supported.

GLOSSARY

Terms used in this guide to define Lighthouse elements and concepts are listed below.

TERM

DEFINITION

AUTHDOWNLOCAL (RADIUS/LDAP/AAA)

AUTHLOCAL (RADIUS/LDAP/AAA)

CELLULAR HEALTH
DARK MODE

ENROLLMENT
ENROLLMENT BUNDLE

ENROLLED NODE
ENROLLMENT TOKEN
INSTANCE

LIGHT MODE
LIGHTHOUSE

LIGHTHOUSE ENTERPRISE

When this authentication option is selected, if
remote authentication fails because the user
does not exist on the remote AAA server, the
user is denied access.

When this authentication option is selected, if
remote authentication fails because the user
does not exist on the remote AAA

server, Lighthouse tries to authenticate the user
using a local account.

Status of the cellular connection of a node.

Changes the user interface to display mostly
dark colors, reducing the light emitted by device
screens.

Connecting a node to Lighthouse

Used to assign a number of tags to a set of
nodes when they are enrolled. During enrollment,
the bundle is specified using its name, and a
bundle-specific enrollment token.

Node that has been connected to Lighthouse and
is ready for use.

A password that authorizes the node with
Lighthouse. Used when performing Node-based,
or ZTP enrollment.

A single running Lighthouse.

Changes the user interface to display mostly
light colors. This is the default Ul setting.

System for accessing, managing and monitoring
Opengear console servers.

Offers an elevated centralized management
solution with additional functionality. It supports
growing trends such as edge computing and SD-
WAN with High Availability and Remote IP
Access.
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LIGHTHOUSE VPN

LOCALAUTH (RADIUS/LDAP/AAA)

MANAGED DEVICE
MULTIPLE INSTANCE

NODE

PENDING NODE

PRIMARY INSTANCE

REPLICATION

ROLE

SECONDARY/DEPENDENT INSTANCES

SMART GROUP

TAG

The OpenVPN based connections that the
Lighthouse instance has with the nodes it is
managing

When this authentication option is selected, if
local authentication fails, Lighthouse tries to
authenticate the user using a remote AAA server.

A device that is managed via a node through a
serial, USB, or network connection.

Access nodes through multiple Lighthouse
instances at the same time,

A device that can be enrolled with Lighthouse,
allowing it to be accessed, managed, and
monitored. Currently, Opengear console servers
are supported on a standard license, with
support for other vendors Console Servers
available as an add-on.

A node that has been connected to Lighthouse
and has been configured with a VPN Tunnel, but
which has not yet been approved for access,
monitoring, or management. The approval
operation can be automated by configuring
Lighthouse to auto- approve nodes.

The main instance of Lighthouse used for
updating configuration and node enrollment.

Automatic copying of the primary Lighthouse
database to any connected dependent
instances. Replication ensures that these
instances mirror the same information and
maintains connections to the same nodes.

A set of access rights for a particular group.
Three roles are defined within Lighthouse:
Lighthouse Administrator, Node Administrator,
and Node User.

Redundant instances of Lighthouse that are
used to access Lighthouse information and
connected nodes.

Dynamic filter used to search for particular
nodes, or for defining the access rights of a
group of users. Smart Groups use node
properties, as well as tags defined by users.

User-defined attribute and value that is assigned
to one or more nodes. Tags are used when
creating Smart Groups for filtering views or
access to nodes.
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2. Lighthouse overview

2.1Lighthouse VM host requirements

To host Lighthouse, the VM needs to be configured to support a T0GB SCSI disk. If you plan on running
NetOps Secure Provisioning or SDI/IP Access, you will need a second 120GB disk.

e Lighthouse deploys as an application running in a Linux-based virtual machine (VM). The
Lighthouse binary is available in open (for VM managers such as Boxes, KVM, and VirtualBox),
VMware and Hyper-V specific Virtual Machine formats, image format. Lighthouse can also be run
through cloud hosting services including Amazon’s AWS, and Microsoft Azure.

e TorunaLighthouse VM, the host computer must be able to run a VM manager and at least one full
64-bit Linux-based virtual machine.

e To host Lighthouse, the VM needs to be configured to support:
o 10GB SCSI disk.

o 1 x network interface card, preferably paravirtualised (virtio, vmxnet3), Realtek rtI8139, or
Intel e1000 are also supported, bridged.

o VGA console for initial setup.

To dimension CPU and RAM resources, follow these guidelines:
CPU and RAM utilization increase with the number of enrolled nodes.
For small deployments (Up to 500 nodes), allocate:

e 2 x64-bit CPU cores.

e 8GBRAM.
For medium deployments (between 500 and 1000 nodes), allocate:

e 4 x64-bit CPU cores.

e 18GBRAM.
For large deployments (more than 1000), allocate:

e 4 x64-bit CPU cores.

e 32GBRAM.

For large deployments, please contact us for guidance on the deployment options, including low and zero-
touch enrollment. The performance and limitations are dependent on network deployment.

Additionally, Lighthouse VPN keepalive timeout needs to be modified according to the size of deployment.

2.2 Lighthouse architecture

Lighthouse provides a platform for centrally accessing, managing, and monitoring Opengear console
Servers.

Console servers connect to a central Lighthouse instance over an OpenVPN tunnel, and are accessed,
managed, and monitored via services transported over the VPN tunnel. In Lighthouse terminology, the
console server is referred to as the node.
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NOTE: This diagram depicts High Availability. Without a secondary Lighthouse set up, the
diagram remains the same but without the secondary elements.

2.2.1 Lighthouse to Node interactions

For management and monitoring operations, Lighthouse queries and pushes data to and from a REST API
on the node.

When a node is enrolled in Lighthouse, Lighthouse generates an X.509 certificate. This certificate
authenticates the OpenVPN tunnel and provides the node access to the Lighthouse REST API. The node
also imports a Certificate Authority from Lighthouse and uses that to allow Lighthouse access to the node’s
REST API. Lighthouse also provides a public SSH key to the node, which allows Lighthouse to access the
node’s serial ports via SSH.

For serial access, a node’s serial port subsystem is connected to via SSH. Users can also access the node's
Web Ul, which is reverse-proxied through the VPN tunnel.

2.2.2 User to Lighthouse interactions

Users interact with Lighthouse via an Ember.js JavaScript application, which communicates with
Lighthouse via a REST API. This REST API can integrate Lighthouse into other systems. Documentation for
this APl is available for direct customer use.
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While Lighthouse supports REST API versions v1, v1.1, v2, v3, v3.1 and v3.2, some of the endpoints in v1,
v1.1, and v2 have been deprecated, meaning the functionality and expected request body may be different.
We advise using the v3.2 to ensure the latest available functionality.

2.2.3 Node organization and filtering

To help search, organize, and filter access to nodes, Lighthouse uses Smart Groups which allow node
properties and user-supplied tags, consisting of a name and value, to be compiled into a search expression.
These search expressions can be saved and used to filter the various lists of nodes in the Web Ul, for
example when selecting a serial port to connect to or to connect to the node’s Web Ul. They can also be
used for selecting the nodes that a particular group of users can access.

To help locate managed devices, Lighthouse includes Managed Device Filtering which allows users to
search for port labels on a node. This search can be saved and applied on the MANAGE > MANAGED
DEVICES > Console Gateway page.

2.2.4 Multiple Instance Feature

Starting with version 5.3, Lighthouse offers a Multiple Instance feature that allows you to set up a
secondary or dependent instance of Lighthouse that automatically receives updates from a primary
Lighthouse instance and maintains connections to all of its remote nodes.

Secondary instances are read-only. They may be used to view Lighthouse information specific to that
instance, and to connect to its nodes via pmshell. Configuration changes must be performed on the
primary instance, which will then update the information displayed on the secondary instance.

The multiple instance feature has the following limitations:

e Up to ten secondary instances can be enrolled.

e Multiple instance support is available starting with Lighthouse 5.3.

e Secondary Lighthouse instances are read-only. We recommended that you preconfigure instance
specific settings such as hostname, external endpoints, and time zone on a secondary instance
before adding it to the primary in a normal way through UI.

e Dependent Lighthouse instances must have zero nodes enrolled before being enrolled to the
primary Lighthouse.

e Removing a dependent Lighthouse instance will initiate a factory reset.

e If external endpoints on the primary or secondary Lighthouses are updated after a secondary
Lighthouse has been enrolled, it may break replication.

e Only Opengear nodes with a version that supports multiple instance will connect to the secondary
instance, which means CS 4.4.1, or later and NGCS 19.Q2.0 or later. Nodes that don't support
multiple instance will behave normally on the primary.

e The secondary instance Ul offers a limited display.

See Chapter 10 for specific information on using the multiple instance feature.
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3. Lighthouse VM installation

To host Lighthouse, the VM needs to be configured to support a T0GB SCSI disk. If you plan on running
NetOps Secure Provisioning or SDI/IP Access, you will need a second 120GB disk.

3.1 Lighthouse VM components

Lighthouse VM is available in several formats:

An Open Volume Format file — 1ighthouse-20.Q1.0-ov£. zip — inside a PKZip archive. This
is for use with virtual machine managers such as KVM and Virtual Box.

A VMware configuration file — 1ighthouse-20.Q1.0-vmx. zip —inside a PKZip archive. This is
for use with virtual machine managers from VMware.

Araw (.hdd) file, 1ighthouse-20.Q1.0-raw.hdd. tar. This file has been compressed with tar
and is for use with hosting services such as ElasticHosts.

An Open Virtual Appliance file — lighthouse-20.Q1.0.0ova. This is for use with virtual
machine managers such as VM and Virtual Box as well as for use with virtual machine managers
from VMware.

A Hyper-V configuration file with Powershell script — 1ighthouse-20.Q1.0-hyperv.zip —
inside a PKZip archive. This is for use in Microsoft Hyper-V deployment.

A Microsoft Azure file, Lighthouse-azure.zip for deploying on Azure.

An Amazon Web Services bootstrap shell script aws_bootstrap. sh for deploying on AWS.
An upgrade file, Lighthouse-20.Q1.0.1h_upg.

The optional 1lighthouse-nom.vhd file for NetOps.

NOTE: The NetOps disk is only required to run NetOps modules (including Secure Provisioning,
and IP Access) or to run a Docker container on Lighthouse. To install:

Upload the 1ighthouse-nom. vhd file for netops.

Go to images.

Create a new image.

Choose the boot disk by navigating to the storage explorer and selecting the
lighthouse. vhd disk image. Optionally add the netops disk under managed disks.

Mo~

3.2 VMware vSphere 6.0 via the VMware vSphere 6.0 client on Windows

This procedure assumes VMware vSphere 6.0 is installed and running on available hardware. User must
have access to a Windows computer on which the VMware vSphere 6.0 client is installed and that this
installed client application can connect to and manage the VMware Sphere 6.0 instance. Finally, a copy of
the Lighthouse binary in Open Volume Format is required, the . ov £ file, either copied to the Windows
computer running the VMware vSphere 6.0 client or available via a URL.

This procedure was tested using the VMware Sphere Client 6.0 running on Windows 7 Enterprise SP 1.
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3.2.1 Launch the vSphere Client and connect to a vSphere instance.

1.

Launch the VMware vSphere Client. The simplest way is to use the Start Menu shortcut added during
installation.

Start > All Programs > VMware > VMware vSphere Client

The VMware vSphere Client opens a login window.

[ VMware vSphere Client

vmware

VMware vSphere”

Client

[Q All vSphere features introduced in vSphere 5.5 and beyond are
available only through the vSphere Web Client. The traditional
vSphere Client will continue to operate, supporting the same
feature set as vSphere 5.0.

To directly manage a single host, enter the IP address or host name.
To manage multiple hosts, enter the IP address or name of a
vCenter Server.

IP address / Name: Iesxi LI

User name: ||

Password: |

™ Use Windows session credentials

Login Close

Select the IP address or name of the VMware vSphere instance where Lighthouse will be installed from
the IP address/Name drop-down list.

Enter the User name and Password required to gain management privileges to the selected VMware
vSphere instance.

Click Login or press Return.
The login window displays progress text in the bottom left corner:

Connecting

Loading inventory
Loading main form
Displaying main form

The vSphere main form window opens.

3.2.2 Import the Lighthouse VM Open Volume Format (. ovf) image

1.

From the vSphere Client menu bar, choose File > Deploy OVF Template.
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@ 57% Deploying Opengear Lighthouse VM

The Deploy OVF Template window appears, with the first stage, Source, pre-selected.

If the file Opengear Lighthouse VM.ovf is on a remote computer via a URL, enter this URL in the
Deploy from a file or URL field. Otherwise, click Browse. An Open dialog appears.

Navigate to the directory containing the file Opengear Lighthouse VM.ovf.
Select Opengear Lighthouse VM.ovf and click Open.

The Deploy OVF Template window opens again, with the Opengear Lighthouse VM.ovf file
listed in the Deploy from a file or URL combo-box. Click Next.

The OVF Template Details stage appears, showing basic information about the Lighthouse VM
encapsulated by the .ov £ file. Click Next.

The Name and Location screen appears with the Name field pre-populated and pre-selected.

The default name is Opengear Lighthouse VM. To change this, enter a new name. Click Next.

The Disk Format screen displays which data-store the Lighthouse VM'’s virtual disk uses, how much
free space the virtual disk has available and which provisioning scheme is being used. Click Next.
The Network Mapping screen shows which destination or inventory network the Lighthouse VM's
virtual network is mapped to. Click Next.

The Ready to Complete screen appears, listing the basic properties of the about-to-be-deployed
virtual machine. To be able to power-up the new virtual machine after deployment, select the Power
on after deployment checkbox. Click Finish.

The Deploying Opengear Lighthouse VM progress dialog appears.

Deploying Opengear Lighthouse VM

Deploying disk 1 of 1 from
C:\Users\Administrator \Documents\Ironman.ovf\Opengear Lighthouse
VM\Opengear_Lighthouse_VM-disk1.vmdk

INENNENNENENEEE

8 seconds remaining

[ Close this dialog when completed Cancel

10. Once deployment has finished the Deployment Completed Successfully alert appears. Click Close.

The new virtual machine is now deployed and appears in the inventory list.
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(=) esxi - vSphere Client

File Edit View Inventory Administration Plug-ins Help

iJ (_b Home D gf Inventory D Eﬂ Inventory
= [ |esxi

Opengear Lighthouse VM

eSSl

3.2.3 Launch the Opengear Lighthouse virtual machine

The vSphere Client provides several ways of launching a Virtual Machine hosted on a vSphere instance.
Begin by selecting the Opengear Lighthouse VM from the vSphere Client’s inventory list. The selected VM
can then be launched by doing one of the following:

e Select Inventory > Virtual Machine > Power > Power On.
Press Ctrl-B.

e Click the Power on the virtual machine link in the Basic Tasks section of the Getting Started tab.
This option requires the Getting Started tab be front-most. If it is not already the front-most tab,
make it active by clicking it.

e Select Inventory > Virtual Machine > Open Console and then:

o Click Power On in the console tool bar, or
o Choose VM > Power > Power On from the console menu bar, or
o Press Ctrl-B.

NOTE: Only the fourth option above results in the running virtual machine being accessible from within
the vSphere Client. The first three boot the Lighthouse VM and get it running headless.

3.2.4 Access the console of a running but headless Opengear Lighthouse instance

If direct interaction with a running but headless *Opengear Lighthouse VM* is required, open a console
window.
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Select the running Opengear Lighthouse VM in the vSphere Client's inventory list, then do one of the
following:

e Select Inventory > Virtual Machine > Open Console or
¢ Right-click and select Open Console from the contextual menu that appears.

NOTE: A Lighthouse VM is running a bash shell with no other interactive options. As a result, when the
vSphere Client opens its console window, the Lighthouse VM captures the mouse pointer, making it
unavailable for use by any other window. Press CTRL+ALT to release the pointer.

3.3 VMware Workstation Player on Windows as host

Follow these steps when VMware Workstation Player is installed on the host Windows machine. VMware-
ready virtual machine files are stored in C: \Users\%$USERNAME%\Virtual Machines\. Thisisthe
location selected by default by VMware Workstation Player. If another location is preferred, adjust this
procedure as required.

Prepare the Lighthouse VM file for import into VMware Workstation Player.

1. Move the lighthouse-20.Q1.0-vmx.zip archive to C: \Users\$USERNAME%\Virtual
Machines\.

Right-click the archive and select Extract all from the contextual menu.

A Select a Destination and Extract Files dialog opens. By default, the location is the same folder
as the archive isin: C: \Users\%USERNAME%\Virtual Machines\. Leave this as the
destination folder.

Uncheck the Show extracted files when complete checkbox and then click Extract.

A folder called 1ighthouse is created inside C:\Users\%USERNAME%\Virtual
Machines\.

W

o &

Import the Opengear Lighthouse VM file into VMware Workstation Player.

1. Launch VMware Workstation Player.
2. Click Open a Virtual Machine.
3. Navigateto C:\Users\$USERNAME%\Virtual Machines\lighthouse\.

VMware Workstation Player points to Libraries > Documents and includes
C:\Users\$USERNAME%\My Documents\.

Assuming this is the case, double-click virtual Machines and then double-click
Lighthouse.

4. If only one file — Lighthouse — is visible, double-click it to add the Lighthouse 2020.Q1.0 virtual
machine to the VMware Workstation 12 Player virtual machines list. If more than one file appears,
double-click Lighthouse.vmx.

5. The Lighthouse virtual machine is added to the VMware Workstation 12 Player virtual machines
list.

6. With Opengear Lighthouse VM selected in the VMware Workstation 12 Player virtual machine list,
click Play virtual machine to boot Lighthouse.
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3.4 VMware Workstation Pro on Windows as host

This procedure assumes VMware Workstation Pro is already installed on the host Windows machine and
that VMware-ready virtual machine files are stored in C: \Users\$USERNAME%\Virtual Machines\.
If another location is preferred, adjust the steps as needed.

Prepare the Opengear Lighthouse VM file for import into VMware Workstation Pro.

1. Movethe 1ighthouse-20.01.0.zip archiveto C:\Users\%USERNAME%\Virtual
Machines\.

2. Right-click the 1ighthouse-20.Q1.0-vmx. zip archive and select Extract all from the
contextual menu.

3. A Select a Destination and Extract Files dialog opens. The location is the same folder as the
PKZip archive isin: C: \Users\%USERNAME%\Virtual Machines\. Leave this as the
destination folder.

4. Uncheck the Show extracted files when complete checkbox and then click Extract.

5. Afolder called lighthouse is created inside C: \Users\%USERNAME%\Virtual Machines\.

Import the Opengear Lighthouse VM file into VMware Workstation Pro.

1. Click Open a Virtual Machine.

2. Navigateto C:\Users\$USERNAME%\Virtual Machines\lighthouse\.

3. VMware Workstation Pro points to Libraries > Documents and this library includes
C:\Users\%USERNAME%\My Documents\. Double-click virtual Machines and then
double-click Lighthouse.

4. If only one file — Lighthouse — appears, double-click it to add the Lighthouse 2020.Q1.0 virtual
machine to the VMware Workstation Pro virtual machines list. If more than one file appears,
double-click Lighthouse . vmx.

5. The Lighthouse 2020.Q1.0 virtual machine is added to the VMware Workstation Pro virtual
machines list.

6. With the Opengear Lighthouse VM selected in the My Computer listing and the subsequent
Opengear Lighthouse VM tab open, click Power on this virtual machine to boot Lighthouse.

3.5 VMware Workstation Player or Pro on Fedora Workstation as host

VMware Workstation Player 12 cannot be installed on Fedora 25 without substantial reconfiguration of a
base Fedora Workstation setup and leaves Fedora Workstation in a state that is unsupported by any
external entity.

Opengear does not support this particular combination of host operating system and virtual machine
manager.

3.6 Local deployment on Hyper-V running on Windows 10/Windows Server 2016

This procedure assumes Hyper-V is already installed on a Windows 10/Windows Server 2016 host
machine and the required Zip archive, i ronmam-hyperv.zip is
in C:\Users\%USERNAMES%S\Downloads.

1. Unzip lighthouse-hyperv.zip.
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2. Navigate to the extracted folder. Make sure 1ighthouse.vhd and
lighthouse virtual machine registration.psl are in the folder.
3. Right-click and choose Run with Powershell to execute the Powershell script.
Leave the host name empty when prompted to deploy Lighthouse to local machine.
Launch Hyper-V Manager. Lighthouse should be registered as a new VM image under Virtual
Machine.
6. Select Lighthouse from the list and click Start in the Action Panel to boot Opengear Lighthouse.

o &

3.7 Remote Hyper-V deployment with pre-authenticated user

In this scenario, the user who performs Lighthouse deployment does not have local access to Hyper-V
installed on Windows 2016. However, user has access to a Windows 10 which can manage the Hyper-V
server remotely.

This procedure assumes Hyper-V is installed on Windows Server 2016 host machine and the required Zip
archive 1ighthouse-hyperv.zipisin C:\Users\%USERNAMESS$\Downloads. Windows 10 is
already configured to manage Hyper-V on Windows Server 2016. Windows 10 and Windows Server 2016
must have the same user (same password) created. The user who performs the deployment must have
permission to both execute the Powershell script and deploy the image on Hyper-V.

1. Login to Windows 10 with the user mentioned above.

2. Unzip lighthouse-hyperv.zip

3. Navigate to the extracted folder. Make sure 1ighthouse.vhd and

lighthouse virtual machine registration.psl are in the folder.

Right-click and choose Run with Powershell to execute the Powershell script.

Enter the fully qualified domain name for Windows Server 2016 when prompted to deploy

Lighthouse to the remotely-managed Windows Server 2016 machine.

6. Launch Hyper-V Manager. Lighthouse should be registered as a new VM image under Virtual
Machine for Windows Server 2016.

7. Select Lighthouse from the list and click Start in the Action Panel to boot Opengear Lighthouse.

o &

3.8 Remote Hyper-V deployment with different user

In this scenario, the user who performs Lighthouse deployment does not have local access to Hyper-V
installed on Windows Server 2016. However, user has access to Windows 10 which can manage the
Hyper-V server remotely. The user who performs the deployment must have permission to both execute
the Powershell script and deploy the image on Hyper-V. This procedure assumes Hyper-V is installed on
Windows Server 2016 host machine and the required Zip archive, i ronmam-hyperv. zip, is

in C:\Users\%USERNAME%S$\Downloads. Windows 10 is already configured to manage Hyper-V on
Windows Server 2016.

1. Login to windows 10 with a user who does not exist on Windows Server 2016.

2. Unzip lighthouse-hyperv.zip.

3. Navigate to the extracted folder. Make sure 1ighthouse.vhd and

lighthouse virtual machine registration.psl are in the folder.

Right-click and choose Run with Powershell to execute the Powershell script.

Enter the fully qualified domain name for Windows Server 2016 when prompted to deploy

Lighthouse to remotely -managed Windows Server 2016 machine.

6. Enter the user details created on Windows Server 2016 which has permission to deploy Hyper-V.

7. Launch Hyper-V Manager. Lighthouse should be registered as a new VM image under Virtual
Machine for Windows Server 2016.

8. Select Lighthouse from the list and click Start in the Action Panel to boot Opengear Lighthouse.

o &
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3.9 VirtualBox on Windows as host

NOTE: when a Skylake processor is available, we do not recommend the use of VirtualBox.

NOTE: We recommend that VirtualBox users customize their instances and change their network cards to
one other than e1000. We also suggest virtio for better performance.

This procedure assumes VirtualBox is already installed on the host machine and the required PKZip
archive, 1ighthouse-20.Q01.0-ovf.zipisin C:\Users\%USERNAME%$\Downloads.

16.
17.
18.
19.
20.

21.
22.

23.
24.
25.

26.
27.
28.

Unzip 1ighthouse-ovf. It may appear as 1ighthouse-20.Q1.0-ovf.zip depending on the
Windows Explorer preference settings).

Right-click the 1ighthouse-ovf archive and select Extract all from the contextual menu.

The Select a Destination and Extract Files dialog opens. The destination is
C:\Users\%USERNAMES%\Downloads\Lighthouse-ovf.

Uncheck the Show extracted files when complete checkbox and edit the destination by removing
Lighthouse-ovf from the path.

Click Extract.

A folder called 1ighthouse-ovf is created inside C:\Users\%USERNAMES\Downloads\ .
Launch VirtualBox.

The Oracle VM VirtualBox Manager window appears.

Choose File > Import Appliance.

. The Appliance to import dialog opens.

. Click Expert Mode.

. The Appliance to import dialog changes from Guided Mode to Expert Mode.

. Click the icon of a folder with an upward pointing arrow superimposed. This icon is to the far right

of the Appliance to import field.

. The Open File dialog appears with C: \Users\%USERNAME%\Documents as the current folder.
. Navigate to C: \Users\$USERNAME%\Downloads\Lighthouse.ovf\Opengear

Lighthouse VM\.

Select the file Opengear Lighthouse VM and click Open.

Double-click the text vm in the Name row and Configuration column to make it editable.

Type Opengear Lighthouse VM and press Enter.

Click Import.

A new virtual machine, called Opengear Lighthouse VM is added to the list of virtual machines
available to Virtual Box.

Select Opengear Lighthouse VM from the list.

Choose Machine > Settings. Or click the Settings icon in the VirtualBox Manager toolbar or press
Control+S.

The Opengear Lighthouse VM — Settings dialog appears.

Click the System option in the list of options running down the left-hand side of the dialog.

The dialog shows the System options available as three tabs: Motherboard, Processor, and
Acceleration. Depending on the underlying hardware platform, Acceleration may be greyed-out
and unavailable. The Motherboard tab is preselected.

In the Motherboard tab, select the Hardware Clock in UTC Time checkbox.

Click OK or press Return.

Select Opengear Lighthouse VM from the list and click Start in the Oracle VM VirtualBox
Manager toolbar to boot Lighthouse. Double-clicking Opengear Lighthouse VM in the list also
boots Lighthouse.
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NOTE: Selecting the Hardware Clock in UTC Time checkbox is necessary because Lighthouse
expects the hardware clock to be set to UTC, not local time. Unlike other Virtual Machine
Managers, Virtual Box both exposes this option as a user-adjustable setting and does not set it to
UTC by default.

3.10 VirtualBox on macOS as host

VirtualBox should already installed on the host macOS machine and the required PKZip archive,
lighthouse-20.Q1.0-ovf.zipisin ~/Downloads.

1. Unzip lighthouse-20.Q1.0-ovf.zip.

This creates a folder — Lighthouse-ovf —in ~/Downloads that contains the following files
and folders:

Lighthouse-ovf
L — Opengear Lighthouse VM
t:: Opengear Lighthouse VM.ovf
Opengear Lighthouse VM-diskl.vmdk

2. Launch Virtual Box.

The Oracle VM VirtualBox Manager window appears.

Choose File > Import Appliance or press Command+I.

The Appliance to import dialog sheet slides down from the Oracle VM VirtualBox Manager

toolbar.

5. Click Expert Mode.

The Appliance to import dialog sheet changes from Guided Mode to Expert Mode.

6. Click the icon of a folder with an upward pointing arrow superimposed. This icon is to the far-right
of the Appliance to import field.

7. The Open File dialog sheet slides down from the Oracle VM VirtualBox Manager toolbar. This
sheet opens with ~/Documents as the current folder.

8. Navigateto ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/.

9. Select Opengear Lighthouse VM and click Open. (Depending on the Finder Preferences
settings, the file may present as Opengear Lighthouse VM.ovf.)

10. Double-click the text vm in the Name row and Configuration column to make it editable.

11. Type Opengear Lighthouse VM and hit Return.

12. Click Import.

A new virtual machine, called Opengear Lighthouse VM is added to the list of virtual machines.

13. Select Opengear Lighthouse VM from the list.

14. Choose Machine > Settings. Or click the Settings icon in the VirtualBox Manager toolbar. The
Opengear Lighthouse VM — Settings dialog appears.

15. Click the System option in the dialog’s toolbar.

16. The dialog shows the System options available as three tabs: Motherboard, Processor, and
Acceleration. (Depending on the underlying hardware platform, Acceleration may be greyed-out
and unavailable). The Motherboard tab is preselected.

17. In the Motherboard tab, select the Hardware Clock in UTC Time checkbox.

18. Click OK or press Return.

19. Select Opengear Lighthouse VM from the list and click Start in the Oracle VM VirtualBox
Manager toolbar to boot Lighthouse. Double-clicking Opengear Lighthouse VM in the list also
boots Lighthouse.

o
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NOTE: Selecting the Hardware Clock in UTC Time checkbox is necessary because Lighthouse
expects the hardware clock to be set to UTC, not local time. Unlike other Virtual Machine Managers,
Virtual Box both exposes this option as a user-adjustable setting and does not set it to UTC by

default.

NOTE: By default, VirtualBox stores virtual machines in ~/vVirtualBox VMs. If this is the first virtual
machine setup by VirtualBox, it creates the virtualBox VMs folder in the current user's home-
directory and a folder — Opengear Lighthouse VM — inside the virtualBox VMs folder. The
Opengear Lighthouse VM folder contains the files and folders which make up Lighthouse when
run under Virtual Box.

3.11 VirtualBox on Ubuntu as host

Before beginning, make certain that VirtualBox and all required support files are installed on the host
machine and the PKZip archive, 1ighthouse-20.Q1.0-ovf.zipisin ~/Downloads.

1.

Unzip 1ighthouse-20.0Q1.0-ovf.zip

This creates a folder — Lighthouse-ovf —in ~/Downloads that contains the following files
and folders:

©ONoAWN

©

10.
11.
12.
13.
14.
15.

16.

Lighthouse-ovf
L — Opengear Lighthouse VM
t:: Opengear Lighthouse VM.ovf
Opengear Lighthouse VM-diskl.vmdk

Launch Virtual Box.

The Oracle VM VirtualBox Manager window appears.

Choose File > Import Appliance.

The Appliance to import dialog opens.

Click Expert Mode.

The Appliance to import dialog changes from Guided Mode to Expert Mode.

Click the icon of a folder with an upward pointing arrow superimposed. This icon is to the far
right of the Appliance to import field.

A file-navigation dialog, Choose a virtual appliance to import, opens with ~/Documents as
the current folder.

Navigate to ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/.

Select Opengear Lighthouse VM.ovf and click Open.

Double-click the text vm in the Name row and Configuration column to make it editable.
Type Opengear Lighthouse VM and hit Return.

Click Import.

A new virtual machine, called Opengear Lighthouse VM is added to the list of virtual
machines available to Virtual Box.

Select Opengear Lighthouse VM from the list and click Start in the Oracle VM VirtualBox
Manager toolbar to boot Lighthouse. Double-clicking Opengear Lighthouse VM in the list also
boots Lighthouse.

NOTE: VirtualBox stores virtual machines in ~/vVirtualBox VMs. If this is the first virtual machine
setup by VirtualBox it creates the virtualBox VMs folder in the current user's home-directory and a
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folder — Opengear Lighthouse VM —inside the VirtualBox VMs folder. Inside Opengear
Lighthouse VM are the files and folders which make up Lighthouse when run under Virtual Box.

3.12 VirtualBox on Fedora Workstation as host

Before beginning, make certain that VirtualBox and all required support files are already installed on the
host machine and the PKZip archive, 1ighthouse-20.Q1.0-ovf.zipisin ~/Downloads.

1. Unzip lighthouse-20.Q1.0-ovf.zip. This creates a folder — Lighthouse.ovf —in
~/Downloads that contains the following files and folders:

Lighthouse.ovf
L — Opengear Lighthouse VM
t:: Opengear Lighthouse VM.ovf
Opengear Lighthouse VM-diskl.vmdk

2. Launch Virtual Box.
The Oracle VM VirtualBox Manager window appears.
3. Choose File > Import Appliance or press Control-I.
The Appliance to import dialog opens.
4. Click Expert Mode.
The Appliance to import dialog changes from Guided Mode to Expert Mode.
5. Click the icon of a folder with an upward pointing arrow superimposed. This icon is to the far
right of the Appliance to import field.
The Open File dialog opens with ~/Documents as the current folder.
Navigate to ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/.
Select Opengear Lighthouse VMand click Open.
Double-click the text vm in the Name row and Configuration column to make it editable.
Type Opengear Lighthouse VM and hit Return.
0. Click Import.
A new virtual machine, called Opengear Lighthouse VM is added to the list of virtual
machines available to Virtual Box.
11. Select Opengear Lighthouse VM from the list and click Start in the Oracle VM VirtualBox
Manager toolbar to boot Lighthouse. Double-clicking Opengear Lighthouse VM in the list also
boots Lighthouse.

S PN

NOTE: VirtualBox stores virtual machines in ~/vVirtualBox VMs. If this is the first virtual machine setup
by VirtualBox, it creates the virtualBox VMs folder in the current user’'s home-directory and a folder —
Opengear Lighthouse VM —inside the VirtualBox VMs folder. Inside Opengear Lighthouse
VM are the files and folders which make up Lighthouse when run under Virtual Box.

3.13 Virtual Machine Manager (KVM) on Ubuntu as host

Virtual Machine Manager and all required support files should be installed on the host machine and the
the . tar archive, 1ighthouse-20.Q1.0-raw.hdd.tar isin ~/Downloads.

1. Expand lighthouse-20.Q1.0-raw.hdd.tar. This extracts 1ighthouse-20.Q1.0-
raw.hdd in ~/Downloads.
2. Launch Virtual Machine Manager.
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Click New at the top left of the Virtual Machine Manager window (or choose File > New Virtual
Machine). The Source Selection window opens.

Click Select afile. A Select a device or ISO file dialog slides into view.

Navigate to ~/Downloads/ .

Select the file 1ighthouse-20.Q1.0-raw.hdd and click Open in the top right-hand corner of
the dialog. A Review window opens providing basic information about the virtual machine or box,
as Boxes calls them, to be created.

Click Create in the top right corner of the Review window.

A new virtual machine instance, Opengear_Lighthouse_VM-disk1, is created and presented in the
Boxes window.

To rename the virtual machine instance, right-click on the machine instance and choose
Properties from the contextual menu that appears. Click anywhere in the Name field to select and
edit the name. Click the close box to save the changes.

3.14 Boxes on Fedora Workstation as host

Boxes and all required support files should be installed on the host machine and 1ighthouse-
20.Q01.0-ovf.zipisin~/Downloads.

1.

ocoukrwnN

© N

Unzip 1ighthouse-20.Q1.0-ovf.zip. This creates a folder — Lighthouse.ovf —in
~/Downloads that contains the following files and folders:

Lighthouse.ovf
L — Opengear Lighthouse VM
t:: Opengear Lighthouse VM.ovf
Opengear Lighthouse VM-diskl.vmdk

Launch Boxes.

Click New in the Boxes window title bar. The Source Selection window opens.

Click Select afile. A Select a device or ISO file dialog opens.

Navigate to ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/.

Select the file Opengear Lighthouse VM-diskl.vmdk and click Open in the top right-hand
corner of the dialog. A Review window opens providing basic information about the virtual
machine (or ‘box’, as Boxes calls them) to be created

Click Create in the top right corner of the Review window.

A new virtual machine instance, Opengear_Lighthouse_VM-disk1 is created and presented in the
Boxes window.

To rename the virtual machine instance, right-click on the machine instance and choose
Properties from the contextual menu that appears. Click anywhere in the Name field to select and
edit the name. Click Close to save the changes.

3.15 Boxes on CentOS as host

CentO0S should be installed, complete with the Gnome desktop environment as the host operating system.
CentO0S includes the full complement of KVM-centric virtualization tools including the GUI-based
virtualization management tools Boxes and virt-manager and the shell-based virtualization management
tool virsh.

This procedure assumes Boxes is used to setup and manage the Lighthouse VM and that the required
PKZip archive, 1ighthouse-20.Q1.0-ovf.zipisin ~/Downloads.
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1. Unzip 1ighthouse-20.Q1.0-ovf.zip

This creates a folder — Lighthouse.ovf —in ~/Downloads that contains the following files
and folders:

Lighthouse.ovf
L — Opengear Lighthouse VM
t:: Opengear Lighthouse VM.ovf
Opengear Lighthouse VM-diskl.vmdk

Launch Boxes

Click New in the Boxes title bar.

Navigate to ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/

Select Opengear Lighthouse VM and click Open. A new virtual machine, called Opengear
LighthouseVM is added to the list of virtual machines available to Boxes.

arwON

3.16 Azure environment

To

LN =

SO PN O

12.
13.
14.

15.
16.
17.

18.

19.

use the Microsoft Azure environment:

Login to the Microsoft Azure portal at https://portal.azure.com

Under Azure services click the Storage Accounts icon.

Create a new storage account.

Navigate to the newly created storage account, click storage explorer and create a new blob
container.

Upload the 1ighthouse.vhd image provided with the 1ighthouse-azure.zip file.

Go to the newly created image and click Create VM.

Ensure the selected image is correct.

Choose the desired virtual machine instance size.

Enter the details for the Microsoft Azure admin user with either password OR SSH key authentication.

. If SSH key authentication is selected, the user will be created without a password and will be unable

to access the Ul.

. To login to the Lighthouse Ul, the user must then login via SSH with key authentication and configure

their password using the ogpasswd utility (eg. sudo ogpasswd -u 'username' -p 'newpassword’).
Login via SSH with a password will remain disabled for this user.
Select the inbound ports enabled for the Lighthouse instance (SSH, HTTPs, and optionally HTTP).
Navigate to the next page of configuration (Disks) and select the desired storage option for the boot
disk.
Go to the Review page.
After validation passes, click Create.
Go to the Virtual Machines page, select the virtual machine and open the Serial Console. Lighthouse
should now be deploying on Microsoft Azure.
To allow nodes to enroll in Lighthouse, you will need to add the following firewall rules in the
Microsoft Azure virtual machine control panel:
a. Go to the virtual machine configuration and select Networking.
b. Add arule to allow UDP connections from any source to port 1194 on the instance's internal
network address (10.0.0.x).
c. Add arule to allow UDP connections from any source to port 1195 on the instance's internal
network address (10.0.0.x).
d. HTTPs and SSH should already be allowed from the initial setup If not, add them.
Confirm that the Azure instance public IP address has been added to external endpoints in Settings >
Administration.
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3.17 Amazon Web Services (AWS) environment

To use Lighthouse with AWS, you will need to create an account, create an AWS EC2 instance, and create
an Amazon Machine Image. You will need to spin up a standard AWS EC2 instance with 30 gigs or more
of disk space to ensure there is enough room for the necessary operations.

To use the AWS environment, you will need to complete several steps. Visit AWS Help for assistance in
completing the following steps:

Sign Up for AWS

Create an IAM User.

Create a Key Pair

Connect to your instance using your key pair
Create a Virtual Private Cloud (VPC)

Create a Security Group

ocurwWN =

Launch a Linux build-box instance

We do not have a public AMI. You will need to launch a Linux build-box instance in order to create a
Lighthouse AMI. This is a one-time procedure, as once Lighthouse is running, you can upgrade it from the
Lighthouse Web GUI.

We have a compressed binary image and a script. On the first deployment of Lighthouse you do need to
spin up a Linux host in EC2 to use as a “build-box”, upload the Lighthouse raw image, untar it, then run the
Lighthouse aws-bootstrap script, which creates a private AMI. You can then use this to launch one or
more Lighthouse instances.

Using the AWS Management Console:

1. Open the Amazon EC2 console at https://console.aws.amazon.com/ec2/.

2. From the console dashboard, click Launch Instance.

3. The Choose an Amazon Machine Image (AMI) page displays a list of basic configurations that
serve as templates for your instance.

4. Onthe Choose an Instance Type page, click the hardware configuration of your instance.

NOTE: You'll need to choose at least a medium-sized image or larger.

5. Click Review and Launch to let the wizard complete the other configuration settings for you.

6. On the Review Instance Launch page, under Security Groups, the wizard created and selected a
security group for you. You can use this security group, or you can select the security group that
you created when getting set up using the following steps:

a. Choose Edit security groups.

b. On the Configure Security Group page, ensure that Select an existing security group is
selected.

c. Select your security group from the list of existing security groups, and then click Review
and Launch.

7. On the Review Instance Launch page, choose Launch.

When prompted for a key pair, select Choose an existing key pair, then select your key pair.
NOTE: Don't select Proceed without a key pair. If you launch your instance without a key pair,
then you can't connect to it.
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8. Click View Instances to close the confirmation page and return to the console.
Launch Lighthouse VM Instance

1. Click the acknowledgement check box, and then choose Launch Instances.
2. It can take a few minutes for the instance to be ready so that you can connect to it. Check that
your instance has passed its status checks in the Status Checks column.

Upload Lighthouse software to the build-box and run script to create the AMI
After creating the AWS EC2 instance:

Locate the aws_bootstrap.sh script, provided in the current Lighthouse release folder.
Connect via SCP and copy aws_bootstrap.sh onto the AWS EC2 instance.

While SSHed to your instance on AWS, run the built in aws configure command.
Provide an access key with administrative privileges.

Sl N

NOTE: At a minimum, the access key sufficient permissions to create, attach, delete, and snapshot EBS
volumes as well as create an Amazon Machine Image (AMI).

5. Download the Lighthouse image from the Opengear FTP site.
6. Copy the raw_hdd image to the AWS EC2 instance and untar the file. Optionally, you can untar
and then copy the file.

7. From AWS, run the aws_bootstrap. sh script with the appropriate parameters to tell it where to
find the untarred Lighthouse image on the instance.

NOTE: aws-bootstrap.sh creates an AMI from a Lighthouse image and has the following options:
-f FILENAME Use the specified local file to create the image

-r URI Download the image file from the specified URI

-d DEVICE Attach temporary disk images to the specified device (eg, xvde)

-n NAME The name to use for generated images (default: Lighthouse)

-h Display help message

8. When complete, you'll have an AMI called Lighthouse you can use to create a Lighthouse
instance with any hardware configuration you require.
9. To set a password for the root user on Lighthouse:

a. Open the Configure instance details page of the AMI launch process.
b. Under the Advanced Details section, add a root password using the userdata field in the
format password=Whatever123. If you do not, you will have to log in via SSH to set it.

NOTE: Optionally, you can specify a custom startup script in the Advanced Details
section with script_uri=http://my.domain/my_script.sh. This script will be run once on first
boot. Different user options should be provided on separate lines.

10. When done, the EC2 instance can be shut down and removed. Future instances can be created
from the AMI.

NOTE: Currently AWS support is limited to:
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All standard Lighthouse operations

Running on the AWS platform

Providing aws-cli tools for interaction with AWS
Loading the provided SSH key for the root user
Running custom scripts on startup (see above)
Providing a root password via userdata (see above)

At this time we do not support:

e Using AWS's database services
e Using AWS's redis services
e Using any of AWS's scalability functionality

NOTE: boot up is headless, so most of the information in section 4. First boot of the Lighthouse
VM does not apply. The root password must be specified in the Advanced Details.
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4. First boot of the Lighthouse VM

NOTE: This section does not apply to Azure or AWS.
During boot, two screens open.
1. The first notes the VM is Booting to latest installed image.

The selected image is Lighthouse Root 1. Two other images are available: Lighthouse Root 1 and
Root 2. Do not change the boot image the VM boots from.

2. The second screen prompts to Select Lighthouse boot mode and displays four options:

Graphics console boot

Graphics console recovery mode
Serial console boot

Serial console recovery mode

Graphics console boot is preselected and should not be changed. After the first boot has
completed a message appears:

Welcome to Lighthouse. This is software version:
2020.01.0

3. Thefinal step in the initial setup appears:

To complete initial setup, please set a new root password.
Press ENTER to continue.

4. After pressing Enter, a prompt appears:

Enter new root password:

5. Enter a password and press Enter. Keep in mind that non-US-English keyboards are not supported
in the graphics console.

NOTE: We recommend you set a temporary password at this point and change it to a very strong high-
entropy password as soon as possible using the WebUI.

6. The confirm prompt appears:
Confirm given password

7. Re-enter the password and press Enter. Multiple configuration notices appear ending with a login
prompt:

lighthouse login:
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8. Enter root and press Enter. A password prompt appears:
Password:

1. Enter the newly-set password and press Enter. A standard bash shell prompt appears with the list
of static, DHCP, and IPv6 addresses.

netl 192.168.0.1/24
netl:dhcp 192.168.1.186/24
netl fe80::a00:27ff:fe39:daa3/64

root@lighthouse: ~#
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5. Initial system configuration

5.1 Lighthouse IP addressing
When the Lighthouse VM is booted and running, it can be reached at:

e The static address, 192.168.0.1, or

e The address it is assigned by any DHCP server it finds. Type ifconfig command to see which IP
address the VM has been allocated by DHCP.

e Static IP address on another subnet, requiring IP address, mask, gateway set using ogconfig-cli
commands.

Only the first two options are available out-of-the-box. The static IP on another subnet has to be
configured first.

If there is no DHCP and Lighthouse is not reachable on the default address 192.168.0.1 then the static IP
address can be changed from the console using the ogsetnetwork.sh command.

root@lighthouse:~# ogsetnetwork.sh --help

Usage: ogsetnetwork.sh [Use options below to configure a static IP]

-a, --address Static IP address to set
-n, --netmask Netmask for IP address
-g, --gateway Network gateway address
-d, --dnsl Chosen DNS server #1

-D, --dns2 Chosen DNS #2

Example:

ogsetnetwork.sh -a 192.168.1.24 -n 255.255.255.0 -g 192.168.1.1

Tip: Type ogset<tab> and tab completion will give you the full command.

5.2 Loading Lighthouse

Open a new browser window or tab and enter:

1. https://192.168.0.1/,https://[DHCP-supplied address]/, Oran|IPv6

address, for example: https://[fe80::a00:27ff:fe39:daa3/64].
2. Press Return. The Lighthouse Login page loads.
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Q opengear
Lighthouse™ Central Management

LIGHTHOUSE LOGIN

Username

root

Password

-------

©® Opengear 2020 | Customer Support

5.3 Login to Lighthouse
To login to Lighthouse:

1. Enter a username in the Username field. The first time you log in, the Username will be root.
2. Enter the password in the Password field.
3. Click Log In or press Enter. The Dashboard loads.

When you log in, you will see a few standard Lighthouse interface elements including:

e The primary menu options MONITOR, MANAGE, CONFIGURE, and SETTINGS on the left.

e Alight/dark mode toggle switch on the bottom left of the interface. This control allows you to
modify the appearance of Lighthouse for low lighting situations.

e System menu options Add Node, Help, System, and Log Out on the top right.s

The elements that appear on the Dashboard page depend on the privileges granted to the currently
logged in user.



31
Lighthouse User Guide

\\( opengear ©AddNode @Help O System 3 Logout

Ughthouse™ Central Management

(Z) moNTor DASHBOARD
Dashboard CURRENT NODE STATUS LICENSING INFORMATION
£ mANAGE

=
Number of Installed Licenses: 1

T Disconnected: 1 Connected: 1

= Number of Supported Nodes: 2 / 25

o
COpRSELINGS Number of Supported NetOps Secure Provisioning Nodes: 0 / 0

Number of Supported NetOps Software-Defined Infrastructure Nodes: 0 /
0

Expiry Date: Nov 11, 2023
Pending: 4 Status: In Compliance

Enabled Features: Multiple Lighthouse Support

ENROLLED NODES

Name Status Actions

test Disconnected,
Last status change 11 hours ago

platypus Connected,
Last status change 20 minutes ago

For root users, the Dashboard displays Enrolled Nodes, Cellular Health Status, Current Node Status, and
Licensing Information.

Cellular Health is clickable and will take you to the MANAGE > NODES > Node Web Ul page where you
can view the Cellular Health column with information on each node.

Current Node Status is clickable. Nodes may be Connected, Disconnected, or Pending.

Current Node Status

Disconnected: 1
Connected: 2

Pending: 1

Clicking on:

¢ Pending opens Configure > NODE ENROLLMENT > Pending Nodes
e Connected opens Manage > NODES > Node Web Ul filtered to show only connected nodes
¢ Disconnected opens Manage > NODES > Node Web Ul filtered to show only disconnected nodes

NOTE: The appearance of the Dashboard, the Sidebar, and other Lighthouse pages depends on the
privileges assigned to the logged-in user. In this guide, screenshots represent what the root user sees.
Users with different privileges will see filtered views of available nodes, managed devices, users, groups,
tags, and Smart Groups have different privileges regards creating and changing settings within
Lighthouse.
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5.4 Network connections

To see the network connections available to Lighthouse, select SETTINGS > NETWORK CONNECTIONS >
Network Interfaces

% °P¢n$)¢°f ® Add Node @ Help © System 2] Log out

Lighthouse™ Central Management

) MONITOR NETWORK INTERFACES

MANAGE

A Editing these settings may break connectivity

[Z] conricure

<P serTines Name Type Details Status Actions
e —— default-conn-1 Ethernet 1Pva Static Enabled and running Edit
wo! 192.168.0.1/24

Network Interfaces default-conn-2 Ethernet IPv4 DHCP Enabled and running Edit
B 192.168.1.186/24
USER MANAGEMENT

default-conn-3 Ethernet 1Pv6 Automatic Enabled and starting Edit

SERVICES Unavailable

DATE & TIME

SYSTEM

© Opengear 2020 | Customer Support

This displays three connections: static and DHCP IPv4 interfaces and by default, an automatic IPv6
connection.

To edit a given network interface:

Select SETTINGS > NETWORK CONNECTIONS > Network Interfaces
Click Edit in the Actions section of the network interface to be modified.
Make the desired changes.

Click Apply.

LN =

\\( opengear @®AddNode @Help O System 3 Logout
Lighthouse™ Central Management
MONITOR CONNECTION DETAILS
MANAGE
Enabled
CONFIGURE Description @
Q’D SETTINGS 1Pv4 DHCP network connection
NETWORK CONNECTIONS Connection Type ®
Network Interfaces IPv4 DHCP M
USER MANAGEMENT
e=mE IPV4 DHCP
DATE & TIME No configuration is necessary for IPv4 DHCP addressing.

SYSTEM

MEDIA SETTINGS

Media @

Automatic "

Cancel m
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NOTE: Don't change the configuration method. Instead, disable the interface which will not be
used by unchecking the Enabled checkbox. If default-static and default-DHCP are changed to the
same configuration method (i.e. both are set to Static assignment or both are set to DHCP)
neither interface works.

5.5 Setting the Lighthouse hostname
To set the hostname for a running Lighthouse instance:

1. Select SETTINGS > SYSTEM > Administration.
2. Edit the Hostname field as required.

@ AddNode @Help O System 2 Logout

Lighthouse™ Central Management

7) MONITOR ADMINISTRATION

MANAGE SETTINGS

2] conFiGURE
=

Hostname @

]
(%4} SETTINGS lighthouse
NETWORK CONNECTIONS
SSH Port @
USER MANAGEMENT
22

External Network Addresses

Multi-Instance
API Port VPN Port VPN Port
Order Address (defout: 443) (defaut: 1194) (defautt: 1195)

192.168.1.186 443 1194 1195 -

External IP addresses or DNS names of the system

Apply

System Upgrade

o am © Opengear 2020 | Customer Support

3. Click Apply.

5.6 Adding external IP addresses manually (optional)

Adding a Lighthouse instance’s external IP address or addresses to a Lighthouse instance’s configuration
is an optional step.

To add a single external address:

1. Select SETTINGS > SYSTEM > Administration.
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\\, opengear ®AddNode @Help O System 3 Logout

Lighthouse™ Ci

entral Management

ADMINISTRATION

SETTINGS

Hostname @

lighthouse

NETWORK CONNECTIONS

USER MANAGEMENT

SERVICES

Licensing
Configuration Ba
Configuration Re:

System Upgrade

2.
3.

SSH Port @
22
External Network Addresses

Multi-Instance
API Port VPN Port VPN Port
Order Address (default: 443) (defautt: 1194) (default: 1195)

192.168.1.186 443 1194 1195 -

External IP addresses or DNS names of the system.

store

© Opengear 2020 | Customer Support

In the Address field of the External Network Addresses section, enter an IP address.

(Optional step) Change the API Port, VPN Port or both, if the ports used on the entered IP address
are different from the default (443 and 1194, respectively).

Click Apply.

To add further external addresses to a Lighthouse instance’s configuration:

-_—

o &

To chan

1.

2.

If extern

Click the + button. A second row appears in the External Network Addresses section.

In the Address field, enter an IP address.

(Optional step) Change the API Port, VPN Port, or both, if the ports used on the entered IP
address are different from the default (443 and 1194, respectively).

Add further IP addresses as required by repeating the steps above.

Click Apply.

ge the order in which manually added IP addresses are sent to remote nodes:

Click the up and down arrows in the Order column to change the order in which the IP addresses
are listed.

The presented order reflects the order in which these addresses are sent out.

Click Apply.

al IP addresses are manually added to a Lighthouse configuration, these addresses are sent to a

remote node during enroliment. If no external IP address is manually added, default external IP addresses
are used.

The external IP addresses are sent to a remote node during enrollment in the following order:

1.
2.
3.

netl:dhcp
netl:staticl
The IP address connected to the default gateway.
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5.7 Setting the Lighthouse internal clock

To set the time zone:

1. Select SETTINGS > DATE & TIME > Time Zone.
2. Select the Lighthouse instance’s time-zone from the Time Zone drop-down list.
3. Click Apply.

§ opengear © Add Node

Lighthouse™ Central Management

@Help @ system 2 Logout

7) MoNITOR TIME ZONE

MANAGE SETTINGS
E CONFIGURE
= Time Zone @
B
P SETTINGS uTe
NETWORK CONNECTIONS v
USER MANAGEMENT Pacific/Wallis m
PRC
SERVICES
PST8PDT
DATE & TIME ~ ROC
ROK
uct

Time Zone

To set the correct time and date, either:

1. Select SETTINGS > DATE & TIME > Manual Settings.
2. Enter the current Date and Time.
3. Click Apply.

@Help @ sSystem B Logout

Q opengear ® Add Node

Lighthouse™ Central Management

MONITOR MANUAL SETTINGS

CCURRENT LIGHTHOUSE TIME: 00:07 FEB 06, 2020
&‘:’» MANAGE

=1 SETTINGS

[2] conricure

=

P seTTNGS Date @

NETWORK CONNECTIONS 2020 February 1
USER MANAGEMENT Time ®

SERVICES 0 P

Manual Settings

or

Select SETTINGS > DATE & TIME > Automatic Settings.

Click the Enabled checkbox.

Enter a working NTP Server address in the NTP Server Address field.
Click Apply.

ML=
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) opengear © Add Node

Lighthouse™ Central Management

@Help @ System 2 Logout

MONITOR AUTOMATIC SETTINGS
=5 MANAGE NTP SETTINGS
[; oAl Enabled
P seTTiNGs
REMOTE NTP SERVER LIST
NETWORK CONNECTIONS
USER MANAGEMENT NTP Server Address
SERVICES 0.pool.ntp.org| -
DATE & TIME
Automatic Settings

Manual Settings

Time Zone m

5.8 Examine or modify the Lighthouse SSL certificate

Lighthouse ships with a private SSL Certificate that encrypts communications between it and the
browser.

To examine this certificate or generate a new Certificate Signing Request, select SETTINGS > SERVICES >
HTTPS Certificate. The details of the Current SSL Certificate appear.

Below this listing is a Certificate Signing Request form, which can be used to generate a new SSL
certificate.

\\' opengear ®AddNode @Help O System  5) Logout

Lighthouse™ Central Management
e CERTIFICATE SIGNING REQUEST

USER MANAGEMENT
Common Name @
SERVICES

Cellular Health Reporting

Organizational Unit @

Console Gateway

HTTPS Certificate

Lighthouse VPN Organization @

Node Backup Locality/City @

Session

State/Provice @
SNMP Service
Syslog

DATE & TIME Country @

SYSTEM United States

5.9 Examine or modify Lighthouse Session Settings
To modify Web and CLI session settings select SETTINGS > SERVICES > Session Settings.

e Web Session Timeout: This value can be set from 1 to 1440 minutes.
e CLI Session Timeout: This value can be set from 1 to 1440 minutes or set it to 0 to disable the
timeout. Changes take effect the next time a user logs in via the CLI.
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¢ Enable additional enroliment-only REST API port: This port defaults to 8443. When this option is
enabled, only /nodes endpoint is accessible via port 8443(GET/POST/PUT) and all other
endpoints return a 404 Not Found error. Enabling this API allows users who are using NAT for the
Lighthouse to expose an external port publicly only for nodes that are attempting to enroll to the
Lighthouse, and not for the other functionality available from the REST API. After this option is
disabled, all endpoints should be accessible as per normal usage.

@ Help

§ opengear ® AddNode

Lighthouse™ Central Management

© system  2J Log out

MONITOR SESSION SETTINGS

MANAGE SETTINGS

E CONFIGURE N
= Web Session Timeout @

o
P seTTINGs 2

NETWORK CONNECTIONS
CLI Session Timeout @

USER MANAGEMENT o

SERVICES
Enable additional enroliment-only REST API port ]

Cellular Health Reporting

Con: Gateway
HTTPS Certificate
Lighthouse VPN

Modules

Session Settings

5.10 Examine or change the MTU of the Lighthouse VPN tunnel

The MTU setting can be configured for traffic that is travelling through the Lighthouse VPN in an attempt
to solve MTU path discovery problems. To examine the MTU of the Lighthouse VPN tunnel, or to modify it,
select SETTINGS > SERVICES > LIGHTHOUSE VPN. Allowed values are between 1280 and 1500.

Q opengear ® Add Node

Lighthouse™ Central Management

@Help © System ) Log out

7) MONITOR LIGHTHOUSE VPN

bt Editing these settings wil interrupt node connections, it may take a few minutes for them to be restored

[Z] conricure
=

é& SETTINGS SETTINGS

NETWORK CONNECTIONS v VPN Network Range

Address space CIDR Subnet Mask Calculated Node capacity Actions
USER MANAGEMENT
8190

SERVICES 192.168.128.0 19 o

Cellular Health Reporting
Tunnel MTU @

1400

Lighthouse VPN

5.11 Enable or modify SNMP Service
Administrative users can configure SNMP settings under SETTINGS > SERVICES > SNMP Service.

Lighthouse supports both v1/v2 and v3 SNMP versions, which can be running at the same time. The
SNMP service is not enabled by default and starts once it has been configured correctly. If the user does
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not provide an enginelD, the auto-generated ID coming out of snmpd are displayed. Only standard
enterprise MIBs can be used currently, Lighthouse Health statistics (load/uptime/memory usage, etc.)
can be retrieved.

\\( opengear ®AddNode @Help @ System 5 Logout
Lighthouse™ Central Management
MONITOR SNMP SERVICE
MANAGE SETTINGS
2] CONFIGURE
L-_r‘ CONFIGU! Enable @
(P seTTINGS TCP/IP Protocol ®
NETWORK CONNECTIONS uDP
USER MANAGEMENT Location @
SERVICES
Cellular Health Reporting
Contact @
le Gateway
viv2e

@v3

SNMP V1 & V2C

Read-Only Community @

SNMP Service

Read-Write Community @

To enable SNMP Service,

Select the Enable checkbox.

Choose from the v1/v2c and v3 checkboxes.

Fill in the appropriate information for the SNMP versions.
Click Apply.

1.
2.
3.
4.

5.12 Cellular Health Settings

Administrative users can control the cellular health reporting settings under SETTINGS > SERVICES >
Cellular Health Reporting.

% opengear ® Add Node

Lighthouse™ Central Management

@Help © System 2 Log out

MONITOR CELLULAR HEALTH REPORTING

=5 MANAGE SETTINGS
[: CONFIGURE
el Enable @
> seTTNGs Signal Quality Range ® 33 es
NETWORK CONNECTIONS
USER MANAGEMENT
Bad:0-32 Good : 66 - 100 D Restore to default value

Frequency @

every | 1 hour(s) ~

Cellular Connectivity Test @

Y Apply

NetOps Modules

e Uncheck the box if you wish to disable the Cellular Health monitoring.
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e Adjust the sliders on this screen to define what you consider Good, Bad, and Moderate signal
quality to be. This will change the Cellular Health information displayed in various node lists and
on the Dashboard.

e Control how frequently Lighthouse will check the signal quality.

e Finally, you can run periodic cellular connectivity tests which make sure the cellular can actually
connect.

NOTE: Cellular Health Reporting requires Console Server firmware version 4.5 or greater.

5.13 Lighthouse MIBs

Lighthouse MIBs can be found in /usr/share/snmp/mibs/.

Lighthouse can be configured to expose managed node information such as node name, node model
number, node port label, license status, etc. via SNMP.

Some generic information about Lighthouse version and nodes count can be found at:
ogLhStatus:
ogLhVersion
ogLhNodes
ogLhNodesTotal
ogLhNodesPending
ogLhNodesConnected
ogLhNodesDisconnected
ogLhNodesTable with detailed information about nodes.

For enrolled Opengear node, the following information is available.
ogLhNodesTable:

ogLhNodelndex

ogLhNodeName

ogLhNodeModel

ogLhNodeProductType

ogLhNodeVpnAddress

ogLhNodeSerialNumber

ogLhNodeUptime

ogLhNodeConnStatus

ogLhNodePortsTable:
ogLhPortIndex
ogLhPortLabel
ogLhPortID

ogLhNodelnterfacesTable:
ogLhNodelnterfacelndex
ogLhNodelnterfaceName
ogLhNodelnterfaceAddress

For enrolled third-party node, the following information is available:
ogLhThirdPartyNodesTable:

ogLhThirdPartyNodelndex

ogLhThirdPartyNodeSSHPort

ogLhThirdPartyNodeName

ogLhThirdPartyNodeModel
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ogLhThirdPartyNodeProductType
ogLhThirdPartyNodeAddress
ogLhThirdPartyNodeSerialNumber
ogLhThirdPartyNodeUptime
ogLhThirdPartyNodeConnStatus

ogLhThirdPartyNodePortsTable:
ohLhThirdPartyPortIndex
ogLhThirdPartyPortLabel
ogLhThirdPartyPortConnectionMethod
ogLhThirdPartyPortMode
ogLhThirdPartyRemotePort
ogLhThirdPartyPortLinelD

You can query for licensing information.
oglLhLicenseStatus:
ogLhLiclnstalled
ogLhLicSupported
ogLhLicExpiry
oglLhLicStatus
oglLhLicFeatureName
You can also query for enrolled node cellular health information.
ogLhNodeCellularHealth

SNMP commands such as snmpwalk or snmpget retrieve Lighthouse specific information.

Setup: SNMP is configured with version 1 and public is community string
Lighthouse public IP address is 192.168.1.1
All MIBs, including Lighthouse MIB are available in /usr/share/snmp/mibs

Below are some examples of Lighthouse MIB queries using SNMP:

Walk through the entire ogLighthouseMib using name:

snmpwalk -m ALL -v1 -c public 192.168.1.1 ogLighthouseMib
snmpwalk -m ALL -M /usr/share/snmp/mibs -v1 -c public 192.168.1.1
ogLighthouseMib

Walk through the entire ogLighthouseMib using the OID directly:
snmpwalk -m ALL -M /usr/share/snmp/mibs -vl -c public 192.168.1.1
1.3.6.1.4.1.25049.18.1

Get the total nodes enrolled in Lighthouse:
snmpget -m ALL -v1 -c public 192.168.1.1 ogLhNodesTotal.O
snmpwalk -m ALL -v1 -c public 192.168.1.1 ogLhNodesTotal

Get serial number with enrolled node having VPN address 192.168.128.2:
snmpwalk -m ALL -v1 -c public 192.168.1.1 ogLhNodeSerialNumber.192.168.128.2
snmpget -m ALL -v1 -c public 192.168.1.1 ogLhNodeSerialNumber.192.168.128.2

Get cellular health for all enrolled nodes:

snmpwalk -m ALL -c public -v 1 192.168.124.143 ogLhNodeCellularHealth
OG-LIGHTHOUSE-MIB: :0gLhNodeCellularHealth.192.168.128.2 = INTEGER: good(4)
OG-LIGHTHOUSE-MIB: :0ogLhNodeCellularHealth.192.168.128.3 INTEGER: good (4)
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OG-LIGHTHOUSE-MIB: :0ogLhNodeCellularHealth.192.168.128.4 = INTEGER: bad(2)
OG-LIGHTHOUSE-MIB: :ogLhNodeCellularHealth.192.168.128.5 INTEGER: unknown (0)
OG-LIGHTHOUSE-MIB: :0ogLhNodeCellularHealth.192.168.128.6 = INTEGER: bad(2)

5.14 SNMP Manager Settings

Administrative users can configure the SNMP Manager settings. Select SETTINGS > SERVICES > SNMP
Manager. The SNMP Manager allows SNMP TRAP/INFORM messages to be sent from Lighthouse to a
configured server any time a node connection status is changed.

®AddNode @Help @ System 2 Logout

SNMP MANAGER

SETTINGS

E CONFIGURE
=

Enable @
P seTTINGs Manager Protocol @
NETWORK CONNECTIONS TCP
T Manager Address @
SERVICES

Cellular Health Reporting
i Manager Port @

Console Gateway 162

Version @

vi

SNMP V1 &V2C
Session Settings

SNMP Manager Community @

SNMP Service

O am ( SNMP MESSAGE SETTINGS

To enable the SNMP Manager,

Under the Settings section, select the Enable checkbox.

Choose UDP or TCP as the Manager Protocol drop-down.

Enter the Manager Port to receive SNMP messages.

Check the SNMP protocol Version from the v1, v2¢, v3 drop-down.
Choose the SNMP Message Type to be sent, either TRAP or INFORM.
Depending on the selected SNMP version, complete the following steps.

curLN=

Vv SNMP v1 & v2c

Community The SNMP Community to use for
messages.

If SNMP version v1/v2c is selected, expand that section and enter the SNMP Community to use for
messages.
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SNMP V3

Engine ID @

Security Level @

Authentication and Encryption

Username @

root

Authentication Protocol @

SHA

Authentication Password @

Privacy Protocol @

DES

Privacy Password @

If SNMP version v3 is selected, fill in the following:

1.

NogokrwnN

Specify an optional Engine ID for sending an SNMP TRAP message. If left blank, the auto-
generated Engine ID from the SNMP Service will be used. An EnginelD is not needed for an
SNMP INFORM message.

Select the desired Security Level.

Enter the SNMPv3 Username to send messages as.

Select the desired Authentication Protocol, either MD5 or SHA.

Enter the Authentication Password for the user.

Choose the Privacy Protocol, either DES or AES.

Enter the Privacy Password.

SNMP MESSAGE SETTINGS

Events to trigger a TRAP/INFORM notification on.

Node Connection Status @

Node Cellular Health Status @

9.

- Ed

Finally, to activate notifications, fill in the SNMP Message Settings. You can trigger
TRAP/INFORM notifications by checking either or both of the Node Connection Status and the
Node Cellular Heath Status checkboxes.

Click Apply.

When a node connection status changes, a nodeStatusNotif notification is sent, populated with data
about the node's connection status, address and name.
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Structure of notifications for Opengear nodes:

nodeStatusNotif
ogLhNodeName
ogLhNodelndex
ogLhNodeConnStatus

Structure of notifications for third-party nodes:

thirdPartyNodeStatusNotif
ogLhThirdPartyNodelndex
ogLhThirdPartyNodeName
ogLhThirdPartyNodeAddress
ogLhThirdPartyNodeConnStatus

5.15 Syslog export

Administrative users can specify multiple external servers to export the syslog to via TCP or UDP. Select
SETTINGS > SERVICES > Syslog.

SYSLOG
EXTERNAL SYSLOG SERVERS
Server Address Port Protocol Actions
10.84.1.1 514 upp .
/ (]
Delete Selected + ]

This page lists any previously added external syslog servers. To add a new one,

1. Click the plus sign (+) at the end of the list. The Add External Syslog Server dialog opens.

ADD EXTERNAL SYSLOG SERVER

Server Address @

Protocol @

UDP v

Port @

2. Enter the Server Address.
3. Enter the Protocol, either UDP or TCP.




44
Lighthouse User Guide

4. Enter the correct Port. If no port is entered, UDP defaults to port 514 and TCP defaults to 601.
5. Click Apply.

To edit an existing syslog server, click the Edit button “under Actions. Delete a server by clicking the x

o
button

5.16 Node Backup
NOTE: Node backup requires firmware 4.6 or later.

Administrative users can enable automatic node backup. Up to 10 backups can be stored on a rolling
basis.

1. Select SETTINGS > SERVICES > Node Backup.

 opengear ©AddNode OHep O System 5 Logout

Uighthouse™ Central Management

(Z) MoNIToR Ml NODE BACKUP
SETTINGS

CONFIGURE N
= Enable @

P sermnes

STORAGE
NETWORK CONNECTIONS

USER MANAGEMENT v Number of stored backups @

SERVICES ~ 1

1 day(s)

Node Backup | Location ®

mntinvram/backup Validate

Available space

3941 MB

DATE & TIME e SCHEDULING

SYSTEM
Start @

G am © Immediately O Set Time

2. Click the Enable checkbox to turn on this service.

3. Under the Storage section, choose the Number of stored backups you wish to keep.

4. Choose how long you wish these backups to be stored after unenrollment. Selecting Days opens
a field that allows you to enter a number.

5. Enter the Location you wish to store the backup files, then click Validate to make sure the
location exists and has enough space to store them.

6. Click Apply or set a schedule.

To set an automated schedule for performing node backups:

1. Scroll down to the Scheduling section.
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SCHEDULING
Start @
© Immediately © Set Time

Repeat
One Time Only © Interval

every | 1 dav(s)

2. For the Start time, choose either Immediately or choose Set Time to open editable Date and Time
fields.
3. Choose how often you wish to Repeat the backup by adjusting the values for Interval.

NOTE: You can modify these options by returning to SETTINGS > SERVICES > Node Backup at any
time.
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6. Shut Down or Restart Lighthouse

6.1 Shut down a running Lighthouse instance
To shut down a running Lighthouse instance:

1. Select MANAGE > LIGHTHOUSE > Local Terminal

\\( opengear @AddNode OHelp O System ) Logout

Ughthouse™ Central Management

(2) wmonTor Ml LOCAL TERMINAL

-5 maANAGE
MANAGED DEVICES
NODES
LIGHTHOUSE
Local Terminal
[£] conricure

P serTNGs

At the Local Terminal login prompt enter a username with administrative privileges (e.g. root).
At the Password: prompt, enter that account’s password. A Last login date and time for that
account are returned to STD OUT and a shell prompt for the logged in user appears.

4. Enter the command shutdown now and press Return. The virtual machine shuts down.

2.
3.

6.2 Restarting a running Lighthouse instance

To restart a running Lighthouse instance, follow the first three steps of the Shutting down a running
Lighthouse instance procedure above. At the shell prompt, enter one of these commands and press
Return:

e reboot
e shutdown -r now

The Lighthouse virtual machine shuts down and reboots.

7. Using Lighthouse

After Lighthouse has been installed and configured, a small set of nodes should be enrolled, and a set of
tags and smart groups should be created that allow nodes access to be filtered to the correct subset of
users.

Once these nodes are installed, access to the Node’s Web Ul and serial ports should be tested.

This section covers:
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1. Licensing third-party nodes before enroliment

2. Enrolling nodes

3. The Enrolled Nodes page

4. Filtering pages displaying nodes

5. Creating Smart Groups

6. Editing an existing Smart Group

7. Creating Managed Device Filters

8. Editing an existing Managed Device Filter

9. Connecting to a node’s web-management interface

10. Connecting to a node’s serial ports via Console Gateway

7.1 Licensing third-party nodes before enrollment

Lighthouse includes support for managing third-party remote nodes at no cost. Support for third-party
remote nodes is not built-in to a new Lighthouse instance, however: it is added via a license.

A license is an encrypted, RFC 7519-compliant, JSON web token that contains key-values. Licenses are
distributed by Opengear and are available as encrypted ASCII strings sent by e-mail via a fulfillment
procedure.

Before enrolling a third-party remote node, its corresponding license must be added to Lighthouse as
follows:

7.1.1 Adding a license using the Lighthouse Ul

1. Select SETTINGS > SYSTEM > Licensing
2. Click the + button on the bottom right of the page. A New License dialog opens.

NEW LICENSE

License file @

Browse... No file selected.

3. Click Browse... to select the license file to upload.
4. Click Apply.

7.1.2 Showing installed licenses in the Lighthouse Ul
To see all installed licenses, select SETTINGS > SYSTEM > Licensing.

Installed licenses are also shown on the Lighthouse dashboard under the LICENSING INFORMATION
section. Select MONITOR > Dashboard to open the Dashboard.
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LICENSING INFORMATION

Number of Installed Licenses: 1

Number of Supported Nodes: 0 /25

Number of Supported NetOps Secure Provisioning Nodes: 0 /0

Number of Supported NetOps Software-Defined Infrastructure Nodes: 0/0

Expiry Date: Nov 11, 2023
Status: In Compliance

Enabled Features: Multiple Lighthouse Support

The dashboard also displays messages when:

e The number of nodes supported by a license has been reached or exceeded.
e The maintenance period of a license has expired.

7.1.3 Showing installed licenses via the Local Terminal

oglicdump is a shell-based tool that writes the current licensing status of a Lighthouse instance to STD
ouT (or, using the -o switch, a file).

For example:
# oglicdump
{

"OGLH": {
"contact": {
"email": "test@test.com",
"name": "test",
"phone": "test"
b
"features": {
"additional": {
"multipleinstance": "1",
"thirdpartynodes": "1"

|
"maintenance": 1548806400,
"nodes": 20

If no licenses are installed, oglicdump returns the following:

# oglicdump
No data found
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7.2 Enrolling nodes
7.2.1 Enrollment overview

Enrolling nodes is the process of connecting nodes to Lighthouse to make them available for access,
monitoring, and management. Enrollment can be performed via:

The Lighthouse Web Ul
The Node Web Ul

ZTP

USB key

Credentials must be provided to authenticate either the Lighthouse during enrollment via the Lighthouse
WebUI, or the node during the other enrollment scenarios.

The Lighthouse VPN uses certificate-authenticated OpenVPN tunnels between Lighthouse and remote
nodes. These tunnels rely on the time being synchronized between the Lighthouse instance and the
console server or other remote node. During enrollment, if a remote node is not relying on an NTP server
to set its time, it inspects the HTTP Date header sent by Lighthouse and sets its local time to match that
of the Lighthouse instance.

If a remote node is relying on an NTP server to set its own time, it still checks the HTTP Date header sent
by Lighthouse to affect the time synchronization but does not set its local time to that of the Lighthouse
instance.

When enrolling via Lighthouse, an administration username and password for the node must be provided.
When enrolling via the node, an enrollment token must be provided. A default enroliment token can be set
on the CONFIGURE > NODE ENROLLMENT > Enrollment Settings page, and individual tokens set per
enrollment bundle.

Enrollment is a two-step process:

1. Once enrollment starts, nodes receive their enrollment package, and establish a VPN connection
to Lighthouse.

2. The node is now in the Pending state and needs to be Approved before the node is available for
access, management, or monitoring.

NOTE: This second step can be skipped by selecting the Auto-approve node checkbox when
configuring an enrollment bundle.

7.2.2 Enrollment bundles

An enrollment bundle is a downloadable file that stores provisioning information, allowing for bulk
enrollment and manipulation of remote nodes.

Applying an enrollment bundle during enrollment allows tags to be associated with nodes when they're
first enrolled, rather than manually assigning tags after the nodes are enrolled.
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This is useful for larger roll outs where there are many nodes deployed with a similar configuration and
responsibilities. If relevant Smart Groups and tags have been set up, newly enrolled nodes are
immediately visible for the relevant users to configure and use.

Associating templates with an enrollment bundle allows to run a set of templates on a node, after it has
been enrolled. Any template defined on the Lighthouse can be added to an enrollment bundle, and each
bundle supports any number of templates.

NOTE: NetOps modules (see NetOps User Guide) can also be associated with enrollment bundles.

7.2.3 Creating an enrollment bundle

An enrollment bundle can be created in a Lighthouse instance as follows:

1. Select CONFIGURE > NODE ENROLLMENT > Enrollment Bundles

@Help O System 3] Logout

\\( opengear ® Add Node

Ughthouse™ Central Management

MONITOR ENROLLMENT BUNDLES

MANAGE Name Node Count Actions
CONFIGURE bne-de ) /0 W

NODE ENROLLMENT NYDC

| Enroliment Bundles

2. Click the + button. The Enrollment Bundle Details page appears.

ENROLLMENT BUNDLES

ENROLLMENT BUNDLE DETAILS

Name @
Token O

Auto-approve rode @

ENROLLMENT BUNDLE NODE TAGS

Tag values specitied here wil automaticaly be appied 1o any nodes enralled against this bundie.

TEMPLATES

Tempiates selocted hore wil automatcally be appied 1o any nodes enralled against ths tundle In the specified order.
Tempiate push cperations wil stop from continng f one falls.

Order Tempians Tyse Tempdits Nama Actions

No Tamplitis harve bosn seoctd

NETOPS MOOWLES

NetOps Mocules selected here wil automaticaly be acivated on any supgorted nodes enrolied aganst this bunde
Orer Modih Name Actors

No moms have baan sekiciod

Gancel m !

3. Enter a Name and Authentication Token for the bundle in the respective fields.
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4. Select the number of Tags and Values to apply to any nodes that enroll using this enrollment

5.

6.

7.

bundle.
(Optional) Select the Auto-approve node checkbox.

When this is checked, a device configured using this enrollment bundle is not placed in pending
mode during the enrollment process. Instead, it is automatically approved for enrollment after it
has been identified.

You can also use this bundle to automatically activate NetOps modules for any supported nodes.
Scroll down to the NETOPS MODULES section and press the + button to open the MODULE
DETAILS dialog.

MOOULE DETALS

Please select a module from the list bolow.

Module Name

Cancel E

Select the desired Module Name from the drop-down list. Click Apply.

With the enrollment bundle named, use the ENROLLMENT BUNDLE NODE TAGS to populate it with the
desired name-value pairs:

ocukrwn =

Select a field name from the left-most drop-down menu.
Select or enter a value from the right-most drop-down menu.
Click the + button to add a new pair of drop-down menus.
Select another field name and select or enter another value.
Repeat until all desired name-value pairs are displayed.
Click Apply.

With the enrollment bundle named, use the TEMPLATES to populate it with the desired list of templates
to be applied post-enroliment:

N —

ocukw

Click the + button to add a new pair of drop-down menus.

Select a value from the Template Type menu. The selected template type filters the available
names to those templates of that type.

Select a value from the Template Name menu.

Repeat until all desired type-name pairs are displayed.

Click Apply.

The templates in the table can be reordered using the arrow buttons in the far-left column of the
table and are executed in the order they appear. The order buttons appear if there is more than
one template in the table.

Template push operations stop if one template fails.

7.2.4 Structure of an enroliment bundle

An enrollment bundle file, mnani fest . og, contains a series of field-value pairs that an unconfigured
device can use to configure itself.
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Options that can be set inmanifest.og include new firmware, custom configuration scripts, OPG config
files, and Lighthouse enrollment details.

By default, mani fest . og includes the following field-value pairs (with example values):

address=192.168.88.20
api_ port=4443
bundle=bne-dc
password=secret

Custom field-value pairs can be added manually. The field names are potential field names for a real-
world, customized file, but the values following each field name are examples:

script=configure ports.sh
image=acm7000-3.16.6.1image
external endpoints=192.168.1.2:4444,192.168.1.3:4445

7.2.5 Enrollment via Lighthouse Web Ul
Enrollment via Lighthouse Web Ul only works if the Node is reachable from Lighthouse.

1. Select the Add Node shortcut in the top menu bar to open a NEW ENROLLMENT dialog.
2. Select the Product type from the Product drop-down menu.
3. Available options in the Product drop-down menu are:

An Opengear device

A generic third-party device
An Avocent ACS6000

An Avocent ACS8000

An Avocent ACS Classic

A Cisco 2900 Series

NEW ENROLLMENT
Product @
An Opengear device ”

Network Address @

Usemame @

root

Password @

Auto-approve node @

Cancel
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NOTE: Enrolling an Avocent ACS6000, an Avocent ACS8000, an Avocent ACS Classic, or a Cisco
2900 Series requires the device’s license to have been added as per the Licensing third-party
nodes before enrollment procedure above. If an appropriate license has not been added to
Lighthouse, the procedure returns a No licenses have been applied error and the node is not
added to Lighthouse.

Enter the Name, Network Address, Username, and Password of the node being enrolled. The
Username and Password fields are for the login credentials required by the remote node being
enrolled, not the login credentials used to login to the Lighthouse instance.

NOTE: Lighthouse populates the node name field with the hostname of the enrolled node rather
than a user provided value. It is no longer possible for users to specify a custom name, except
when enrolling third party nodes. Console servers with firmware 4.1.1 and higher provide their
hostname in the node information, with pre-4.1 nodes instead just having their node id used as
the name. Nodes enrolled prior to upgrading to 5 have their names switched to the new standard
if the node is running 4.1.1 firmware but retain their old name if older firmware is still installed.

To enroll a generic third-party device, there are three more required fields: Connection Method;
Base Protocol Port; and Port Count.

NOTE: The following procedure assumes the third-party device’s license has been added as per
the Licensing third-party nodes before enrollment procedure above. If an appropriate license has
not been added to Lighthouse, the procedure returns a No licenses have been applied error and
the node is not be added to Lighthouse.

NEW ENROLLMENT

Product @

A aeneric third partv device

Name @

Network Address @

Connection Method @

SSH

Usemname @

root

Password @

4 Auto-approve node @
Base Protocol Port @

3000

Port Count ©

4

SERIAL PORT LABELS

Port Label 1 @

Port 1

Port Label 2 @

Port2
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6. Choose SSH or Telnet from the Connection Method drop-down menu, as appropriate for the
connection method supported by the third-party device.

7. Enter a base number in the Base Protocol Port. By default, this is set to 3000. The Base Protocol
Port number is the starting port number from which the third-party device’s individual serial port
network port numbers will be derived.

8. Enter the number of serial ports the third-party device has in the Port Count field. Below the Port
Count field is a Serial Port Labels section. Whatever number is entered in the Port Count field, the
Port Label x fields in this section update to match.

9. Optionally, edit the labels used to identify each serial port in the Serial Port Labels section.

10. Click Apply.

Once enrolled, the console server's details are removed from the Pending Nodes page and added to
the CONFIGURE > NODE ENROLLMENT > Enrolled Nodes page.

\\( opengear ®AddNode @Help @ System 3 Logout

Lighthouse™ Central Management
ENROLLED NODES

Q FILTERING

Smart Group Filtering Free Text Search

Items per page 1

Node Id Name Status Info Actions

nodes-1  platypus Connected,
1 Last status change 2 192.168.128.6
Edit Smart Groups minutes ago

C n
Edit Managed Device Filters Template Run Status:
ccccccc

x 7

00:13:c6:08:0e:4a

192.168.0.1
CONFIGURATION TEMPLATING 92.168.0.

MULTIPLE INSTANCE 192.168.1.95

NETOPS MODULES Unavailable
Show details

7.2.6 Enrollment via Node Web Ul

If the node is situated behind a firewall, Lighthouse is not able to initiate an enrollment. It needs to be
triggered from the Node Web Ul.

Log into the Node Web UL.

Select Serial & Network > LIGHTHOUSE.

Enter the Server Address of Lighthouse (which can be hostname, FQDN, or IP address)
Optionally, enter the Server Port.

Enter the Enrollment Bundle (if a specific bundle is being used), and the Enroliment Token
(either the global token or the bundle-specific token).

Select Apply Settings. The enrollment process begins.

a2

o

7.2.7 Lighthouse Enrollment via OM, ACM, CM, and IM Web Ul

e OM: Nodes can be enrolled into a Lighthouse instance on OPERATIONS MANAGER Web Ul using
the CONFIGURE > LIGHTHOUSE Enrollment menu item and the 1hvpn-callhome command.
See the OPERATIONS MANAGER User Guide for more details.

e ACM, CM and IM: On the Web Ul, select Serial & Network > Lighthouse to open the Request
Enroliment with Lighthouse Server page.
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7.2.8 Mass Enrollment using ZTP
For mass node enrollments using ZTP, three new custom DHCP fields are handled by ZTP scripts.

These fields contain the URL, Bundle Name and Enrollment Password used in an enrollment which is
kicked off after all other ZTP handling is completed. If a reboot is required because of a config file being
provided the enrollment starts after the reboot. Otherwise it happens immediately.

Here is a sample configuration file for the ISC DHCP Server:

option space opengear code width 1 length width 1;
option opengear.config-url code 1 = text;

option opengear.firmware-url code 2 = text;

option opengear.enroll-url code 3 = text;

option opengear.enroll-bundle code 4 = text;
option opengear.enroll-password code 5 = text;

class "opengear-config-over-dhcp-test" {
match if option vendor-class-identifier ~~ ""Opengear/";
vendor-option-space opengear;
option opengear.config-url "http://192.168.88.1/config.xml";
option opengear.enroll-url "192.168.88.20";
option opengear.enroll-bundle "";
option opengear.enroll-password "default";

NOTE: The maximum amount of data allowable as DHCP options is 1200 bytes, including all overhead
inherent in the structuring of this data. Individual options are limited to 255 characters.

7.2.9 Enrollment via USB drive

USB Enrollment enables the configuration of a device using a manifest file copied to a USB drive and
inserted into the unconfigured device before it first boots.

Once created (see Creating an enrollment bundle above), mani fest . og files can be downloaded from a
Lighthouse instance as follows:

1. Select CONFIGURE > NODE ENROLLMENT > Enrollment Bundles. A list of existing Enrollment
Bundles appears.

2. In the Actions column of the particular bundle, click the download button, a downward arrow in a
circle.

3. Depending on the browser’s configuration, amanifest . og file is either downloaded to the local
system or the browser opens a dialog asking to specify where download should be copied.

To enroll via USB drive:

4. Copymanifest.og to the root directory on a USB drive.
5. Plug the USB drive into an unconfigured and powered-down console server.
6. Power the console server up.
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On first boot, the device looks for a file —manifest.og — on any USB drives attached to the
device and configures the device based on their contents.

7.3 The Enrolled Nodes page

ENROLLED NODES

Q FILTERING

Smart Group Filtering Free Text Search

Items per page 10

Node Id Name Status Info Actions

nodes-1 platypus Connected,

1 Last status change 2 192.168.128.6
minutes ago
Configuration 00:13:c6:08:0e:4a
Template Run Status:

Success 192.168.0.1

X 7

192.168.1.95

Unavailable
Show details

CONFIGURE > NODE ENROLLMENT > Enrolled Nodes lists all enrolled nodes in the order they are enrolled
to Lighthouse.

The Items per page drop-down allows user to select the number of nodes per page. Choose a default
value of 10, 20, 50, 80, or 100 nodes per page, or enter a custom value between 1 and 100. This setting
applies to the current user session only and will be lost when current user logs out. This drop-down is
also presented on Pending Nodes, Console Gateway, and Node Web Ul pages.

It also displays details about each node (such as model, firmware version, serial number) and status.
Connection Status is the current status of the node and displays either of two things:

e Connected: Last status change x [time unit] ago: The time since Lighthouse connected to the
console server.

o Disconnected: last status change x [time unit] ago: The time since Lighthouse disconnected from
the console server.

Configuration Retrieval Status displays if any configuration retrieval sections failed when performing a
configuration sync with this node, such as Groups, Users, Node Description, Authorization, or Serial Ports.

Configuration Template Run Status displays the result of the most recent configuration template push on
this node, listing which templates finished applying, or failed to apply to the node. This information is
displayed until the next template push has completed on this node.

The Configuration Retrieval Status and Configuration Template Run Status are not displayed if there is
no relevant data to display and are only displayed for users with Lighthouse Administrator or Node
Administrator permissions.



57

Lighthouse User Guide

Results of the Configuration Retrieval Status and Configuration Template Run Status will indicate:

Success: all templates were successfully executed on the node.

Partial Failure: some templates failed to execute on the node, or some config sections failed to
synchronize.

Failure: all templates failed to execute on the node, or all config sections failed to synchronize.

The detailed information is shown in a popover that appears when the summary of each status is
clicked on, navigated to, or hovered over. The format of the detailed information for each status
shown on relevant popovers is as follows:

e Retrieval failed for: section_name, section_name, section_name.
e Template(s) failed to apply: template_name, template_name, template_name.
e Template(s) successfully applied: template_name, template_name, template_name.

The Cellular Health column displays the node’s current cellular status. If this state is Good|Moderate|Bad,
the color indicator and the text are clickable links that open a popup containing detailed health
information.

Cellular Health Details for im7216-0013c6045fb8

Cellular IP Address Status Conditions Signal Quality RSS! Connection Type Sim Issues Connectivity Test

10.92.141.156

2001:8004:1140:af5:1¢c6f:9d83:9a44:dab8

Up Failover Disabled 81 63 Ite No Connectivity Test Disabled

This popup includes the following information:

Cellular IP Address (IPv4 and IPv6)

Cellular interface status (Up|Down)

Conditions

Signal Quality

RSSI

Connection Type

Sim Issues

Connectivity Test (Passed|Failed|Connectivity Test Disabled)

7.4 Filtering pages displaying nodes

There are three ways to filter search results: Free Text Search, Smart Group Filtering, and Managed
Device Filtering. They can be used independently from each other or in combination. MANAGE >
MANAGED DEVICES > Console Gateway uses all of them because it is the only page which lists all nodes
with managed devices.

7.4.1 Filtering using the Free Text Search field

The Free Text Search text-entry field allows the near real-time filtering. It searches over node name,
firmware version, management VPN address, MAC address, and serial number. Type a string (e.g. 4.7.7 or
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192.168.128.1 or CM7148) and press Return. Only nodes which include that string in their Name or
Description are displayed.

The Free Text Search field treats multiple search terms (i.e. terms delimited by the space character) as
Boolean AND searches.

For example, a search on the string:
4.1.1 CM7148

returns any nodes that have both CM7748 AND 4.1.7 in searchable fields (e.g. CM7748 in the name field
and 4.1.17 in the firmware version field).

To make a search string that contains spaces into a single searched entity, enclose the string in double
quotes.

7.4.2 Filtering using the Smart Group Filtering drop-down menu

Selecting from the Select Smart Group drop-down menu sets the page to display the subset of nodes that
belong to the selected group. See Creating Smart Groups below for how to create such groups.

Once a particular Smart Group has been selected, further filtering options become available. For example:

Q Filtering

Smart Group Filtering

SandyDevices City Is Sandy -

Deployment Is Remote -+

In the example above, the CONFIGURE > NODE ENROLLMENT > Enrolled Nodes page is being filtered on
the SandyDevices Smart Group.

It is then being further filtered to only display nodes with a City of Sandy, and a Deployment of Remote.
To add more filtering options:

Click the * button. An extra row of drop-down menus appears.

Select the desired tag from the left-most drop-down menu.

Select the filtering operator from middle drop-down menu.

Select or enter the value to be filtered against from the right-most drop-down menu.
Click Apply.

arwnN=

7.4.3 Filtering using the Managed Device Filtering drop-down menu

Selecting from the Select Managed Device Filter drop-down menu sets the page to display the subset of
nodes with filtered managed devices. See Creating Managed Device Filter below for how to create
managed device filters.
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Once a particular Managed Device Filter has been selected, further filtering options become available. For
example:

 opengear ® Add Node

Lighthouse™ Central Management

@Help @ system 2 Logout

IONITOR CONSOLE GATEWAY

5 wanace Q FILTERING

MANAGED DEVICES
Smart Group Filtering Free Text Search

Console Gateway

Quick Search

Managed Device Filtering
NODES

DC-west routers
LIGHTHOUSE

- Port Label Begins with
[Z] conricure

router

P serTines

Port Label Contains

dc-west

oo sonse. | [0

In the example above, the MANAGE > MANAGED DEVICES > Console Gateway page is being filtered on
the DC-west routers Managed Device Filter. It is then being further filtered to only display nodes with a
Port Label Begins with router, and a Port Label Contains dc-west.

To add more filtering options:

Click the + button. An extra row of drop-down menus appears.

Select the Port Label from the left-most drop-down menu.

Select the filtering operator from middle drop-down menu.

Enter the value to be filtered against from the right-most drop-down menu.
Click Apply.

SNk W=

7.5 Creating Smart Groups
Smart Groups are saved search parameters used within Lighthouse for grouping related remote nodes.

A given User Group can be linked to a particular Smart Group. When a Group is linked in this fashion,
members of the Group inherit rights over all nodes in the group based on the Group'’s Role. See Modifying
existing groups for how to set a Group’s Role and Linked Smart Group.

Smart Groups can also be used to filter visible nodes on pages that display enrolled nodes (such as
CONFIGURE > NODE ENROLLMENT > Enrolled Nodes) to make it easier to drill down to a particular
console.

Smart groups are dynamic, so as more nodes are added to the system, the filters update.
To create a Smart Group:

1. Navigate to any page which displays the Smart Group search interface, for example CONFIGURE
> NODE ENROLLMENT > Enrolled Nodes or MANAGE > NODES > Node Web Ul.
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2. Click on the Select Smart Group drop-down and select New Smart Group. This populates a
number of new drop downs and text boxes.

CONSOLE GATEWAY

Q FILTERING

Smart Group Filtering Free Text Search

New Smart Group Searct ® 9

Value
Clear Save as... m

3. Click the Field to search drop-down to select a node attribute to filter on.

These attributes include details about the device (Model, Firmware Version, Serial Number, NET1
MAC Address), and include any tags that have been configured in the system. For filtering access to
devices, tags are the most useful attributes to filter on. When a tag is selected, the Value text box
becomes a drop-down with the values for that tag.

4. Click the Operator drop-down to select the operator to apply to the Value. In general, the Is
operator is the most useful.
Select the Value to be matched against.

5.
6. Click Apply to see the results of the filter.
7. Click Save As and type in a name for your new Smart Group.

This Smart Group can now be used for filtering nodes for display and for access.

7.6 Editing an existing Smart Group

To edit an existing Smart Group:

Select CONFIGURE > Edit Smart Groups.

@Help @ system 8 Logout

 opengear © Add Node

Lighthouse™ Central Management

MONITOR EDIT SMART GROUPS

3 s Adding smart groups iis done via the filter menu at the top of any pages containing a node list. Click here to go to the managed nodes page.
==

CONFIGURE

Name Actions

DC
NODE ENROLLMENT

Enrolled Nodes sLC
Enroliment Bundles

Enroliment Settings [¢]
Pending Nodes

Edit Tags

Edit Smart Groups

e Click the Delete button to delete an existing Smart Group.
e Click the Edit Group button to change a Smart Group’s name.



61
Lighthouse User Guide

To change the search parameters used by a Smart Group:

1. Navigate to a page that displays Smart Groups for filtering (e.g. CONFIGURE > NODE
ENROLLMENT > Enrolled Nodes).

Select the required Smart Group to be changed from the Select Smart Group drop-down menu.
Change the Tag and Operator values as required.

Click Save as.

HwN

SAVE SMART GROUP

Name @

Engineering Units

5. Leave the Smart Group name unedited and click Apply. The changed Smart Group overwrites the
existing Smart Group.

7.7 Creating Managed Device Filters

Managed Device Filters are saved search parameters for grouping related managed devices on remote
nodes. Managed Device Filters can be used to filter visible nodes with managed devices on the MANAGE
> MANAGED DEVICES > Console Gateway page to make it easier to find a particular console.

Managed Device Filters are dynamic, so as more nodes with managed devices which match saved filters
are added to the system, the filters update.

To create a Managed Device Filter:

1. Navigate to the MANAGE > MANAGED DEVICES > Console Gateway page.
2. Click on the Select Managed Device Filter drop-down and select New Managed Device Filter.
This populates a number of new drop-downs and text boxes.

Managed Device Filtering

New Managed Device Filter

Clear Save as... m

Click the Field to search drop-down to select a node attribute to filter on.

Select Port Label configuration.

Click the Operator drop-down to select the operator to apply to the Value. In general, the Contains
operator is the most useful.

ok~ w
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6. Populate the Value to be matched against.
7. Click Apply to see the results of the filter.
8. Click Save As and type in a name for the filter.

This Managed Device Filter can now be used for filtering nodes with managed devices.

7.8 Editing an existing Managed Device Filter

To edit an existing Managed Device Filter, select CONFIGURE > Edit Managed Device Filters page.

® AddNode @ Help @ System ) Log out

MONITOR EDIT MANAGED DEVICE FILTERS

e Adding managed device filters is done via the fiiter menu at the top of the Console Gateway page. Click here to go to the Console Gateway page.
Name Actions

[2] conricure

DC-west routers .

NODE ENROLLMENT s ©

Enrolled Nodes

Edit Smart Groups

Edit Managed Device Filters

e Click the Delete button to delete an existing Managed Device Filter.
e Click the Edit button to change a Managed Device Filter's name.

To change the search parameters used by a Managed Device Filter:

1. Navigate to a page that displays Managed Device Filter, such as MANAGE > MANAGED DEVICES
> Console Gateway.

2. Select the Managed Device Filter to change from the Select Managed Device Filter drop-down

menu.

Change the parameters (e.g. Operator values) as required.

Click Save as.
5. Leave the Managed Device Filter name unedited and click Apply. The modified Managed Device
Filter overwrites the existing Managed Device Filter.

W

SAVE MANAGED DEVICE FILTER

Name @

DC-west routers
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7.9 Connecting to a node’s web-management interface

Once a node has been enrolled, its own web-management interface can be accessed from within the
Lighthouse Ul. To connect to an enrolled node’s web-management interface:

1. Select MANAGE > NODES > Node Web UI.

2. In the Actions column, click the Access Web Ul link for the particular node.
The web-based login for that node loads.

3. Authenticate using the username and password required by that node. The appearance of the
Web Ul depends on which device you have added. Below is the ACM/CM/IM Web Ul, followed by
the OM Web UI.

\\/ opengear

System: Login
Username

Password/Passcode

LOG IN TO OPERATIONS MANAGER
Username
root

Password

This system is being accessed via Lighthouse - click here to return to Lighthouse ) Opengear 2020 | Customer Support

At the bottom of the browser window is a visual indication that the console server session is being
mediated through Lighthouse and a link allowing for a quick return to Lighthouse.

7.10 Connecting to a node’s serial ports via Console Gateway

Searching for serial ports on Lighthouse can be accomplished by selecting MANAGE > MANAGED
DEVICES > Console Gateway and MANAGE > MANAGED DEVICES > Quick Search.
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The Items per page drop-down on Quick Search page allows user to select the number of ports per page.
Choose a default value of 10, 20, 50, 80, or 100 ports per page, or enter a custom value between 1 and
100. This setting applies to the current user session only and will be lost when user logs out.

NOTE: Port-centric search allows filtering via the Managed Device Filters and displays a list of ports x
Iwithin enrolled nodes that match the search terms, while node-centric search allows filtering via Smart
Groups and node properties. Quick Search can be used to filter on the managed device label.
Node-centric searching

1. Select MANAGE > MANAGED DEVICES > Console Gateway.
2. Find the particular port using the Smart Group Filtering options to restrict the listed nodes.
3. Click the + button in the Access Console Ports row adjacent the particular node.
Port-centric searching
1. Select MANAGE > MANAGED DEVICES > Console Gateway.
2. Find the particular port by using the Managed Device Filtering options to restrict the listed
managed devices within enrolled nodes.

Once the serial port is located, serial port access via Console Gateway can be accomplished in two ways:

e HTML5 Web Terminal
e SSH

Quick Search

1. Select MANAGE > MANAGED DEVICES > Quick Search.

2. Enter the managed device label, aka name, in the Quick Managed Device Search field. This
search live-updates as user type.

3. Use Web Terminal and/or SSH links inside Actions on a particular port to access it.

7.10.1 Access via HTML5 Web Terminal

To provide easy console port access, Lighthouse includes a HTML5 Web Terminal. The HTML5 Web
Terminal includes native cut, copy and paste support. The terminals available on nodes do not.

To access a console port via the Web Terminal:

1. Locate the particular port by using one of the search techniques discussed above.
2. Click the Web Terminal link for the particular port. A new tab opens containing the Web Terminal.

To close a terminal session, close the tab, or type ~. in the Web Terminal window.
7.10.2 Access via SSH

To access ports via SSH, the user can either use a console chooser menu to select the node and the
console port or use a direct SSH link from the Web Ul to connect to the port.
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To access a console port via a Direct SSH link:

1. Locate the particular port by using one of the search techniques discussed above.
2. Click the SSH link to connect to the URL.

These auto-generated links use the colon (:) as the field-delimiter. The auto-generated SSH link has the
following form:

ssh://user-name:console-server—-name:port—-number@lighthouse-ip-address

Some web browsers associate the colon character with delimiting the protocol at the beginning of a URI
so they don't pass these auto-generated URIs correctly.

To work around this, the default delimiter character can be changed. To change this character:

Select SETTINGS > SERVICES > Console Gateway.

§ opengear ® Add Node

Lighthouse™ Central Management

@Help @ system ) Log out

(2) wmonimor Ml CONSOLE GATEWAY

5 maNAGE v SETTINGS
[E CONFIGURE
= Console Gateway Port Delimiter @
P serTines
NETWORK CONNECTIONS
Console Gateway SSH Address @

USER MANAGEMENT
192.168.1.186

SERVICES
Apply

Cellular Health Reporting

Console Gateway

e Enter a delimited character in the Console Gateway Port Delimiter text-entry field. The carat, #, is
the most common alternative.

e Use the Console Gateway SSH Address drop-down menu to choose an address from which to
SSH. The list of available addresses contains the current network interfaces and external network
addresses. The value defaults to net7:dhcp if it exists and net7:static otherwise. The additional
external addresses can be added to this list using the SETTINGS > SYSTEM> Administration

page.

To use the console chooser menu, SSH to the Lighthouse appliance with the username format
username:serial. This connects to the Lighthouse and presents a list of nodes that the user can access.
Once the user selects a node, they are presented with a list of console ports they have access to. When
one is selected, the user is connected to that port. For faster access, there are username format
shortcuts that give more specific lists of serial ports, or direct access without a menu.

e username:node_name
When a valid node name is specified, a list of console ports that the user can access on that node
is shown. If they do not have access to this node, the connection fails.

e username:node_name:port_name
When a valid node name and port name are specified, and the user has access to that node and
port, the user is connected to this port. If they do not have access to that port, the connection
fails.
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e username:port_name
When a valid port name is specified, the user is connected to first port with that port name found.
If the user does not have access to this port, the connection fails.

NOTE: Node names and port names are not case sensitive.

7.10.3 Example Console Gateway session

$ ssh adminuser:serial@lighthouse-name-or-ip-here
1: cm71lxx
Connect to remote > 1
1: Cisco Console 2: Port 2

Connect to port > 1
router#
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8. Lighthouse user management

Lighthouse supports locally defined users, and remote users that are authenticated and authorized by
AAA.

Users must be members of one or more groups. Each group has a role assigned to it which controls the
level of access that group members have to the system. These roles are:

Role Description

Lighthouse The Lighthouse Administrator role is assigned to groups whose members need to manage and

Administrator  maintain the Lighthouse appliance. Members have access to all data on the Lighthouse system

The Node Administrator role is assigned to groups that need to manage and maintain a set of Nodes.

Each group with the Node Administrator role must have an associated Smart Group which is evaluated

to define the set of nodes that the group members have access to.

The Node User role is assigned to groups that need to access a set of nodes. Each group with the

Node User Node User role must have an associated Smgrt Group which is evaluated to def!ne the set of npdes
that the group members have access to. Optionally, access to the managed devices can be limited by
associating the saved Managed Device Filter with the Node User role.

Node
Administrator

Group membership can either be defined locally for local users or defined on the AAA server. Groups that
are assigned by the AAA servers must still exist locally.

8.1 Password fields in Lighthouse

All password fields in Lighthouse are write-only. They accept data from the clipboard or pasteboard but
do not pass data out.

8.2 Creating new groups

@Help @ System 2 Log out

% opengear ® Add Node

Lighthouse™ Central Management

GROUPS
Group Name Description Members Actions

admin Provides users with unlimited configuration 1 ,
and management privileges

netgrp Group for users created automatically via 0 ;o
network authentication
NETWORK CONNECTIONS

USER MANAGEMENT
Delete Selected Disable Selected

| Groups

To create a new group:

1. Select SETTINGS > USER MANAGEMENT > Groups.
2. Click +. The New Group dialog opens.
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NEW GROUP

GROUP DETAILS

Group Name

Role
Lighthouse Administrator

Linked Smart Group
All Nodes

Linked Managed Device Filter
All Managed Devices

Group Enabled

-y ...

3. Enter a Group Name, Description, and select a Role for the group.

Group Name is case sensitive. It can contain numbers and some alphanumeric characters. When using
remote authentication, characters from a user's remote groups that are not allowed on Lighthouse are
converted to underscores during authentication. Local groups can be created that take that into account,
allowing the authentication to continue.

If the Role selected is Lighthouse Administrator, members of the group have access to all nodes and
managed devices.

If the Role selected is Node Administrator, select a Linked Smart Group to define the nodes that the
group has access to. Members of the group have access to all managed devices.

If the Role selected is Node User, select a Linked Smart Group to define the nodes that the group has
access to. Choose All Managed Devices or a saved managed device filter from Linked Managed Device
Filter drop-down to define the managed devices that the group has access to.

1. Select Group Enabled checkbox to enable group.
2. Click Save Group.

NOTE: When a new group is given the Lighthouse Administrator role, members of the group have access
to the sudo command. Groups or users with the Lighthouse Administrator role are added to the admin
group, which is in the list of allowed sudoers. On first boot of a new Lighthouse instance, the root user is
the only member of the admin group and the only user with sudo access.

8.3 Modifying existing groups
To modify an existing group:

1. Select SETTINGS > USER MANAGEMENT > Groups.

2. Click the Edit Group button in the Actions section of the group to be modified and make desired
changes.

3. Click Save Group.
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\\, opengear ®AddNode @Help O System 3 Logout

Lighthouse™ Central Management

MONITOR EDIT GROUP

MANAGE GROUP DETAILS

[Z] conricure

Group Name
[:P SETTINGS netgrp
NETWORK CONNECTIONS Description

USER MANAGEMENT Group for users created via network

Groups Role
Local Users N oy
Lighthouse Administrator

Remote Authentication
Linked Smart Group
SERVICES

All Nodes
Cellular Health Reporting

Linked Managed Device Filter
Console Gateway

All Managed Devices
Lighthouse VPN Group Enabled

NetOps Modules

The Modify Group dialog allows the group’s Description, Role, Linked Smart Group, and Linked Managed
Device Filter to be set and changed.

If a Group's Role is Lighthouse Administrator, the group’s Linked Smart Group is All Nodes and Linked
Managed Device Filter is All Managed Devices. This cannot be changed. If a Group has a Linked Smart
Group other than All Nodes or a Linked Managed Device Filter other than All Managed Devices, the
group’s Role cannot be set to Lighthouse Administrator.

See Creating Smart Groups above for details regarding creating and using Smart Groups and Creating
Managed Device Filters for details regarding creating and using Managed Device Filters.

The Groups page also allows user to delete a group. All users who were members of the deleted group
lose any access and administrative rights inherited from the group.

8.4 A note on default netgrp Lighthouse group

The netgrp group is inherited as the primary group for all remote AAA users who are not defined locally
on Lighthouse. By default, netgrp has the Lighthouse Administrator role and is disabled - it must be
enabled to take effect for remote AAA users.

8.5 Creating new users

To create a new user:
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§ opengear ® Add Node

Lighthouse™ Central Management

@Help O System ) Logout

MONITOR LOCAL USERS

MANAGE Username Description Actions
) arames root System wide SuperUser account ;o
=
P serTiNes
LA e Al Delete Selected Disable Selected + c
USER MANAGEMENT
Groups
Local Users
Remote Authentication
1. Select SETTINGS > USER MANAGEMENT > Local Users.
By default, the root user is the only user listed.
2. Click the + button. The New User page appears.
NEW USER
USER DETAILS
Usemame
Description
root
Password @
Confirm Password @
Group Memberships
Group Name Description Members
admin Provides users with unlimited configuration and management privileges 1
netgrp Group for users created automatically via network authentication 0
0/ 2 Groups Selected
User Enabled

Enter a Username, Description, and Password.
Re-enter the Password in the Confirm Password field.
Select the User Enabled checkbox.

Click Save User.

ocous®

To create a new user without password which causes them to fail back to remote authentication:

Select SETTINGS > USER MANAGEMENT > Remote Authentication
Apply Remote Authentication Settings.

Select SETTINGS > USER MANAGEMENT > Local Users

Click the + button. The New User dialog loads.

Enter a Username, Description.

Select the Remote Password Only checkbox.

Select the Enabled checkbox.

Nook,wnN =
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8. Click Apply.

NOTE: When a new user is created, an entry is added to the syslog, indicating the new user's name, the
user that performed the operation, and the time that it occurred:

2018-04-03T12:42:48.587744+00:00 lighthouse configurator users[28915]: User <newuser>
added to passwords file

2018-04-03T12:42:48.710530+00:00 lighthouse og-rest-api: User <newuser> created by
<root>

If the created user is set to disabled, the configurator users message does not appear as they have
not been added to the passwords file.

The syslog can be accessed from Lighthouse by clicking Help > Technical Support Report.

8.6 Modifying existing users

To modify an existing user:

-_—

Select SETTINGS > USER MANAGEMENT > Local Users

2. Click the Edit User button in the Actions section of the user to be modified and make desired
changes.

3. Click Save User.

® Add Node @ Help @ System ) Log out

% opengear

Ughthouse™ Central Manager

7) MONITOR

#] CONFIGURE

&P seTTiNGs

NETWORK CONNECTIONS

USER MANAGEMENT

EDIT USER
USER DETAILS
Usemame

sandyadmin

Description

sandy admin

Password @

Confirm Password @

Group Memberships
Group Name
admin

netgrp

2/2 Groups Selected

User Enabled

Description
Provides users with unlimited configuration and management privileges

Group for users created automatically via network authentication

Members
2

1

Cancel m

The Edit Users dialog allows the user’s Description to be changed and the user's Password to be reset.
The username cannot be changed. To disable a user, uncheck the Enabled checkbox.
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Disabled users cannot login to Lighthouse using either the Web-based interface or via shell-based logins
(i.e. sshusername-disabled@lighthouse-name-or-ip). The user and the /home /username-
disabled directory still exist in the Lighthouse VM file system.

8.7 Deleting users
To delete a user:

1. Select SETTINGS > USER MANAGEMENT > Local Users
2. Click the Delete button in the Actions section of the user to be deleted.
3. Click Yes in the Confirmation dialog.

8.8 Disabling a Lighthouse root user
To disable a root user:

Make sure that another user exists that is in a group that has the Lighthouse Administrator role.
Select SETTINGS > USER MANAGEMENT > Local Users

Click Disable in the Actions section of the root user.

Click Yes in the Confirmation dialog.

L=

To enable root user back log in with another user exists that is in a group that has the Lighthouse
Administrator role and click Enable in the Actions section of the root user.

8.9 Configuring AAA
Lighthouse supports three AAA systems:

e LDAP (Active Directory and OpenLDAP)
e RADIUS
o TACACS+

Authentication works much the same with each, but group membership retrieval varies. The following
sections detail the configuration settings for each provider and explain how group membership retrieval
works.

To begin, select SETTINGS > USER MANAGEMENT > Remote Authentication.
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8.9.1 LDAP Configuration

REMOTE AUTHENTICATION

SETTINGS

Scheme Mode

LDAP - LDAPDownLocal

Remote authentication servers

Address (dotauts 10 LOARLDAPS standerd ports)

LDAP base DN @

LDAP bind DN @

root

LDAP username attribute @
LDAP group membership attribute @
Ignore referrals @

ssL
Server protocol @
LDAP over SSL preferred

Ignore SSL certificate errors @

CA certificate @

Browse...  No file selected.

-_—

Select LDAP from the Scheme drop-down menu.

2. Choose the desired Mode from the drop-down menu.
e LDAPDownLocal

LDAP: Default behavior

LDAP/Local

Local/LDAP

NOTE: See the Glossary for more information about these modes.

3. Add the Address and optionally the Port of the LDAP server to query.
4. Add the LDAP Base DN that corresponds to the LDAP system being queried.

For example, if a user’s distinguished name is cn=John Doe,dc=Users,dc=ACME,dc=com, the
LDAP Base DN is dc=ACME,dc=com

5. Add the LDAP Bind DN. This is the distinguished name of a user with privileges on the LDAP
system to perform the lookups required for retrieving the username of the users, and a list of the
groups they are members of.

6. Add and confirm a password for the binding user.
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7. Add the LDAP username attribute. This depends on the underlying LDAP system. Use
sAMAccountName for Active Directory systems, and uid for OpenLDAP based systems.

8. Add the LDAP group membership attribute. This is only needed for Active Directory and is
generally memberOf.

9. |If desired, check Ignore referrals option. When checked, LDAP will not follow referrals to other
remote authentication servers when logging users in to Lighthouse. If multiple remote
authentication servers exist on the network, checking this option may improve login times.

10. Under the SSL section, choose the desired Server protocol.

LDAP over SSL preferred: this will attempt LDAPS before trying LDAP without SSL
LDAP (no SSL) only: non-SSL LDAP is always used
LDAP over SSL only: LDAP over SSL is always used

11. If desired, check Ignore SSL certificate errors to ignore any SSL certificate errors.

12. CA Certificate is used to upload an SSL Certificate which will verify any LDAP servers you specify
on the page.

NOTE: The certificate will be uploaded but will not be used if you've chosen to ignore certificate
errors.

13. Install the CA certificate by clicking the Browse... button and locating the appropriate file.

14. Click Apply.

NOTE: Multiple servers can be added. The LDAP subsystem queries them in a round-robin fashion.
8.9.2 RADIUS configuration
To configure RADIUS:

1. Select SETTINGS > USER MANAGEMENT > Remote Authentication.

REMOTE AUTHENTICATION

SETTINGS

Scheme Mode

RADIUS = RADIUSDownLocal

2. In the Settings section, select RADIUS from the Scheme drop-down menu.
3. Choose the desired Mode from the drop-down menu.

e RADIUSDownLocal
e Radius
e RADIUS/Local
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e Local/RADIUS

NOTE: See the Glossary for more information about these modes.

4. Add the Address and optionally the Port of the RADIUS authentication server to query.

5. Add the Address and optionally the Port of the RADIUS accounting server to send accounting
information to.

6. Add the Server password, also known as the RADIUS Secret.

NOTE: Multiple servers can be added. The RADIUS subsystem queries them in a round-robin fashion.

To provide group membership, RADIUS needs to be configured to provide a list of group names via the
Framed-Filter-Id attribute. The following configuration snippet shows how this can be configured for
FreeRADIUS:

operatorl Auth-Type := System
Framed-Filter-ID = ":group name=west coast admin,east coast user:"

NOTE: The Framed-Filter-ID attribute must be delimited by the colon character.
8.9.3 TACACS+ configuration
To configure TACACS+:

1. Select SETTINGS > USER MANAGEMENT > Remote Authentication.

REMOTE AUTHENTICATION

SETTINGS
Scheme Mode
TACACS+ - TACACS+DownLocal
Remote authentication servers

Address

TACACS+ login method @

TACACS+ service @

2. Select TACACS+ from the Scheme drop-down menu.
3. Choose the desired Mode from the drop-down menu.
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TACACSDownLocal:
TACACS: Default behavior
TACACS/Local
Local/TACACS

NOTE: See the Glossary for more information about these modes.

4. Add the Address and optionally the Port of the TACACS+ authentication server to query.

5. Select the Login Method. PAP is the default method. However, if the server uses DES-encrypted
passwords, select Login.

6. Add the Server password, also known as the TACACS+ Secret.

7. Add the Service. This determines the set of attributes sent back by the TACACS+ server

NOTE: Multiple servers can be added. The TACACS+ subsystem queries them in a round-robin fashion.

To provide group membership, TACACS+ needs to be configured to provide a list of group names This
following configuration snippet shows how this can be configured for a tac_plus server:

user = operatorl {
service = raccess {
groupname = west coast admin,east cost user
}
}

To do this with Cisco ACS, see Setting up permissions with Cisco ACS 5 and TACACS+ on the Opengear
Help Desk.
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9. Lighthouse central configuration

Templates are a centralized way of changing the configuration for enrolled Opengear console server
nodes by pushing pre-defined configuration templates to selected nodes. Lighthouse supports the
creation and execution of Users and Groups, Authentication and Script templates.

9.1 Creating new users and groups templates

Administrators can access CONFIGURE > CONFIGURATION TEMPLATING > Users and Groups
Templates to create, edit, and delete users and groups templates. Each template must contain at least
one group.

Each template contains a list of user-defined groups and/or individual users. Each group has a defined
role which determines what privileges group members have. User roles are defined by the groups they are
a member of.

The available group roles are:

¢ Node Administrator — maps to the administrator role on the nodes.
¢ Node User — maps to the ports user role and the pmshell role on the nodes. Ports access can be
restricted if required.

To create a new users and groups template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Users and Groups Templates.
2. Click the + button. The New Users and Groups Template page loads.

NEW USERS AND GROUPS TEMPLATE

TEMPLATE DETAILS

Name

Description

SET GROUP LIST

Groups provided in this kst will replace any user defined groups on the node

Group Name Actions

SET USER LIST

Users provided in this list will replace any existing users on the node

User Name Actions

Note: To push users, the selected nodes need to be running firmwars version 4.3.0 o later.

3. Enter a Name and Description for a template in the Template Details section.
4. Click the + button in the Set Group List section to add a new group. The Group Details dialog
loads.
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GROUP DETAILS

Group Name
Description

Role

Node Administrator =

5. Enter a Group Name, a Description, and select a Role for the group.

6. If Node User role is selected, the Restrict accessible Serial Ports checkbox and Serial Ports
range appear.

7. Use the checkbox to restrict access and specify as port or range of ports in the Serial Ports range

text box.

Click Apply.

Click the + button in the Set User List section to add new users. The User Details dialog loads.

©

USER DETAILS

Username

Description
root

Password

Confirm Password

Group Memberships
Group Name Description

No Groups have been created

0/ 0 Groups Selected

Cancel m

10. Enter a Username, a Description, and a Password for the user. Type the password again in the
Confirm Password text box.

11. Optionally, click checkboxes next to the groups this user should belong to. Only groups from this
template are available.

12. Click Apply.

13. Continue adding new groups and users until finished.

14. Click Save Template.

NOTE: When a users and groups template is pushed to a node, all custom groups on that node are
replaced by groups defined in the template. If no users are in the new template, existing users will
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remain on the node. To push users, the selected nodes need to be running firmware version 4.3.0 or
later.

9.2 Modifying existing users and groups templates

The Edit Users and Groups Template dialog allows a template’s Description, Group List, and User List to
be set and changed.

To modify a template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Users and Groups Templates.

% opengear ® AddNode @D Help @ System 3 Logout
Lighthouse™ Central Management
MONITOR USERS AND GROUPS TEMPLATES
IL? MANAGE Template Name Description Actions
(=] conricure groups for dc region e
NODE ENROLLMENT f
r i
groups for rc region s e
users and groups for DC template for data center region ; o
Edit Managed Device Filters
CONFIGURATION TEMPLATING
Delete Selected + c

Apply Templates
Authentication Templates
Script Templates

Users and Groups Templates

MULTIPLE INSTANCE

© Opengear 2020 | Customer Support

2. Click Edit button in the Actions section of the template to be modified. The Edit Users and
Groups Template dialog appears.
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\\' opengear @AddNode @Help O System 3 Logout
Inagement

Ughthouse™ Central Ma
& :‘ MONITOR Ml  EDIT USERS AND GROUPS TEMPLATE

5 manace Bl TEwPLATE DETALS

CONFIGURE Neme

NODE ENROLLMENT M usersa ind groups for DC

template for data center region

CONFIGURATION TEMPLATING ~ SET GROUP LIST

Groups provided in this list will repiace any user defined groups on the node
Group Name Actions

dc_admin
s /s ©

de_user

MULTIPLE INSTANCE

NETOPS MODULES

7}
5’ sernnes

SET USER LIST

Users provided in this st will replace any existing users on the node

User Name Actions

No Users have been created

Note: To push users, the selected nodes need to be running firmware version 4.3.0 or later.

Make changes to the template’s details, group list, or Individual user list as required.
Click the x button under Actions next to any groups or users which need to be removed.
Click Save Template.

ok~ w

9.3 Deleting users or groups from a template
To delete a template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Users and Groups
Templates.

2. Click the Edit button in the Actions section of the template.
Click the x button under Actions next to any groups or users which need to be removed.

4. Click Save Template to save the changes.

w

9.4 Deleting users and groups templates
To delete a template:
1. Select CONFIGURE > CONFIGURATION TEMPLATING > Users and Groups Templates.

2. Click the Delete button in the Actions section of the template to be removed. The Confirmation
alert box appears.
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CONFIRMATION

Are you sure you want to proceed with this action?

- K3

3. Click Yes in the Confirmation dialog. The users and groups template is deleted.

9.5 Creating new authentication templates

Only users assigned to the Lighthouse Administrator role can access CONFIGURE > CONFIGURATION
TEMPLATING > Authentication Templates and create authentication templates.

The supported modes are Local, Radius, TACACS+, and LDAP. For example, if an authentication template
is configured to use RADIUS as an authentication source, that corresponds to RADIUSDownLocal with
Use Remote Groups ticked on the downstream node.

To create a new authentication template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Authentication Templates.
2. Click the + button. The New Authentication Template page loads.

\\( °P¢n9¢°f ® Add Node @ Help @ System 2J Log out

Uighthouse™ Central Management

7) MONITOR NEW AUTHENTICATION TEMPLATE

MANAGE TEMPLATE DETAILS

CONFIGURE

Name

NODE ENROLLMENT

Description

AUTHENTICATION SETTINGS

Pre-populate from Lighthouse @
Pre-populate

Scheme

MULTIPLE INSTANCE Local users only

NETOPS MODULES

P seTTNGS [T B Save Template

3. Enter a Name and Description for a template in the Template Details section.

4. Select a desired Scheme or click Pre-populate to pre-populate a template with the current
Lighthouse remote authentication configuration.

Enter or update authentication settings if required. See Configuring AAA above for an example.
Click Save Template.

ow
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NOTE: When an authentication template is pushed to a node, the authentication settings at that node are
replaced by the those defined in the authentication template.

NOTE: The authentication templates do not support the full list of settings that the Opengear console
servers support. However, templates can be applied, and then additional settings configured manually.

9.6 Modifying existing authentication templates

The Edit Authentication Template dialog allows the template’s Description and Authentication Settings
to be set and changed.

To modify an existing authentication template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Authentication Templates.

\\, opengear © Add Node

Uighthouse™ Central Management

@Help @ System 3 Log out

7) MONITOR AUTHENTICATION TEMPLATES

MANAGE Template Name Description Actions
CONFIGURE radius auth template ;o
NODE ENROLLMENT
tacacs template tacacs set up
/ (<]
local template
P / (<]
CONFIGURATION TEMPLATING
Delete Selected + c

Apply Templates

Authentication Templates

Script Templates

2. Click Edit in the Actions section of the template to be modified. The Edit Authentication
Template dialog appears.
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@AddNode @Help (O System 3 Logout

Ml  EDIT AUTHENTICATION TEMPLATE
TEMPLATE DETAILS

Name

radius auth template

Description

AUTHENTICATION SETTINGS

Pre-populate from Lighthouse @
Pre-populate
Scheme

RADIUS
MULTIPLE INSTANCE

NETOPS MODULES
Remote authentication servers

0]
5’ sernnes v Port

Addess e 101812)

192.168.250.20 1812 =+
Remote account ting servers
Port
Address s 1o 1813
192.168.250.21 1813 -t

Confirm server password

5. Make required changes.
6. Click Save Template.

9.7 Deleting authentication templates
To delete an authentication template:
1. Select CONFIGURE > CONFIGURATION TEMPLATING > Authentication Templates.

2. Click Delete in the Actions section of the template to be removed. The Confirmation alert box
appears.

CONFIRMATION

Are you sure you want to proceed with this action?

- B

3. Click Yes in the Confirmation dialog. The authentication template is deleted.

9.8 Creating new script templates

Users assigned to the Lighthouse Administrator role can access CONFIGURE > CONFIGURATION
TEMPLATING > Script Templates and create script templates.
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Script Templates allow the user to upload arbitrary shell scripts to be run on a node. A script may set
additional configuration settings not available in other templates or store additional files onto the node
such as certificates, for example. The uploaded script must have a .sh extension and can’t be more than
TMB in size. Other than those, there are no other restrictions on the script file to be uploaded. Once saved,
the template stores the size and SHA1 checksum of the script. This can be used to verify the script
contents of the template once saved. To apply script templates, the selected nodes need to be running
firmware version 4.1.1 or later.

To create a new script template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Script Templates.
2. Click the + button. The New Script Template dialog loads.

@ Add Node @ Help © System 3 Log out

Ml NEW SCRIPT TEMPLATE

TEMPLATE DETAILS

Name

Description

CONFIGURATION TEMPLATING N Seript timeout

Script checksum @
No script uploaded
Script size (kB) @
MULTIPLE INSTANCE No script upioadsd
NETOPS MODULES

UPLOAD SCRIPT FILE

5’ seTTnGs

3.
4.
5.

Script File @
Browse... | No file selected.

Note: To apply script templates, the selected nodes need to be running fimware version 4.1.1 or later.

Enter a Name and Description for a template in the Template Details section.

To select a script to upload, click Choose file.

Click Save Template. Script checksum and Script size are shown after template with uploaded
script is saved.

9.9 Modifying existing script templates

The Edit Script Template dialog allows the template’s Description, Script timeout, and Script File to be
uploaded. To modify an existing script template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Script Templates.
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@Help @ System 3 Logout

% opengear ® Add Node

Lighthouse™ Central Management

MONITOR SCRIPT TEMPLATES

& MANAGE Template Name Description Actions
L2 ] CONFIGURE ntp script pushes ntp settings , °
NODE ENROLLMENT - -
serial ports confi
po 9 ; °
Edit Tags
Edit Smart Groups
Delete Selected + c

Edit Managed Device Filters

CONFIGURATION TEMPLATING
Apply Templates
Authentication Templates

Script Templates

2. Click Edit in the Actions section of the template to be modified. The Edit Script Template dialog

appears.
% OP209¢0f ® Add Node @ Help @ System 3) Log out
Lighthouse™ Central Management
MONITOR EDIT SCRIPT TEMPLATE
5 MANAGE TEMPLATE DETAILS
CONFIGUI Name
NODE ENROLLMENT ntp script
Description
Ec oups pushes ntp settings

Edit Managed
] Script timeout ®

CONFIGURATION TEMPLATING
15
Apply Templates

Script checksum ®
Aut ation Templates

3d498d602292aaab29219d2a25730b3f36611d21
Script Templ

Users and G Templates Script size (kB) @

28 bytes
MULTIPLE INSTANCE

NETOPS MODULES
UPLOAD SCRIPT FILE

P sETTNGS

Script File @
Browse... No file selected.

Note: To apply script templates, the selected nodes need to be running firmware version 4.1.1 or later.

Cancel Save Template

3. Make required changes.
4. Click Save Template.

9.10 Deleting script templates

To delete a script template completely:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Script Templates.
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2. Click Delete in the Actions section of the template to be removed. The Confirmation alert box
appears.

CONFIRMATION

Are you sure you want to proceed with this action?

- K3

3. Click Yes in the Confirmation dialog. The script template is deleted.

9.11 Apply Templates

Users with Lighthouse Administrator privileges (i.e. users with the Lighthouse Administrator role or users
who are members of groups with the Lighthouse Administrator role) can access CONFIGURE >
CONFIGURATION TEMPLATING > Apply Templates and execute templates affecting any node.

Users with Node Administrator privileges (i.e. users with the Node Administrator role or users who are
members of groups with the Node Administrator role) can access CONFIGURE > CONFIGURATION
TEMPLATING > Apply Templates and execute templates affecting nodes in Smart Groups linked to their
role.

Apply Templates consists of four stages, each one a step in the overall wizard. The steps are:

Select Template.

Select Nodes.

Preflight. This test run simulates what happens if the template is pushed to the selected nodes.
Execution.

L=

To apply a template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Apply Templates.

©AddNode @Help O System 3 Logout

(2) monmor Ml APPLY TEMPLATES - SELECT TEMPLATE

=] Ml Select Template > ...
RS MANAGE P

CONFIGURE SELECT TEMPLATE TEMPLATE DETAILS

NODE ENROLLMENT ~ b Authentication Template Name

radius auth template ntp script
tacacs template Template Description
local template pushes ntp settings
Users and Groups
groups for dc region
groups for rc region
users and groups for DC
4= Script

E ors
CONFIGURATION TEMPLATING N m

Apply Templates serial ports con

NetOps Module Activation

Next - Select Nodes
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2. Select a template from the existing template tree. Template Details populates with details from
the selected template.
3. Click Next — Select Nodes. The Select Nodes stage loads.

©AddNode (D Help (O System 3 Logout

Ml APPLY TEMPLATES - SELECT NODES

Bl Select Tempiste > Select Nodes .

TEMPLATE NAME TEMPLATE DESCRIPTION

ntp script pushes nip settings

Q FILTERING

Smart Group Fitering Free Text Search

Script will be run on the Verify the content of the script befors executing.

Node la Name Status Info Actions

CONFIGURATION TEMPLATING

nodes-11 platypus Connected,
Last status change 39 seconds 192.168.1286
ago

]

00:13:c6:080e:4a
192.168.0.1
192.168.1.95

Unvatable

Back - Select Template Next - Prefight

4. Select nodes from the list of enrolled nodes. Smart Group Filtering and Free Text Search
Filtering can be used to narrow down the results.

The screenshot above shows filtering being used to set the list of enrolled nodes to match the set of
nodes an administrator wishes to deal with.

NOTE: Third-party nodes are not supported for template execution.

5. Click Next — Preflight. The Preflight stage loads. This stage requires manual refresh to retrieve
updated Preflight Result and Details.

After all nodes finish preflight, a success message appears and Next — Push Configuration
becomes active.

@Help ©System 3 Logout

\ opengear © Add Node

Lighthouse™ Central Mansgement

(2 MownTorR Ml APPLY TEMPLATES - PREFLIGHT

Bl Select Template > Select Nodes > Preflight > ...

TEMPLATE NAME TEMPLATE DESCRIPTION
ntp script pushes nip setlings
P profight i y ‘o
Prefight Resut Node Id Name sus Detals
a v nodes-11 pltypus Connected
Last status change 39 secands
ago0
c
Edit M:
CONFIGURATION TEMPLATING o
Back - Select Nodes. Next - Push Configuration

Apply Templates

6. Select desired nodes for template execution and click Next — Push Configuration. The
Configuration Status stage loads. This stage requires manual refresh to retrieve updated Push
Result and Details.
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After all nodes finish the template push, a success message appears.

Q opengear © Add Noda

@ Help
Uighthouse™ Central Management

@ System  3) Log out

:'.‘ MONITOR Ml APPLY TEMPLATES - CONFIGURATION STATUS

Bl Select Template > Select Nodes > Preflight > Configuration Status.

TEMPLATE NAME TEMPLATE DESCRIPTION

ntp script pushes ntp settings

Push Result Node Id Name Status Detais
nodes-11 vaty, e
v nodes-1 platypus Connected © |1 changets)
Last status change 39 seconds
ago Script executed succassfully

Configuration Template Run
Status: Success

CONFIGURATION TEMPLATING

9.12 Manually Activate Secure Provisioning or Software Defined Infrastructure via
Template

Users assigned to the Lighthouse Administrator role can manually apply the Secure Provisioning NetOps
Module or Software Defined Infrastructure to desired OPERATIONS MANAGER nodes.

1. As a Lighthouse administrator, choose CONFIGURE > CONFIGURATION TEMPLATING > Apply
Templates

2. Click Secure Provisioning or Software Defined Infrastructure under NetOps Module Activation.

% opengear

Lighthouse™ Central Management

MONITOR APPLY TEMPLATES - SELECT TEMPLATE

S MANAGE Select Template > ...

@ CONFIGURE SELECT TEMPLATE TEMPLATE DETAILS

NODE ENROLLMENT = Authentication Template Name

Edit Tags i Users and Groups Please choose a template from the list
Edit Smart Groups - Seript Template Description

Edit Managed Device Filters #~ NetOps Module Activation This template has no description

CONFIGURATION TEMPLATING Secure Provisioning

Software-Defined Infrastructure
Apply Templates

Authentication Templates

Click Next — Select Nodes

Choose the desired OPERATIONS MANAGER nodes by clicking the checkboxes next to them.
Click Next — Preflight. Refresh to ensure the preflight check has succeeded.

When preflight is complete, click Next - Push Configuration.

3.
4.
5.
6.
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10. Multiple Instance

This chapter discusses licensing, setup, configuration, promoting and disconnecting secondary
instances, and upgrading a multiple instance Lighthouse.

10.1 Licensing

Multiple instance functionality requires the installation of a valid license with the multiple instance
feature. This license must only be installed on the primary Lighthouse instance.

If a multiple instance license is not installed:
e The dependent Lighthouse instances page will display a banner on an empty page
e The multiple instance Lighthouse VPN page will display a banner but will allow the user to modify
the default VPN settings in case it conflicts with their network.

10.2 Setting up a multiple instance

Lighthouse supports up to 10 secondary instances for each primary.

1. Start with what will be the primary instance and one or more Lighthouse instances to act as
secondary. All instances must have the same version of Lighthouse. To support more than one
instance you must use 19.Q3 or later.

2. Configure the networking information for each instance (hostname, external endpoints, network
addresses).

3. Configure time settings of each instance.

4. Install a license with the multiple instance feature on the primary Lighthouse.

a. On the primary Lighthouse, click Configure > MULTIPLE INSTANCE > Dependent
Lighthouse Instances.

©AddNode @Help (O System 3 Logout

Ml DEPENDENT LIGHTHOUSE INSTANCES
Name Status Description Actions

There are currently no dependent Lighthouse Instances configured

Dependent Lighthouse Instances

b. Click Add. Enter the network address, username and password of a Lighthouse instance
to enroll as secondary. Optionally enter a valid, unused network subnet to use as the
dependent Ihvpn address range. If none is entered, a default will be assigned.
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 opengear ©AddNode @Hep O System 3 Logout

Uighthouse™ Central Management

MONITOR gl NEW DEPENDENT LIGHTHOUSE

DEPENDENT LIGHTHOUSE DETAILS

] conricure

Network Address @

NODE ENROLLMENT

Network Port @

443

Usemame @
root

Password ®

DEPENDENT LIGHTHOUSE VPN

VPN Network Range ®
Address space CIDR Subnet Mask Calculated Node capacity Actions

1721620 24 254 2

Note: The console server nodes must be running firmware version 4.4.1 or later o abtain Multiple Lighthouse Support

Cancel m

5. Dependent Lighthouse enrollment will show status as is moves from Pending > Registered >
Enrolled.

\\, opengear @®AddNode (@ Help (@ System 3 Logout
Lighthouse™ Centrat Management

MONITOR @l DEPENDENT LIGHTHOUSE INSTANCES

+/ Details saved successfully, LH may become unresponsive during enrollment

Name staus Description Actions
lighthouse-2 Falled - Network address is same 8s Primary  System Version, s e
Lightnouse. Network Address: 192.168.1.186

VPN Address Range: 172.16.2.0124
Number of Nodes: Unknown

MULTIPLE INSTANCE

Dependent Lighthouse Instances

6. When the VPN connection is established between primary and secondary Lighthouse, this page
will display Connected with the time since the last status change and Disconnected when the
connection is lost. Any errors in the enrollment process will be displayed in the status column.

% opengear © Add Node

Ughthouse™ Central Management

@Help O System  3) Logout

7) MONI DEPENDENT LIGHTHOUSE INSTANCES

Name Status Description Actions
I o e t o 4 Versi
[E] conrioume ighthouse-2 Connected: Last status change 42 seconds System Version: 20.01.000 s
ago Network Address: 192.4.3.1.96
NODE ENROLLMENT VPN Address Range: 172.16.2.0124

Number of Nodes: 0/6

CONFIGURATION TEMPLATING

MULTIPLE INSTANCE

Dependent Lighthouse Instances
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10.3 Multiple instance configuration

Lighthouse with multiple instance support requires multiple separate subnets for Lighthouse VPN
connections: between each instance and its nodes, and between the primary and dependent Lighthouses.
Each subnet must not overlap any subnet in use by another Lighthouse instance.

The subnet between the primary Lighthouse and its nodes is modified under Settings > SERVICES >
LIGHTHOUSE VPN on the primary Lighthouse. Calculated Node capacity displays the addressable nodes
based on the network address and CIDR mask.

\\( opengear © Add Node

Lighthouse™ Central Management

@Help O System 3 Log out

(=S LIGHTHOUSE VPN

[2] conricure
Editing these settings will interrupt node connections, it may take a few minutes for them to be restored

D
3> SETTINGS
NETWORK CONNECTIONS SETTINGS
USER MANAGEMENT VPN Network Range
SERVICES Address space CIDR Subnet Mask Calculated Node capacity Actions

8190
Cellular Health Reporting 192.168.128.0 19 o
e Gateway
Tunnel MTU @
HTTPS Certificate
; 1400
Lighthouse VPN
NetOps Modules Apply

Node Backup

A secondary Lighthouse is read-only and cannot be modified. The Settings > SERVICES > LIGHTHOUSE
VPN page displays the subnet used by this Lighthouse instance, but it cannot be modified directly.

The subnet between each secondary Lighthouse and its nodes can be modified on the primary
Lighthouse under Configure > MULTIPLE INSTANCE > Dependent Lighthouse Instances > Edit.

@Help O System ) Logout

\\( opengear © Add Node

Lighthouse™ Central Management

MONITOR EDIT DEPENDENT LIGHTHOUSE

RARAO= Editing these settings may break the connectivity between dependent Lighthouse and nodes
CONFIGURE
P DEPENDENT LIGHTHOUSE VPN
Edit Tags VPN Network Range
Edit Smart Groups Address space CIDR Subnet Mask Calculated Node capacity Actions
Edit Managed Device Filters 1721620 2 254

CONFIGURATION TEMPLATING

MULTIPLE INSTANCE The range for VPN tunnels between the dependent Lighthouse and nodes

Dependent Lighthouse Instances

coes | B0
Lighthouse VPN

NETOPS MODULES

The subnet between the primary Lighthouse and dependent Lighthouse instance can be modified on the
primary Lighthouse under Configure > MULTIPLE INSTANCE > LIGHTHOUSE VPN
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\\, opengear ® Add Node

Lighthouse™ Central Management

@Help @ System 2 Logout

MONITOR LIGHTHOUSE VPN
é MANAGE
CONFIGURE

NODE ENROLLMENT SETTINGS

Editing these settings may break connectivity between primary and dependent Lighthouses

Edit Tags Lighthouse VPN @
Edit Smart Groups Address space CIDR Subnet Mask Calculated Node capacity Actions
Edit Managed Device Filters

172.16.1.0 24 254 o
CONFIGURATION TEMPLATING

MULTIPLE INSTANCE Aﬂp'y
Dependent Lighthouse Instances
Lighthouse VPN

NETOPS MODULES

P seTTINGs

Other information that is specific to dependent Lighthouse should be configured before enrolling but can
be modified on the primary Lighthouse via ogconfig-cli.
Instance specific information includes:

e hostname

e time zone

e networking

e external interfaces

The instance specific information is present on both Lighthouses but read-only on the secondary
Lighthouse. Both configurations can be viewed via ogconfig-c1i.

Primary Lighthouse configuration is stored in lighthouse_configurations[0]
Secondary Lighthouse configuration is stored in lighthouse_configurations[1]

View all secondary Lighthouse instance specific configuration (can be run on either Lighthouse instance):

ogconfig-cli
print lighthouse configurations[1]

You can modify secondary configuration from primary Lighthouse. For example, to update the hostname
of the secondary Lighthouse, run the following commands on the Primary Lighthouse:

ogconfig-cli
set lighthouse configurations[l].hostname new name
push

10.4 Disconnecting a secondary instance

Dependent Lighthouse instances can be removed from the primary Lighthouse. To do so, click Configure
> MULTIPLE INSTANCE > Dependent Lighthouse Instances, and click the x button under Actions next to
the instance.

The secondary Lighthouse will begin unenrollment, which will factory reset the secondary Lighthouse. A
user will be required to enter a new root password via console when it reboots.
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You will need to manually remove the connection to the secondary Lighthouse from each connected
node. Clean dead connections from node side by clicking the Delete link in the Console Server.

\\( opengear

Serial & Network: Lighthouse

10.5 Promoting a secondary instance

When a primary Lighthouse is no longer reachable, a secondary Lighthouse instance can be promoted to
primary. The new primary can then be used to enroll a secondary Lighthouse if required.

NOTE: This should only be performed if the primary Lighthouse has no chance of returning, the procedure
is not reversible and will break all node connections with the previous primary instance. The previous
primary instance must be factory reset before it can be used again.

To promote a secondary instance to primary, login as root on the secondary instance via console or ssh
and run

promote-secondary-lighthouse

You will need to remove all dead connections from node side from the Console Server. The Promotion
tool deletes connection between primary and secondary instance but does not touch node connections.

The new primary can then be used to enroll a secondary Lighthouse if required.

NOTE: If the previous primary becomes accessible again, it will not be able to connect to its enrolled
nodes or the previous secondary Lighthouses.

10.6 Upgrading a multiple instance Lighthouse
To upgrade a Multiple Instance Lighthouse:
When the primary Lighthouse is updated, any secondary Lighthouses will be updated in a rolling fashion

after the primary has successfully booted. If any Lighthouse fails to successfully update along the way,
the update will stop.
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If the auto update fails, a manual update can be performed.

To upgrade a Lighthouse running version 5.3.0 with enrolled dependent instances, a script called
'sysflash_mi_upgrade_bootstrap.sh' which is provided with the Lighthouse 2019.Q2 or later release must
be used.

To upgrade the secondary independently of the primary:
1. Upload sysflash_mi_upgrade_bootstrap.sh script to the secondary Lighthouse instance.
2. Ensure that the script is executable
3. Runthe command as you would with sysflash. It can be passed a URL to the upgrade file or a
path to the file on the box.
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11. Command line tools
Lighthouse includes a web-based terminal. To access this bash shell instance:

1. Select MANAGE > LIGHTHOUSE > Local Terminal.

\\, opengear @AddNode @Help O System 3 Logout

Lighthouse™ Central Management

(@ woniTor LOCAL TERMINAL
§ MANAGE 1ghthouse login:

MANAGED DEVICES

Local Terminal

[2] conFicure

D
[ad) SETTINGS

2. Atthe presented login prompt, enter an administrator's username and press Return.
3. Apassword: prompt appears. Enter the administrator’s password and press Return.
4. A bash shell prompt appears.

This shell supports most standard bash commands and also supports copy-and-paste to and from the
terminal.

Lighthouse-specific shell-based tools are listed below.
node-command --list-nodes
Example node-command Output

== node-command ID 2017-05-19T14:08:33.360164 29534 ==
14:08:33 [SUCCESS] BNE-RO1-ACM7004-5 192.168.128.2:22
OpenGear/ACM7004-5 Lighthouse 3b90d826 —-- Tue May 9 13:42:16 EST 2017

14:08:33 [SUCCESS] BNE-R02-IM7216 192.168.128.3:22
OpenGear/IM72xx Lighthouse 3b90d826 -- Tue Jul 5 13:42:16 EST 20167

11.1 node-info
node-info is a shell-based tool for pulling more detailed information from console servers.
Example node-info output

$ node-info -A
BNE-RO1-ACM7004-5
address: 192.168.128.2
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id: nodes-1
ssh port: 22

description: Brisbane Rack 1

enrollment status:
connection status:

BNE-R02-IM7216

address: 192.168.128.3

id: nodes-2
ssh port: 22

Enrolled
Connected

description: Brisbane Rack 2

enrollment status:
connection status:

11.2 node-upgrade

Enrolled
Connected

node-upgrade is a tool for running bulk firmware upgrades on managed console servers.

By passing in required information — such as the firmware version to upgrade to, the location of the

firmware image to upgrade with, and the nodes to upgrade — via appropriate flags, node-upgrade can

upgrade the firmware on multiple console servers and report results back to STD 0UT with a single

command.

node-upgrade accepts twelve flags as follows:

-h --help

-q -—quiet

-b --batch

-1 --list-nodes

-1 —--node-id=ID

-n --node-name=name
-a —--node-address=address
-g --smartgroup=name
-A --all

-f ——firmware-dir

-v —--version

-z —-ignore-version

An example node-upgrade run

Display this message

Suppress command output

Suppress node-command output

List all nodes matching query, or all nodes if none selected
Select node by config ID

Select node by name

Select node by VPN address

Select nodes by the smart group they resolve to
Select all available nodes

The directory of the firmware file(s)

The firmware version to upgrade to

Ignore firmware version warnings for upgrade

The following is an example node-upgrade command. It sets /mnt/nvram/ as the directory node-
upgrade looks to for the firmware image used as the source for all the firmware upgrade attempts. Every
console server being managed from the active Lighthouse instance is targeted for an upgrade and the
target console servers are set to upgrade to firmware 4.1.0.

# node-upgrade -A -f /mnt/nvram -v 4.1.0

When run, node-upgrade returns information to STD 0UT, such as the following:
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Upgrading firmware for device family: ACM550X

Upgrading firmware for device family: CM71XX

Upgrading firmware for device family: CM7196

Upgrading firmware for device family: ACM7004-5

Upgrading firmware for device family: IM72XX

im7208: flashing firmware file: im72xx-4.1.0.flash

[FAILURE] acm5508: not upgraded to OpenGear/ACM5508-2 version 4.1.0.
Reason for failure: No firmware available for ACM550X device family.
[FAILURE] cm7148: not upgraded to OpenGear/CM7148-2-DAC version 4.1.0.
Reason for failure: netflash failed due to the same firmware currently
on the device.

[FAILURE] cm7196: not upgraded to OpenGear/CM7196A-2-DAC version
4.1.0. Reason for failure: netflash failed due to the same firmware
currently on the device.

[FAILURE] acm7004: not upgraded to OpenGear/ACM7004-5-LMR version
4.1.0. Reason for failure: netflash failed due to the same firmware
currently on the device.

[SUCCESS] im7208: upgraded to OpenGear/IM7208-2-DAC-LR version 4.1.0.

node-upgrade returns status codes 0 (success) or 1 (failure) when particular conditions are met.
Exit code 0 (success) is returned under the following conditions:

Success

Successful upgrade of all nodes.

No nodes selected for upgrade.
No firmware found in nominated directory.

Exit code 1 (failure) is returned under the following conditions:

e Missing or invalid command line options.
e The current user is not authorized to execute commands on a node.
e The specified firmware directory was invalid (i.e. because it does not exist or is not readable).
e Atleast one node upgrade failed.
11.3 ogadduser

ogadduser is a shell-based tool for creating users.
Basic ogadduser usage syntax is as follows:
$ ogadduser -u testuser -p mypassword -g admin

NOTE: When a new user is created via ogadduser, an entry is added to the syslog.
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11.4 ogconfig-cli

ogconfig-cli allows users to inspect and modify the configuration tree from the command line. It is
transactional in nature, allowing users to ensure their configuration is correct before pushing it to the
configuration server.

As the root user, start the tool with:

ogconfig-cli

11.4.1 Commands to try from within the ogconfig-c1i tool

e help

e get

e print . 2

e print users[0].username
e find users enabled false

11.4.2 Config searches using ogconfig-cli

Simple config searches can be performed from inside ogconfig-c1i with the find command.
NOTE: The element being searched must be a list, otherwise the command returns an error.

The syntax is:

find <path of list to search> <element to search for> <value to search for>
For example, to find enabled users use:

ogcfg > find users enabled true

Or to find the enabled ports on a particular node set:

ogcfg> find nodes[0].ports mode 'ConsoleServer'

11.4.3 Changing a configuration from within ogconfig-cli

From inside ogconfig-cli:

ogcfg> set system.hostname "opengear-lighthouse-new"
ogcfg> push

ogcfg> quit

To see that the change has taken effect:

$ cat /etc/hostname
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A configuration change doesn't take effect until it is pushed to the configuration server. For example,
from inside ogconfig-cli:

ogcfg> set system.hostname "opengear-lighthouse-new-again"
ogcfg> print system.hostname
ogcfg> quit

To verify that the change did not yet take effect:
$ cat /etc/hostname
11.4.4 Configuration validation from within ogconfig-cli

Configuration is validated before being applied so that an incorrect configuration cannot be accidentally
set. For example, from inside ogconfig-cli, setting an invalid ethernet link speed is rejected:

ogcfg> set system.net.physifs[0].ethernet.link speed "1GB"
ogcfg> push
Commit failed
Messages: String is not in the list of allowed values
Push command failed

ogcfg> quit

11.4.5 Modify LHVPN keepalive timeout for different sized deployments with ogconfig-cli

The lhvpn timeout (in seconds) should be adjusted depending on the number of nodes to ensure stable
connections are maintained. We recommend these settings:

Fewer than 100 nodes: timeout = 60
100 to 599 nodes: timeout = 120
600 to 1199 nodes: timeout = 240
1200 to 2200 nodes: timeout = 360

The lhvpn timeout can be modified by running the following commands, where <timeout val> isthe
number of seconds:

ogcfg> set services.lhvpn.server.keepalive.timeout <timeout val>
ogcfg> push

NOTE: VPN connections will be restarted after pushing a new timeout value.

11.4.6 Support for mounting the hard disks with ogconfig-cli

Extra hard disks can be mounted in the Lighthouse VM by adding them to the configuration. Each new
disk needs to have a partition created and formatted. Partitions can be created using £disk or cfdisk,
and should be formatted using the ext4 filesystem, using the mk fs.ext4 command:
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root@lighthouse:~# mkfs.ext4 /dev/sdbl

The directory in which to mount the filesystem must be created. In general, new filesystems should be
mounted in the provided mountpoint of /mnt /aux. Any other filesystems should be mounted within the
filesystem mounted here.

Add the information to the configuration system using ogconfig-cli as follows, modifying the path for
the specific situation.

ogcfg> var m !append system.mountpoints map
{8435270-fb39-11e7-8fcf-4fal1570959}: Map <>

ogcfg> set {m}.node "/dev/sdbl"
{b8c37¢c6-fb39-11e7-971c-23517b19319}: String </dev/sdbl>
ogcfg> set {m}.path "/mnt/aux"
{1fb50d8-fb39-11e7-994c-0£10b09%cbd4}: String </mnt/aux>
ogcfg> push

OK

11.4.7 Support for multiple instance Lighthouse with ogconfig-cli

Configuration system information can be displayed, searched, and set from both the primary and
secondary Lighthouse instances. To reference the primary instance, use

lighthouse configurations[0]. The secondary instance is reachable with

lighthouse configurations[1].

For example, to display nodes all network connections to the primary Lighthouse, use:

ogcfg> print lighthouse configurations[0].system.net.conns

11.5 oglicdump

oglicdump is a shell-based tool for displaying and saving the current third-party licensing status of a
Lighthouse instance.

When used without a switch, oglicdump writes the current status to STD OUT.

To write this status out to a file, or in machine readable form, or as a raw license container string, or to
write out a sub-set of the licensing information (such as licenses for a given SKU), use one of the
switches oglicdump supports:

-h Displays this help.

-v Display version information

-0 <file> File to write out to. Default is stdout.

-s <SKU> Specific SKU code to dump out. Default is all SKU codes.

-f <feature> Specific feature value to dump out. This is only valid in conjunction with -s.
-c Output contacts only. This is only valid in conjunction with -s.

-m Output machine readable, as in compact formatted.

-r Output the raw license container strings from config.
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11.6 cron

The cron service can be used to schedule file execution at specific times. Daemon can be managed via
the /etc/init.d/crond interface, and cron tables managed via crontab.

Usage:

crontab [options] file
crontab [options]
crontab -n [hostname]

Options:

-u <user> define user

-e edit user's crontab

-1 list user's crontab

-r delete user's crontab

-1 prompt before deleting

-n <host> sethostin cluster to run users' crontabs
-c get host in cluster to run users' crontabs

-x <mask> enable debugging

To perform start/stop/restart on crond service:

/etc/init.d/crond start

To verify the current crond status:

/etc/init.d/crond status

To check current cron jobs running with the following command to list all crontabs:
crontab -1

To edit or create a custom crontab file:

crontab -e

This opens a personal cron configuration file. Each line can contain one command to run. The following
format is used:

minute hour day-of-month month day-of-week command
For example, the following entry will run a the specified backup. sh script every day at 3am:
0 3 * * * /etc/config/backup.sh

When finished, save and close the crontab file.



102
Lighthouse User Guide

11.7 sysflash
sysflash is the shell-based tool for upgrading a Lighthouse instance’s system.

Basic syntax is as follows:
# sysflash [flags] [path/to/system-image.lg_upg | Percent-encoded URL to firmware-image.lg_upg]

NOTE: URLs must be Percent-encoded and image filenames cannot include spaces.

sysflash includes eight flags which modify the standard upgrade behavior as well as the -h or --help
flag, which returns all the available flags and their effects:

-b, --board-name <name> Override board name (currently 1ighthouse-vm)
-B, --board-revision <version> Override board revision (currently 1.0)

-V, --vendor <vendor> Override vendor (currently opengear)

-I, --no-version-check Do not check software version for upgradability
-m, —--no-migration Do not migrate current config. Start fresh.

-v, --verbose Increase verbosity (may repeat)

-0, --no-boot-once Do not modify bootloader (implies --no-reboot)
-r, —--no-reboot Do not reboot after upgrading

-h, --help Print this help

11.8 Selecting nodes using shell-based tools

There are a number of ways to select nodes, also known as console servers, as targets on which to run a
command. These can be used multiple times, or together, to select a range of console servers:

Select individually by name, address, Lighthouse VPN address, config index or smart group (as per -list-
nodes output):

node-command --node-name BNE-R01-IM4248
node-command --node-address 192.168.0.33
node-command --node-index nodes-1
node—-command --smartgroup="model-acm"

11.8.1 Select all nodes
node-command --all
11.8.2 Running commands on selected nodes

Once nodes are selected, the commands to be run for each can be given. These are run on each managed
node in parallel. Any command which can be run from a node shell can be run on each managed node.

NOTE: All commands are run as root.

For example, to check the version on two specific, configured nodes, selecting one by name and the other
by index, run the following command:
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node-command —--node-name BNE-R01-ACM7004-5 --node-index nodes-2 cat
/etc/version

NOTE: When using non-trivial selection arguments, check which target nodes have been selected on the
initial command pass by using the --1ist-nodes switch rather than the final command.
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12. System upgrades
A Lighthouse appliance’s system can be upgraded using a . 1h_upg image file.

NOTE: Although upgrades do not overwrite existing configurations or user files, you should perform a
Configuration Backup prior to upgrading.

Once the upgrade is complete, the Lighthouse instance reboots. It is unavailable during the reboot
process.

12.1 Upgrading the system from within Lighthouse
To upgrade a Lighthouse instance’s system using the Lighthouse Ul:

1. Select SETTINGS > SYSTEM > SYSTEM Upgrade.
2. Select the Upgrade Method, either Fetch image from HTTP/HTTPS Server or Upload Image.

\\, opengear ®AddNode @Help O System 3 Logout

Lighthouse™ Central Management

SYSTEM UPGRADE

SYSTEM UPGRADE

Remember to perform a system snapshot using the system hypervisor before upgrading the system image. During the upgrade, the appliance
will reboot and will be unreachable for several minutes.

o
&7 SETTINGS System images must have the extension .Ih_upg.

NETWORK CONNECTIONS Upgrade Method

USER MANAGEMENT Fetch image from HTTP/HTTPS Server
SERVICES Image URL

DATE & TIME

SYSTEM

ADVANCED OPTIONS

Administration

Upgrade Options @

] Perform Upgrade

System Upgrade

If upgrading via Fetch image from HTTP/HTTPS Server:

1. Enter the URL for the system image in the Image URL text-entry field.
2. Click Perform Upgrade.

Or if upgrading via Upload Image:

1. Click the Choose file button.

2. Navigate to the directory containing the system-upgrade-image.lh upg file.
3. Selectthe system-upgrade-image.lh upg file and press Return.

4. Click Perform Upgrade.

NOTE: The Advanced Options section, which expands to present an Upgrade Options text-entry field,
should only be used if a system upgrade is being performed as part of an Opengear Support call.
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Once the upgrade has started, the System Upgrade page displays feedback as to the state of the process.

A system upgrade attempt returns the error System version was not higher than the current version if the
selected image file is not a more recent version than the installed version.

12.2 Upgrading the Lighthouse system via the Local Terminal

Lighthouse includes a shell-based tool — sysflash — that allows a user with administrative privileges to
upgrade the instance’s system from the Local Terminal.

To upgrade Lighthouse instance’s system using the Lighthouse Local Terminal:
1. Select MANAGE > LIGHTHOUSE > Local Terminal.
2. Atthe [hostname] login: prompt, enter an administrator username and press Return.
3. Atthe password: prompt, enter the administrator's password and press Return.
4. Touse sysflashin conjunction with a.lh upg file available via an HTTP or HTTP server:

At the Local Terminal bash shell prompt, enter a URL. It must be URL-encoded:

sysflash http[s]%$3A%2F%2Fdomain.tld%2Fpath%2Fto%2Ffirmware-upgrade-
image.lh upg

5. Press Return.
To use sysflash in conjunction with a.1h_upg file available via the local file system:
1. At the Local Terminal bash shell prompt enter:
sysflash /path/to/system-upgrade-image.lh upg.
2. Press Return.

NOTE: sysflash includes several flags that allow for variations in the standard system upgrade
process. These flags should not be used unless directed to do so by Opengear Support.

Flags are listed by running either of the following at a Local Terminal bash shell prompt:
e sysflash -h or

e sysflash --help
e The same listing is presented in the sysflash entry of the Command line tools chapter above.
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13. Troubleshooting

13.1 Finding the current Lighthouse instance version

13.1.1 Using the web Ul

1. Click System on the top right of the Lighthouse instance’s web Ul.
2. The Details menu appears, listing the Lighthouse instance’s Current version, REST API version,
Hostname, and Current user.

® AddNode @Help @ System 2 Logout
DETAILS

Current version: 20.Q1
REST API version: v3.4
Hostname: lighthouse

Current user: root

13.1.2 Via the local Lighthouse shell

Click MANAGE > LIGHTHOUSE > Local Terminal

Atthe [hostname] login: prompt, enter an administrator username and press Return.
At the Password: prompt, enter the administrator's password and press Return.

At the bash shell prompt, enter cat /etc/version and press Return.

Eal N

The current Lighthouse instance’s version is returned to STD OUT. For example:

root@lighthouse:~# cat /etc/version
2020.01.0

NOTE: The procedure above uses the Web Ul to reach the Lighthouse Local Terminal. This is not the only
way to reach the Lighthouse shell and cat /etc/version works in any circumstance where an
administrator has access to the Lighthouse shell. For example, many of the Virtual Machine Manager
applications that can run a Lighthouse instance offer virtual console access. If this is available and an
administrator logs in to the Lighthouse shell via this console, the command string works as expected.

13.1.3 Other information sources related to a Lighthouse instance’s version

Two other command strings can be useful when specifics about a particular Lighthouse instance are
needed.

Both these commands can be run by an administrator with access to a running Lighthouse instance’s
bash shell.

Firstis cat /etc/sw*. This command concatenates the following four files to STD 0OUT:
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/etc/sw_product
/etc/sw_variant
/etc/sw_vendor

/etc/sw_version

For example:

# cat /etc/sw*
lighthouse
release

opengear
2020.01.0

Secondis cat /etc/issue. /etc/issue is a standard *nix text file which contains system
information for presenting before the system’s login prompt. On a Lighthouse instance, etc/issue
contains the vendor, and the Lighthouse/Lighthouse version

# cat /etc/issue
Opengear Lighthouse 2020.Q1.0 \n \1

13.2 Technical support reports

Lighthouse can generate a technical support report that includes Lighthouse configuration information
and the current system log for the Lighthouse VM.

In the case of contacting the Opengear Technical Support, the support technician may ask for this report.
13.2.1 Generate a support report via the Lighthouse interface

To generate a complete configuration and status report regarding a given Lighthouse VM:

1. Select Help > Technical Support Report.

@® AddNode @@ Help @ System 2 Log out

HELP AND SUPPORT

Technical Support Report

User Manual

Lighthouse generates this support report on demand and the report includes the current system log.
This process can take several minutes.

2. Click Download support report.
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Q opengear

Lighthouse™ Central Management

MONITOR TECHNICAL SUPPORT REPORT

S MANAGE Download support repon\b

CONFIGURE SUPPORT REPORT

NODE ENROLLMENT

*xx System time sk
Thu Feb 6 83:25:08 2020

Enrolled Nodes

This downloads a PKZip archive to the local system. The archive'’s filename is structured as follows:
support-[host-name]-[iso-8601-order-date-and-time-stamp].zip
It contains two files:
» system.txt — the configuration information also presented in the Technical Support Report
window.

* messages — the current Lighthouse VM system log.

The two files are also presented in the Support Report text box below the Download support report link.
Because the report includes the current system log, this is a long but scrollable presentation and is
searchable using the web browser’s built-in search function.

13.2.2 Generate a support report via the local terminal

To generate a complete configuration and status report regarding a given Lighthouse VM:

Select MANAGE > LIGHTHOUSE > Local Terminal.

Atthe [hostname] login:prompt, enter an administrator username and press Return.
At the password: prompt, enter the administrator’'s password and press Return.

At the bash shell prompt, enter

HoOdp =

support-report -z > /tmp/support.zip
and press Return

The -z switch generates the same combined file produced by the Download support report link noted in
the Lighthouse Ul-specific procedure.

NOTE: In the example above, the redirect saves the generated PKZip file to /tmp/support.zip.
However, be aware that the /tmp directory is deleted during a reboot, so the file might be saved to a
different location.

Here are two options for copying the file from Lighthouse:

e Use SCP from a Mac or Windows client. As scp only requires ssh access, no additional
configuration is required on Lighthouse for this to work.

$ scp root@192.168.0.2:/tmp/support.zip
root@192.168.0.2's password:
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support.zip 100% 321 604 .0KB/s 00:00
For Windows users, WinSCP on Win10 also works.

e Use the FTP client on Lighthouse to copy the file to an FTP server. Passive mode must be used
for this to work. Example:

root@LH5-UK-Lab:/tmp# ftp

ftp> open 192.168.0.216

Connected to 192.168.0.216.

220 im7200-demo-uk FTP server (GNU inetutils 1.4.1) ready.
Name (192.168.0.216:root): fred

331 Password required for fred.

Password:

230- *** Opengear UK Demo IM7216 ***

230 User fred logged in.

Remote system type is UNIX.

Using binary mode to transfer files.

ftp> passive

Passive mode on.

ftp> bin

200 Type set to I.

ftp> put support.zip

227 Entering Passive Mode (192,168,0,216,208,166)

150 Opening BINARY mode data connection for 'support.zip'.
226 Transfer complete.

4132664 bytes sent in 0.128 seconds (32262492 bytes/s)
ftp> quit

221 Goodbye.

13.3 Configuration Backup

Before performing a factory reset or system upgrade, you may want to backup the current Lighthouse
configuration. To do so:

1. Select Settings > SYSTEM > Configuration Backup.
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§ opengear OadiNode OHop O Systam 5 Logout
Lighthouse™ Central Management
MONITOR CONFIGURATION BACKUP
MANAGE BACKUP
[#] conFicure
= © Encrypt Backup @
D
P sETTINGS Password
NETWORKCONNECTIONS . [
USER MANAGEMENT Confirm Password
SERVICES
DATE & TIME
ADVANCED
SYSTEM
Administration User Files @
Factory Reset
Licensing
Configuration Backup 4
Configuration Restore Download Backup

System Upgrade

2.
3.

If desired, check Encrypt backup. Enter and confirm a password.
Under the Advanced section, specify the paths to any User Files you also wish to include in the

backup.
4. Click Download Backup and save this file. The filename consists of a timestamp and 1h_bak

extension, for example: 1ighthouse-20190710100325.1h_bak

13.4 Configuration Restore

To restore the configuration and user files you backed up using Configuration Restore:

1. Select Settings > SYSTEM > Configuration Restore.

% opengear ® Add Node

Lighthouse™ Central Management

@Help O System 3 Log out

MONITOR CONFIGURATION RESTORE

MANAGE RESTORE

CONFIGURE During the restore procedure, the appliance will reset all configuration data and will be unreachable for several minutes.

é” SETTINGS Backup File ®
NETWORK CONNECTIONS Browse...  No file selected
USER MANAGEMENT Backup Password @
SERVICES v [
DATE & TIME
SYSTEM

Administration

Factory Reset

Licensing

Configuration Backup

Configuration Restore

2. Locate the file you downloaded when you performed the Configuration Backup.
3. If you chose Encrypt backup when creating the backup, enter the Backup Password.
4. Click Restore Backup.
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Configuration Restore In Progress

Please wait.

+ The system configuration has been restored.
« Lighthouse has been restarted.
« Complete.

5. Lighthouse will restore the backup and any included user files and restart.

13.5 Returning a Lighthouse instance to factory settings

NOTE: During this process, the current Lighthouse configuration will be overwritten and user files will be
deleted. If you wish, you can create a backup of the configuration and any desired user files.

To return an enrolled console server to its factory settings using Lighthouse:

1. Login to the Lighthouse web-based interface as root. Other users, even those with full
administrative privileges, do not have the permissions required to reset the Lighthouse VM to its
factory settings.

2. Select SETTINGS > SYSTEM > Factory Reset.

\ opengear ® Add Node

Lighthouse™ Central Management

@ Help © system 2 Log out

7) MONITOR FACTORY RESET

=5 MANAGE WARNING

]% CONFIGURE This will delete all configuration data from the system and reset all options to the factory defaults. Any custom data or scripts on the device will

o be lost. Please check the box below to confirm you wish to proceed.
3> SETTINGS
Proceed with the factory reset
NETWORK CONNECTIONS

USER MANAGEMENT

SERVICES

DATE & TIME

SYSTEM

Administration

Factory Reset

3. Select the Proceed with the factory reset checkbox.
4. Click Reset.

Running the following shell script as root performs a full factory reset:
/usr/bin/factory reset

This script prompts for confirmation before performing the factory reset. The factory reset procedure and
the shell script are equivalent to logging in to a console server's web-based management interface (see
Connecting to a console server’s web-management interface above) and doing the following:

1. Select Administration
2. Check the Config Erase checkbox.
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3. Click Apply.

NOTE: Returning a console server to its factory settings in this fashion does not un-enroll the server from
the Lighthouse VM.

NOTE: The latest User Manual can be downloaded from the Opengear documentation page at
opengear.com/support/documentation. It can be accessed by Help > User Manual link in the top bar
menu.
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14. EULA and GPL

The current Opengear end-user license agreement and the GPL can be found at
http://opengear.com/eula.




