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1.1. TTerminologyerminology

1.11.1 The Lighthouse table of namesThe Lighthouse table of names
In the Lighthouse User Manual various terms are used to define different elements and concepts of the Lighthouse sys-
tem. These are listed in the table below

TTermerm DefinitionDefinition

Enrollment Enrollment is the process of connecting a node to Lighthouse

Enrollment
Bundle

An Enrollment Bundle is used to assign a number of tags to a set of nodes when they are en-
rolled. During enrollment, the bundle is specified using its name, and a bundle-specific enroll-
ment token

Enrolled
Node

An Enrolled Node is a node that has been connected to Lighthouse, and is ready for use.

Enrollment
Token

An Enrollment Token is a password, used when performing Node-based, or ZTP enrollment, that
authorizes the Node with Lighthouse.

Lighthouse
Ironman

Lighthouse Ironman refers to the 5.1 and newer releases of Lighthouse. Re-written from the
ground up, it provides a solid basis for accessing, managing and monitoring Opengear console
servers.

Lighthouse
VPN

The Lighthouse VPN is the OpenVPN based connections that the Lighthouse instance has with
the nodes it is managing

Managed
Device

A Managed Device is a device that is managed via a Node through a Serial, USB, or Network con-
nection.

Node
A Node is a device that can be enrolled with Lighthouse, allowing it to be accessed, managed, and
monitored. Currently, Opengear Console Servers are supported on a standard license, with sup-
port for other vendors Console Servers available as an add-on.

Pending
Node

A Pending Node is a node that 1) has been connected to Lighthouse and 2) has been configured
with a VPN Tunnel, but which has not yet been approved for access, monitoring, or management.
The approval operation can be automated by configuring Lighthouse to auto-approve nodes.

Role
A Role defines a set of access rights for a particular group. Currently, 3 Roles are defined within
Lighthouse Ironman: Lighthouse Administrator, Node Administrator, and Node User.

Smart
Group

A Smart Group is a dynamic filter used to search for particular nodes, or for defining the access
rights of a group of users. Smart Groups use node properties, as well as tags defined by users.

Tag
A Tag is a user-defined attribute and value that is assigned to one or more Nodes. Tags are used
when creating Smart Groups for filtering views or access to Nodes
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2.2. Lighthouse oLighthouse ovverviewerview

2.12.1 Opengear Lighthouse VM 5.1.0 host requirementsOpengear Lighthouse VM 5.1.0 host requirements
Opengear Lighthouse deploys as an application running in a Linux-based virtual machine (VM). The Opengear Light-
house binary is available in both open (for VM managers such as Boxes, KVM, and VirtualBox) and VMware-specific Vir-
tual Machine formats.

To run an Opengear Lighthouse VM, your host computer must be able to run a VM manager and at least one, full, 64-bit
Linux-based virtual machine.

Specific minimum hardware requirements include:

64-bit CPU with at least 2 cores

1 GB available RAM

2.22.2 Lighthouse architectureLighthouse architecture
Opengear Lighthouse 5.1 provides a platform for centrally accessing, managing, and monitoring Opengear console
servers.

Console servers connect to a central Lighthouse instance over an OpenVPN tunnel, and are accessed, managed, and
monitored via services transported over the VPN tunnel. In Lighthouse terminology, the console server is referred to as
the Node.

2.2.12.2.1 Lighthouse to Node interLighthouse to Node interactionsactions

For management and monitoring operations, Lighthouse queries and pushes data to and from a REST API on the node.

When a node is initially enrolled in Lighthouse, Lighthouse generates an X.509 certificate. This certificate authenticates
the OpenVPN tunnel, and provides the node access to the Lighthouse REST API. The node also imports a Certificate Au-
thority from Lighthouse, and uses that to allow Lighthouse access to the node’s REST API. Lighthouse also provides a
public SSH key to the node, which allows Lighthouse to access the node’s serial ports via SSH

For serial access, a node’s serial port subsystem is connected to via SSH. Users can also access the node’s Web UI, which
is reverse proxied through the VPN tunnel.
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2.2.22.2.2 User to Lighthouse interUser to Lighthouse interactionsactions

Users interact with Lighthouse via an Ember.js Javascript application, which communicates with Lighthouse via a REST
API. This REST API can integrate Lighthouse into other systems. Documentation for this API is available to allow for di-
rect customer use.

2.2.32.2.3 Node organisation and filteringNode organisation and filtering

To help search, organise, and filter access to nodes, Lighthouse has a concept called Smart GroupsSmart Groups, which allow node
properties, as well as user supplied tagstags (which consist of a tag name and value) to be compiled into a search expression.

These search expressions can be saved and used to filter the various lists of nodes in the WebUI (for example, when se-
lecting a serial port to connect to, or to connect to the node’s WebUI). They can also be used for selecting the nodes that
a particular group of users will have access to.
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3.3. Opengear Lighthouse VM installationOpengear Lighthouse VM installation

3.13.1 Opengear Lighthouse VM 5.1.0 componentsOpengear Lighthouse VM 5.1.0 components
Opengear Lighthouse VM 5.1.0 comes in one of four formats:

01. An Open Volume Format file — lighthouse-5.1.0-ovf.zip — inside a PKZip archive. This is for use with vir-
tual machine managers such as KVM and Virtual Box.

02. A VMware configuration file — lighthouse-5.1.0-vmx.zip — also inside a PKZip archive. This is for use
with virtual machine managers from VMware.

03. A raw (.hdd) file, lighthouse-5.1.0-raw.hdd.xz. This file has been compressed with xz and is for use with
hosting services such as ElasticHosts.

04. An Open Virtual Appliance file — lighthouse-5.1.0.ova. This is for use with virtual machine managers such
as VM and Virtual Box as well as for use with virtual machine managers from VMware.

Not every possible combination of host platform and virtual machine manager is, as yet, documented. Also, if an install
procedure is not documented in this manual it does not mean a particular combination of host and virtual machine man-
ager won’t be supported when Opengear Lighthouse 5.1.0 is formally released.

Note: the Lighthouse 5.1.0 user manual uses macOS to denote the operating system shipped with Apple’s desktop and
notebook computers. At the time of writing macOS Sierra 10.12.4 and OS X El Capitan 10.11.6 are both still sup-
ported by Apple. Unless specifically noted, a reference to macOS should be read as referring to both of Apple’s
currently supported operating systems (ie 10.12, macOS, and 10.11, OS X).

3.23.2 VMWVMWare vSphere 6.0 via the VMWare vSphere 6.0 via the VMWare vSphere 6.0 client on Windowsare vSphere 6.0 client on Windows
Note: This procedure assumes VMWare vSphere 6.0 is installed and running on available hardware. It also assumes you

have access to a Windows computer on which the VMWare vSphere 6.0 client is installed and that this installed
client application can connect to and manage the VMWare Sphere 6.0 instance noted above. Finally, this proce-
dure assumes a copy of the Lighthouse 5.1 binary in Open Volume Format (the .ovf file) is available. In particular,
the procedure assumes the binary has been copied to the Windows computer running the VMWare vSphere 6.0
client. Having the binary available via a URL will also work, however.

Note: this procedure was tested using the VMware Sphere Client 6.0 running on Windows 7 Enterprise SP 1.

3.2.13.2.1 Launch theLaunch the vSphere ClientvSphere Client and connect to a vSphere instance.and connect to a vSphere instance.

01. launch the VMware vSphere Client.

When VMware Sphere 6.0 Client is installed, a shortcut to the client is, by default, added to the Start Menu as fol-
lows:

Start > All ProgrStart > All Programs > VMware > VMware vSphere Clientams > VMware > VMware vSphere Client

Depending on any customisation performed or previous actions taken, other means of launching the client may be
available but the default shortcut location should work.

02. The VMware vSphere Client presents a login prompt.
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03. Select the IP address or Name of the VMware vSphere instance onto which you wish to install Lighthouse 5.1 from
the IP address/Name pop-up menu.

04. Enter the user name and password required to gain management privileges to the selected VMware vSphere in-
stance in the User name and Password fields.

05. Click the LLoginogin button, or press ReturnReturn.

06. The login window displays progress text in the bottom left corner. For example:

Connecting…
Loading inventory…
Loading main form…
Displaying main form…

07. The vSphere main form window opens.

3.2.23.2.2 Import the Lighthouse 5.1 VM Open VImport the Lighthouse 5.1 VM Open Volume Folume Format (.oormat (.ovf) imagevf) image

01. From the vSphere Client menu bar choose File > Deploy OVF Template….

02. The DeploDeploy Oy OVF TVF Templateemplate window presents, with the first stage, Source, pre-selected.

03. Click the Browse…Browse… button.

An OpenOpen dialogue box presents.

04. Navigate to the directory containing the file Opengear Lighthouse VM.ovf.

In the screenshot below, for example, this file is in c:\Users\%USERNAME%\My Documents\Iron-
man.ovf\Opengear Lighthouse VM\.
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05. Select the file Opengear Lighthouse VM.ovf and click OpenOpen.

06. The DeploDeploy Oy OVF TVF Templateemplate window presents again, with the Opengear Lighthouse VM.ovf file listed in the
Deploy from a file or URL combo-box.

Note: if the required .ovf file is not stored on the computer running the vSphere Client, but is, instead, available on a re-
mote computer via a URL, enter said URL in the Deploy from a file or URL field rather than taking steps 3 through
6 above.

07. Click NeNextxt.

08. The OVF Template Details stage presents, showing basic information about the Opengear Lighthouse VM encap-
sulated by the .ovf file.

09. Click NeNextxt.

10. The Name and Location stage presents with the Name field pre-populated and pre-selected.

11. The default name is Opengear Lighthouse VM.

To change this, type a new name (by default the Name text field is active and the default name is selected).

12. Click NeNextxt.

13. The Disk Format stage presents, showing which datastore the Opengear Lighthouse VM’s virtual disk uses, how
much free space the virtual disk has available and which provisioning scheme is being used.

14. Click NeNextxt.

15. The Network Mapping stage presents, showing which Destination (or inventory) network the Opengear Light-
house VM’s virtual network is mapped to.

16. Click NeNextxt.

17. The Ready to Complete stage presents, listing the basic properties of the about-to-be-deployed virtual machine.

18. Click FinishFinish.

To power-up the new virtual machine immediately after deployment, check the Power on after deployment check-
box and then click FinishFinish.

19. The Deploying Opengear Lighthouse VM progress bar presents.
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20. Once deployment has finished the Deployment Completed Successfully alert appears.

21. Click CloseClose.

22. The new virtual machine is now deployed and appears in the inventory list.

3.2.33.2.3 Launch the Opengear Lighthouse 5.1.0 virtual machineLaunch the Opengear Lighthouse 5.1.0 virtual machine

The vSphere Client provides at least three ways of launching a Virtual Machine hosted on a vSphere instance.

All three ways begin with the same first step:

01. Select the Opengear Lighthouse VM from the vSphere Client’s inventory list.

The selected VM can then be launched by doing one of the following:

01. Select InInvventory > Virtual Machine > Pentory > Virtual Machine > Power > Power > Power Onower On.

02. Press Ctrl-BCtrl-B.

03. Click the Power on the virtual machine link in the Basic TBasic Tasksasks section of the Getting StartedGetting Started tab.

This option requires the Getting StartedGetting Started tab be front-most. If it is not already the front-most tab, make it active by
clicking it.

04. Select InInvventory > Virtual Machine > Open Consoleentory > Virtual Machine > Open Console and then:

Click the PPower Onower On button in the console tool bar or

Choose VM > PVM > Power > Power > Power Onower On from the console menu bar or

Press Ctrl-BCtrl-B.

Note: only the fourth option above results in the running virtual machine being accessible from within the vSphere
Client. The first three boot the Opengear Lighthouse VM and get it running headless.

3.2.43.2.4 Access the console of a running but headless Opengear Lighthouse instanceAccess the console of a running but headless Opengear Lighthouse instance

If direct interaction with a running but headless *Opengear Lighthouse VM* is required, open a console window by

01. Select the running Opengear Lighthouse VM in the vSphere Client’s inventory list.
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Then do one of the following:

02. Select InInvventory > Virtual Machine > Open Consoleentory > Virtual Machine > Open Console or

03. Right-click and select Open ConsoleOpen Console from the contextual menu that presents.

Note: a running Opengear Lighthouse VM is almost certainly running a bash shell with no other interactive options. As a
consequence, when the vSphere Client opens its console window, the Opengear Lighthouse VM will capture the
mouse pointer, making it unavailable for use by any other window. To release the pointer, press CTRL+ALCTRL+ALTT.

3.33.3 VMware WVMware Workstation Plaorkstation Playyer on Windows as hoster on Windows as host
Note: this procedure assumes VMware Workstation Player is already installed on the host Windows machine. This pro-

cedure also assumes VMware-ready virtual machine files are stored in c:\Users\%USERNAME%\Virtual
Machines\. This is the location selected by default by VMware Workstation Player. If another location is pre-
ferred, adjust this procedure as required.

Prepare the Opengear Lighthouse VM file for import into VMware Workstation Player.

01. move the lighthouse-5.1.0-vmx.zip archive to c:\Users\%USERNAME%\Virtual Machines\.

02. right-click the lighthouse-5.1.0-vmx.zip archive and select ExtrExtract all…act all… from the contextual menu.

03. A Select a Destination and Extract Files dialogue will open. By default the location is the same folder as the archive
is in: c:\Users\%USERNAME%\Virtual Machines\. Leave this as the destination folder.

04. Uncheck the Show extracted files when complete check box and then click ExtrExtractact.

05. A folder called ironmanwill be created inside c:\Users\%USERNAME%\Virtual Machines\.

Import the Opengear Lighthouse VM file into VMware Workstation Player.

01. Launch VMware Workstation Player.

02. Click Open a Virtual MachineOpen a Virtual Machine.

03. navigate to c:\Users\%USERNAME%\Virtual Machines\ironman\.

VMware Workstation Player points to Libraries > Documents by default and, also by default, this library includes
c:\Users\%USERNAME%\My Documents\.

Assuming this is the case, double-click Virtual Machines and then double-click Ironman.

04. If only one file — Ironman— presents, double-click it to add the Lighthouse 5.1.0 pr2 virtual machine to the
VMware Workstation 12 Player virtual machines list. If more than one file presents, double-click Ironman.vmx.

05. The Lighthouse 5.1.0 pr2 virtual machine is added to the VMware Workstation 12 Player virtual machines list.

06. With Opengear Lighthouse VMOpengear Lighthouse VM selected in the VMware Workstation 12 Player virtual machine list, click PlaPlay vir-y vir-
tual machinetual machine to boot Opengear Lighthouse 5.1.0.

3.43.4 VMware WVMware Workstation Pro on Windows as hostorkstation Pro on Windows as host
Note: this procdure assumes VMware Workstation Pro is already installed on the host Windows machine. This proce-

dure also assumes VMware-ready virtual machine files are stored in c:\Users\%USERNAME%\Virtual
Machines\. This is the location selected by default by VMware Workstation Pro. If another location is pre-
ferred, adjust this procedure as required.

Prepare the Opengear Lighthouse VM file for import into VMware Workstation Pro.

01. Move the lighthouse-5.1.0-vmx.zip archive to c:\Users\%USERNAME%\Virtual Machines\.

02. Right-click the lighthouse-5.1.0-vmx.zip archive and select ExtrExtract all…act all… from the contextual menu.

03. A Select a Destination and Extract Files dialogue will open. By default the location is the same folder as the PKZip
archive is in: C:\Users\%USERNAME%\Virtual Machines\. Leave this as the destination folder.

04. Uncheck the Show extracted files when complete check box and then click ExtrExtractact.

05. A folder called ironmanwill be created inside C:\Users\%USERNAME%\Virtual Machines\.

Import the Opengear Lighthouse VM file into VMware Workstation Pro.

01. Click Open a Virtual MachineOpen a Virtual Machine.

02. navigate to C:\Users\%USERNAME%\Virtual Machines\ironman\.

VMware Workstation Pro points to Libraries > Documents by default and, also by default, this library includes
C:\Users\%USERNAME%\My Documents\.

Assuming this is the case, double-click Virtual Machines and then double-click Ironman.

03. If only one file — Ironman— presents, double-click it to add the Lighthouse 5.1.0 pr2 virtual machine to the
VMware Workstation Pro virtual machines list. If more than one file presents, double-click Ironman.vmx.

04. The Lighthouse 5.1.0 pr2 virtual machine is added to the VMware Workstation Pro virtual machines list.
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05. With the Opengear Lighthouse VMOpengear Lighthouse VM selected in the My Computer listing and the subsequent Opengear LighthouseOpengear Lighthouse
VMVM tab open, click PPower on this virtual machineower on this virtual machine to boot Opengear Lighthouse 5.1.0.

3.53.5 VMware WVMware Workstation Plaorkstation Playyer or Pro on Fer or Pro on Fedoredora Wa Workstation as hostorkstation as host
As of the preparation of the Lighthouse 5.1.0 user guide, VMware Workstation Player 12 could not be installed on Fe-
dora 25 without substantial reconfiguration of a base Fedora Workstation setup. Moreover, the reconfiguration leaves
Fedora Workstation in a state that is entirely unsupported by any external entity.

Once appropriately re-configured, it seems likely that Lighthouse 5.1.0 will run in VMware Workstation Player 12 on
Fedora Workstation. At this stage, however, Opengear is not supporting this particular combination of host operating
system and virtual machine manager.

3.63.6 VirtualBoVirtualBox on Windows as hostx on Windows as host
Note: this procedure assumes VirtualBox is already installed on the host machine. This procedure also assumes the re-

quired PKZip archive, lighthouse-5.1.0-ovf.zip is in c:\Users\%USERNAME%$\Downloads, the de-
fault location for files downloaded from remote sources to a computer running Windows.

01. Unzip ironman-ovf (it may appear as lighthouse-5.1.0-ovf.zip depending on your Windows Explorer
preference settings).

Right-click the ironman-ovf archive and select ExtrExtract all…act all… from the contextual menu.

02. A Select a Destination and Extract Files dialogue will open. The destination will be
c:\Users\%USERNAME%\Downloads\Ironman-ovf.

03. Uncheck the Show extracted files when complete checkbox and edit the destination by removing Ironman-ovf
from the path.

04. Click ExtrExtractact.

05. A folder called ironman-ovf will be created inside c:\Users\%USERNAME%\Downloads\.

06. Launch Virtual Box

The OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager window appears.

07. Choose File > Import Appliance…File > Import Appliance….

The Appliance to importAppliance to import dialogue box opens.

08. Click the Expert ModeExpert Mode button.

The Appliance to importAppliance to import dialogue box changes from Guided Mode to Expert Mode.

09. Click the icon of a folder with an upward pointing arrow superimposed. This icon is to the far-right of the Appli-
ance to import field.

The Open File dialogue box opens. By default, it opens with C:\Users\%USERNAME%\Documents as the cur-
rent folder.

10. Navigate to c:\Users\%USERNAME%\Downloads\Ironman.ovf\Opengear Lighthouse VM\ .

11. Select the file Opengear Lighthouse VM and click OpenOpen.

12. Double-click the text ‘vm’ in the Name row and Configuration column to make it editable.

13. Type Opengear Lighthouse VM and hit Enter.

14. Click the ImportImport button.

A new virtual machine, called Opengear Lighthouse VMOpengear Lighthouse VM is added to the list of virtual machines available to Virtual
Box.

15. Select Opengear Lighthouse VMOpengear Lighthouse VM from the list.

16. Choose Machine > Settings…Machine > Settings…. (Alternatively, click the SettingsSettings icon in the VirtualBox Manager toolbar, or press
Control-S.)

The Opengear Lighthouse VM — Settings dialogue box presents.

17. Click the System option in the list of options running down the left-hand side of the dialogue box.

The majority of the dialogue box presents the System options available as three tabs: Motherboard, Processor,
and Acceleration. (Depending on the underlying hardware platform, Acceleration may be greyed-out and unavail-
able). The Motherboard tab is pre-selected by default.

18. In the Motherboard tab, check the Hardware Clock in UTC Time checkbox.

19. Click OKOK or press Return.

20. Select Opengear Lighthouse VMOpengear Lighthouse VM from the list and click StartStart in the OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager toolbar to boot
Opengear Lighthouse 5.1.0. (Double-clicking Opengear Lighthouse VMOpengear Lighthouse VM in the list also boots Opengear Lighthouse
5.1.0.)
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Note: Checking the Hardware Clock in UTC Time check-box is necessary because Lighthouse expects the hardware
clock to be set to UTC, not local time. Unlike other Virtual Machine Managers, Virtual Box both exposes this op-
tion as a user-adjustable setting and does not set it to UTC by default.

3.73.7 VirtualBoVirtualBox on macOS as hostx on macOS as host
Note: this procedure assumes VirtualBox is already installed on the host macOS machine. This procedure also assumes

the required PKZip archive, lighthouse-5.1.0-ovf.zip is in ~/Downloads, the default location for files
downloaded from remote sources to a computer running macOS.

01. Unzip lighthouse-5.1.0-ovf.zip.

This creates a folder — Ironman-ovf — in ~/Downloads that contains the following files and folders:

Ironman-ovf
└── Opengear Lighthouse VM

├── Opengear Lighthouse VM.ovf
└── Opengear_Lighthouse_VM-disk1.vmdk

02. Launch Virtual Box.

The OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager window appears.

03. Choose File > Import Appliance…File > Import Appliance… or press Command-I.

The Appliance to importAppliance to import dialogue sheet slides down from the OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager toolbar.

04. Click the Expert ModeExpert Mode button.

The Appliance to importAppliance to import dialogue sheet changes from Guided Mode to Expert Mode.

05. Click the icon of a folder with an upward pointing arrow superimposed. This icon is to the far-right of the Appli-
ance to import field.

The Open FileOpen File dialogue sheet slides down from the OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager toolbar. By default, this sheet
opens with ~/Documents as the current folder.

06. Navigate to ~/Downloads/Ironman.ovf/Opengear Lighthouse VM/.

07. Select Opengear Lighthouse VM and click OpenOpen. (Depending on your Finder Preferences settings, the file
may present as Opengear Lighthouse VM.ovf.)

08. Double-click the text ‘vm’ in the Name row and Configuration column to make it editable.

09. Type Opengear Lighthouse VM and hit Return.

10. Click the ImportImport button.

A new virtual machine, called Opengear Lighthouse VMOpengear Lighthouse VM is added to the list of virtual machines available to Virtual
Box.

11. Select Opengear Lighthouse VMOpengear Lighthouse VM from the list.

12. Choose Machine > Settings…Machine > Settings…. (Alternatively, click the SettingsSettings icon in the VirtualBox Manager toolbar, or press
Command-S.)

The Opengear Lighthouse VM — Settings dialogue box presents.

13. Click the System option in the dialogue box’s toolbar.

The dialogue box presents the System options available as three tabs: Motherboard, Processor, and Acceleration.
(Depending on the underlying hardware platform, Acceleration may be greyed-out and unavailable). The Mother-
board tab is pre-selected by default.

14. In the Motherboard tab, check the Hardware Clock in UTC Time checkbox.

15. Click OKOK or press Return.

16. Select Opengear Lighthouse VMOpengear Lighthouse VM from the list and click StartStart in the OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager toolbar to boot
Opengear Lighthouse 5.1.0. (Double-clicking Opengear Lighthouse VMOpengear Lighthouse VM in the list also boots Opengear Lighthouse
5.1.0.)

Note: Checking the Hardware Clock in UTC Time check-box is necessary because Lighthouse expects the hardware
clock to be set to UTC, not local time. Unlike other Virtual Machine Managers, Virtual Box both exposes this op-
tion as a user-adjustable setting and does not set it to UTC by default.

Note: by default, VirtualBox stores virtual machines in ~/VirtualBox VMs. If this is the first virtual machine setup by
VirtualBox it will create the VirtualBox VMs folder in the current user’s home-directory and create a further
folder — Opengear Lighthouse VM — inside the VirtualBox VMs folder. Inside Opengear Light-
house VM are the files and folders which make up Opengear Lighthouse 5.1.0 when run under Virtual Box.

Opengear Lighthouse 5.1.0 user guide (revision 1.0.0) page 11 of 71



3.83.8 VirtualBoVirtualBox on Ubuntu as hostx on Ubuntu as host
Note: this procedure assumes VirtualBox and all required support files are already installed on the host machine. This

procedure also assumes the required PKZip archive, lighthouse-5.1.0-ovf.zip is in `~/Downloads`, the
default location for files downloaded from remote sources to a computer running Ubuntu.

01. Unzip lighthouse-5.1.0-ovf.zip.

This creates a folder — Ironman.ovf — in ~/Downloads that contains the following files and folders:

Ironman.ovf
└── Opengear Lighthouse VM

├── Opengear Lighthouse VM.ovf
└── Opengear_Lighthouse_VM-disk1.vmdk

02. Launch Virtual Box.

The OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager window appears.

03. Choose File > Import Appliance…File > Import Appliance….

The Appliance to importAppliance to import dialogue box opens.

04. Click the Expert ModeExpert Mode button.

The Appliance to importAppliance to import dialogue box changes from Guided Mode to Expert Mode.

05. Click the icon of a folder with an upward pointing arrow superimposed. This icon is to the far-right of the Appli-
ance to import field.

A file-navigation dialogue box, headed Plese choose a virtual appliance to importPlese choose a virtual appliance to import opens. By default, it opens with
~/Documents as the current folder.

06. Navigate to ~/Downloads/Ironman.ovf/Opengear Lighthouse VM/.

07. Select Opengear Lighthouse VM.ovf and click OpenOpen.

08. Double-click the text ‘vm’ in the Name row and Configuration column to make it editable.

09. Type Opengear Lighthouse VM and hit Return.

10. Click the ImportImport button.

A new virtual machine, called Opengear Lighthouse VMOpengear Lighthouse VM is added to the list of virtual machines available to Virtual
Box.

11. Select Opengear Lighthouse VMOpengear Lighthouse VM from the list and click StartStart in the OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager toolbar to boot
Opengear Lighthouse 5.1.0. (Double-clicking Opengear Lighthouse VMOpengear Lighthouse VM in the list also boots Opengear Lighthouse
5.1.0.)

Note: by default VirtualBox stores virtual machines in ~/VirtualBox VMs. If this is the first virtual machine setup by
VirtualBox it will create the VirtualBox VMs folder in the current user’s home-directory and create a further
folder — Opengear Lighthouse VM — inside the VirtualBox VMs folder. Inside Opengear Light-
house VM are the files and folders which make up Opengear Lighthouse 5.1.0 when run under Virtual Box.

3.93.9 VirtualBoVirtualBox on Fx on Fedoredora Wa Workstation as hostorkstation as host
Note: this procedure assumes VirtualBox and all required support files are already installed on the host machine. This

procedure also assumes the required PKZip archive, lighthouse-5.1.0-ovf.zip is in ~/Downloads, the
default location for files downloaded from remote sources to a computer running Fedora.

• Unzip lighthouse-5.1.0-ovf.zip.

This creates a folder — Ironman.ovf — in ~/Downloads that contains the following files and folders:

Ironman.ovf
└── Opengear Lighthouse VM

├── Opengear Lighthouse VM.ovf
└── Opengear_Lighthouse_VM-disk1.vmdk

01. Launch Virtual Box.

The OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager window appears.

02. Choose File > Import Appliance…File > Import Appliance… or press Control-I.

The Appliance to importAppliance to import dialogue box opens.

03. Click the Expert ModeExpert Mode button.
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The Appliance to importAppliance to import dialogue box changes from Guided Mode to Expert Mode.

04. Click the icon of a folder with an upward pointing arrow superimposed. This icon is to the far-right of the Appli-
ance to import field.

The Open FileOpen File dialogue box opens. By default, it opens with ~/Documents as the current folder.

05. Navigate to ~/Downloads/Ironman.ovf/Opengear Lighthouse VM/.

06. Select Opengear Lighthouse VM and click OpenOpen.

07. Double-click the text ‘vm’ in the Name row and Configuration column to make it editable.

08. Type Opengear Lighthouse VM and hit Return.

09. Click the ImportImport button.

A new virtual machine, called Opengear Lighthouse VMOpengear Lighthouse VM is added to the list of virtual machines available to Virtual
Box.

10. Select Opengear Lighthouse VMOpengear Lighthouse VM from the list and click StartStart in the OrOracle VM VirtualBoacle VM VirtualBox Managerx Manager toolbar to boot
Opengear Lighthouse 5.1.0. (Double-clicking Opengear Lighthouse VMOpengear Lighthouse VM in the list also boots Opengear Lighthouse
5.1.0.)

Note: by default VirtualBox stores virtual machines in ~/VirtualBox VMs. If this is the first virtual machine setup by
VirtualBox it will create the VirtualBox VMs folder in the current user’s home-directory and create a further
folder — Opengear Lighthouse VM — inside the VirtualBox VMs folder. Inside Opengear Light-
house VM are the files and folders which make up Opengear Lighthouse 5.1.0 when run under Virtual Box.

3.103.10 Virtual Machine Manager (KVM) on Ubuntu as hostVirtual Machine Manager (KVM) on Ubuntu as host
Note: this procedure assumes Virtual Machine Manager and all required support files are already installed on the host

machine. This procedure also assumes the the .xz archive, lighthouse-5.1.0-raw.hdd.xz is in
~/Downloads, the default location for files downloaded from remote sources to a computer running Ubuntu.

01. Expand lighthouse-5.1.0-raw.hdd.xz

This creates a file — lighthouse-5.1.0-raw.hdd — in ~/Downloads.

02. launch Virtual Machine Manager.

03. Click the NewNew button at the top-left of the Virtual Machine Manager window (or choose File > New Virtual Ma-File > New Virtual Ma-
chinechine).

The Source Selection window opens.

04. Click the Select a fileSelect a file button.

A Select a device or ISO file dialogue box slides into view.

05. Navigate to ~/Downloads/.

06. Select the file lighthouse-5.1.0-raw.hdd and click OpenOpen in the top right-hand corner of the dialogue box.

A Review window opens providing basic information about the virtual machine (or ‘box’, as Boxes calls them) to be
created

07. Click the CreateCreate button in the top-right corner of the Review window.

08. A new virtual machine instance, Opengear_Lighthouse_VM-disk1 is created and presented in the Boxes window.

To rename the virtual machine instance, right-click on the machine instance and choose PropertiesProperties from the contextual
menu that appears.

Click anywhere in the Name field to select and edit the name.

Click the close box to save the changes.

3.113.11 BoBoxxes on Fes on Fedoredora Wa Workstation as hostorkstation as host
Note: this procedure assumes Boxes and all required support files are already installed on the host machine. This proce-

dure also assumes the the required PKZip archive, lighthouse-5.1.0-ovf.zip is in ~/Downloads, the
default location for files downloaded from remote sources to a computer running Fedora Workstation.

01. Unzip lighthouse-5.1.0-ovf.zip

This creates a folder — Ironman.ovf — in ~/Downloads that contains the following files and folders:

Ironman.ovf
└── Opengear Lighthouse VM

├── Opengear Lighthouse VM.ovf
└── Opengear_Lighthouse_VM-disk1.vmdk
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02. launch Boxes.

03. Click the NewNew button in the Boxes window title bar

The Source Selection window opens.

04. Click the Select a fileSelect a file button.

A Select a device or ISO file dialogue box opens.

05. Navigate to ~/Downloads/Ironman.ovf/Opengear Lighthouse VM/.

06. Select the file Opengear_Lighthouse_VM-disk1.vmdk and click OpenOpen in the top right-hand corner of the di-
alogue box.

A Review window opens providing basic information about the virtual machine (or ‘box’, as Boxes calls them) to be
created

07. Click the CreateCreate button in the top-right corner of the Review window.

08. A new virtual machine instance, Opengear_Lighthouse_VM-disk1 is created and presented in the Boxes window.

To rename the virtual machine instance, right-click on the machine instance and choose PropertiesProperties from the contextual
menu that appears.

Click anywhere in the Name field to select and edit the name.

Click the close box to save the changes.

3.123.12 BoBoxxes on CentOS as hostes on CentOS as host
Note: this procedure assumes a CentOS installation, complete with the Gnome desktop environment as the host oper-

ating system. By default CentOS includes the full complement of KVM-centric virtualisation tools including the
GUI-based virtualization management tools BoBoxxeses and virt-managervirt-manager and the shell-based virtualization manage-
ment tool virsh.

This procedure assumes BoBoxxeses is used to setup and manage the Opengear Lighthouse VM.

Finally, this procedure assumes the required PKZip archive, lighthouse-5.1.0-ovf.zip is in ~/Downloads, the
default location for files downloaded from remote sources to a computer running Fedora Workstation.

01. Unzip lighthouse-5.1.0-ovf.zip.

This creates a folder — Ironman.ovf — in ~/Downloads that contains the following files and folders:

Ironman.ovf
└── Opengear Lighthouse VM

├── Opengear Lighthouse VM.ovf
└── Opengear_Lighthouse_VM-disk1.vmdk

02. Launch Boxes

03. Click NewNew in the Boxes title bar.

04. Navigate to ~/Downloads/Ironman.ovf/Opengear Lighthouse VM/

05. Select Opengear Lighthouse VM and click OpenOpen.

A new virtual machine, called Opengear LighthouseOpengear LighthouseVMVM is added to the list of virtual machines available to Boxes.

Opengear Lighthouse 5.1.0 user guide (revision 1.0.0) page 14 of 71



4.4. First boot of the Opengear Lighthouse VMFirst boot of the Opengear Lighthouse VM
During boot, two screens present.

01. The first notes the VM is Booting to latest installed imageBooting to latest installed image.

The selected image is Lighthouse Root 1. Two other images are available: Lighthouse Root 1 and Memtest86+. Do
not change the boot image the VM boots from.

02. The second screens asks you to Select Lighthouse boot modeSelect Lighthouse boot mode and presents four options:

Graphics console boot
Graphics console recovyer mode
Serial console boot
Serial console recovery mode

03. Graphics console boot is pre-selected and should not be changed.

04. After the first boot has completed a message presents:

Welcome to Ironman. This is software version:
5.1.0

05. And the final procedure in the initial setup presents:

To complete initial setup, please set a new root password.
Press ENTER to continue.

06. After pressing EnterEnter, a prompt appears:

Enter new root password:

07. Enter a strong, high-entropy password and press EnterEnter.

08. The confirm prompt appears:

Confirm given password

09. Re-enter the password and press EnterEnter.

10. Multiple configuration notices present ending with a login prompt:

opengear-lighthouse login:

11. Enter root (the only user able to login at this point) and press EnterEnter.

12. A password prompt appears:

Password:

13. Enter the newly-set password and press EnterEnter.

14. A standard bash shell prompt appears.

root@opengear-lighthouse:~#
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5.5. Initial system configurInitial system configurationation

5.15.1 LLoading Opengear Lighthouseoading Opengear Lighthouse
When the Opengear Lighthouse VM is booted and running it is addressable at either of two IP addresses:

01. the fixed address, 192.168.0.1192.168.0.1, or

02. whatever address it is assigned by any DHCP server it finds.

Note: if you are connecting to a Lighthouse 5.1.0 instance from a workstation running macOS, Opengear recommends
using a browser other than Safari (for example, Chrome, Firefox, Opera, or Vivaldi). Safari handles self-signed SSL
certificates in a fashion that makes using it to connect to a running Lighthouse 5.1.0 instance difficult, at best.

In your browser of choice open a new window or tab and enter

01. https:/https://192.168.0.1//192.168.0.1/ or https:/https://[DHCP-supplied address]//[DHCP-supplied address]/ in the address bar

02. press ReturnReturn.

The Opengear Lighthouse login page loads.

5.25.2 LLogin to Opengear Lighthouseogin to Opengear Lighthouse
To login to Opengear Lighthouse

01. Enter a username in the Username field.

02. enter the username’s password in the Password field.

03. Click LLog Inog In or press EnterEnter.

The Opengear Lighthouse DashboardDashboard loads.

Note: the Dashboard, the Sidebar, and other Lighthouse pages, will present differently depending on the privileges as-
signed to the logged-in user. In this manual, screenshots such as that of the Lighthouse Dashboard above repre-
sent what the root user sees. Users with different privileges will see filtered views of available nodes, users,
groups, tags and Smart Groups and will have different privileges regards creating and changing settings within
Lighthouse. (For example, users other than root can edit their own account settings but cannot edit other user’s
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accounts. Depending on the privileges an account has, a user may also be restricted with regards what they can
do with enrolled nodes or what new nodes they can enroll.)

5.35.3 Setting the Opengear Lighthouse hostnameSetting the Opengear Lighthouse hostname
To set the hostname for a running Opengear Lighthouse instance:

01. Select Settings > System > AdministrSettings > System > Administrationation.

02. Edit the Hostname field as required.

03. Click ApplyApply.

5.45.4 Adding eAdding external IP addressesxternal IP addresses manually (manually (optional)optional)
Adding a Lighthouse instance’s external IP address or addresses to a Lighthouse instance’s configuration is an optional
step.

To add a single external address:

01. Select Settings > System > AdministrSettings > System > Administrationation.

02. In the Address field of the External Network Addresses section, enter an IP address.
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03. (Optional step) Change the API Port, VPN Port or both, if the ports used on the entered IP address are different
from the default (443 and 1194, respectively).

04. Click the ApplyApply button.

05. Click ApplyApply.

To manually add further external addresses to a Lighthouse instance’s configuration:

01. Click the ++ (add) button.

A second row appears in the External Network AddressesExternal Network Addresses section.

02. In the newly presented Address field, enter an IP address.

03. (Optional step) Change the API Port, VPN Port or both, if the ports used on the entered IP address are different
from the default (443 and 1194, respectively).

04. Add further IP addresses as required by repeating the steps above.

05. Click the ApplyApply button.

To change the order in which manually-added IP addresses are sent to remote nodes:

01. Click the up and down arrows in the OrderOrder column to change the order in which the IP addresses are listed.

The presented order reflects the order in which these addresses are sent out.

02. Click the ApplyApply button.

If external IP addresses are manually added to a Lighthouse configuration, these addresses are sent to a remote node
during enrollment. If no external IP address is manually added to a Lighthouse configuration, default external IP ad-
dresses are used.

The default external IP addresses are sent to a remote node during enrollment in the following order:

01. net1:dhcp

02. net1:static

03. the IP address connected to the default gateway.

5.55.5 Setting the Opengear Lighthouse internal clockSetting the Opengear Lighthouse internal clock
To set the time-zone:

01. Select Settings > Date & Time > Time ZSettings > Date & Time > Time Zoneone.

02. Select the Lighthouse instance’s time-zone from the Time Zone pop-up menu.

03. Click ApplyApply.

To set the correct time and date either

01. Select Settings > Date & Time > Manual SettingsSettings > Date & Time > Manual Settings.

02. Enter the current Date and Time.

03. Click ApplyApply.
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or

01. Select Settings > Date & Time > Automatic SettingsSettings > Date & Time > Automatic Settings.

02. Click the Enabled check-box.

03. Enter a working NTP Server address in the NTP Server Address field.

04. Click ApplyApply.

5.65.6 Examine or change the Lighthouse SSL certificateExamine or change the Lighthouse SSL certificate
Lighthouse ships with a private SSL Certificate that encrypts communications between it and your browser.

To examine this certificate, or generate a new Certificate Signing Request:
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01. Select Settings > Services > HTTPS CertificateSettings > Services > HTTPS Certificate.

The details of the Current SSL CertificateCurrent SSL Certificate present.

Immediately below this listing is a Certificate Signing RequestCertificate Signing Request form, which can be used to generate a new SSL certifi-
cate.

5.75.7 Network connectionsNetwork connections
To see the network connections available to Opengear Lighthouse 5.1.0:

01. Select Settings > Network Connections > Network InterfacesSettings > Network Connections > Network Interfaces
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This currently presents only two default connections: static and dhcp interfaces.

If you log in to the Lighthouse VM and run ifconfig, the two connections listed in Opengear Lighthouse 5.1.0 corre-
spond to the following returned interfaces:

default-static is net1:static.

default-DHCP is net1:dhcp.

To edit a given network interface:

01. Select Settings > Network Connections > Network InterfacesSettings > Network Connections > Network Interfaces

02. Click the Edit button in the ActionsActions section of the network interface to be modified.

03. Make the desired changes in the resultant dialog.

04. Click ApplyApply.
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Note: don’t change the configuration method. Just disable the interface you don’t want to use by unchecking the En-
abled checkbox. As of this release of Opengear Lighthouse 5.1.0, if default-static and default-DHCP are changed
to the same configuration method (ie both are set to Static assignment or both are set to DHCP) neither interface
will work.
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6.6. Shut down or restart Opengear LighthouseShut down or restart Opengear Lighthouse

6.16.1 Shutting down a running Opengear Lighthouse instanceShutting down a running Opengear Lighthouse instance
To shutdown a running Opengear Lighthouse instance:

01. Select Manage > Lighthouse > LManage > Lighthouse > Local Tocal Terminalerminal

02. At the LLocal Tocal Terminalerminal login prompt enter a username with administrative privileges (eg root)

03. At the Password: prompt, enter that account’s password

A Last login date and time for that account are returned to STD OUT and a shell prompt for the newly logged in
user presents.

04. enter the command shutdown now and press ReturnReturn.

The Lighthouse virtual machine shuts down.

6.26.2 Restarting a running Opengear Lighthouse instanceRestarting a running Opengear Lighthouse instance
To restart a running Opengear Lighthouse instance, follow the first three steps of the Shutting down a running
Opengear Lighthouse instance procedure above then:

04. At the shell prompt enter one or other of the following command strings:

reboot

shutdown -r now

05. Press ReturnReturn.

The Lighthouse virtual machine shuts down and immediately reboots.
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7.7. Using Opengear LighthouseUsing Opengear Lighthouse
After Opengear Lighthouse has been installed and configured, a small set of nodes should be enrolled, and a set of tags
and smart groups should be created, that will allow nodes access to be filtered to the correct subset of users.

Once these nodes are installed, access to the Node’s Web UI and serial ports should be tested.

This section will cover
01. Licensing third-party nodes before enrollment

02. Enrolling nodes

03. Creating Smart Groups

04. Accessing the node’s Web UI

05. Accessing the node’s serial ports via Console Gateway

7.17.1 Licensing third-party nodes before enrollmentLicensing third-party nodes before enrollment
Lighthouse 5.1.0 includes support for managing third-party remote nodes.

Support for third-party remote nodes is not built-in to a new Lighthouse instance, however: it is added via a license.

A license is an encrypted, RFC 7519-compliant, JSON web token that contains key-value pairs describing the features
and entitlements of a given third-party remote node.

Licenses are distributed by Opengear and will be available as encrypted ASCII strings sent by e-mail via a fullfilment
procedure.

Before enrolling a third-party remote node, its corresponding license must be added to Lighthouse as follows:

7.1.17.1.1 Adding a license using the Lighthouse UIAdding a license using the Lighthouse UI

01. Select Settings > System > LicensingSettings > System > Licensing

02. Click the ++ (add) button.

03. Paste the encrypted license text string into the License body text field.

04. Click ApplyApply.
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7.1.27.1.2 Showing installed licenses in the Lighthouse UIShowing installed licenses in the Lighthouse UI

Installed licenses are presented at Settings > System > LicensingSettings > System > Licensing.

Installed Licenses are also presented on the Lighthouse Dashboard at Monitor > DashboardMonitor > Dashboard.

The dahsboard also displays messages when:

01. The number of nodes supported by a license has been reached or exceeded.
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02. The maintenance period of a license has expired.

7.1.37.1.3 Showing installed licenses via the LShowing installed licenses via the Local Tocal Terminalerminal

oglicdump is a shell-based tool that writes the current licensing status of a Lighthouse instance to STD OUT (or, using
the -o switch, a file).

For example:

# oglicdump
{

"OGLH": {
"contact": {

"email": "engineering@opengear.com",
"name": "Test",
"phone": "123456"

},
"features": {

"nodes": 500,
"additional": {

"thirdpartynodes": "1"
},
"maintenance": 1603152000

}
}

}

If there are no installed licenses, oglicdump returns the following:

# oglicdump
No data found

7.27.2 Enrolling nodesEnrolling nodes

7.2.17.2.1 Enrollment oEnrollment ovverviewerview

Enrolling nodes is the process of connecting nodes to Lighthouse, to make them available for access, monitoring, and
management. Enrollment can be performed in a number of ways

01. Enrollment via the Lighthouse Web UI

02. Enrollment via the Node Web UI

03. Enrollment via ZTP

04. Enrollment via USB key

Each of these options will be described in this section

To authenticate either the Lighthouse (during enrollment via the Lighthouse WebUI), or the node (during the other en-
rollment scenarios) credentials must be provided.

The Lighthouse VPN uses certificate-authenticated OpenVPN tunnels between Lighthouse and remote nodes. These
tunnels, in turn, rely on the time being synchronized between the Lighthouse instance and the console server or other
remote node. If a remote node is not relying on an NTP server to set its own time, when a remote node receives a Light-
house enrollment request, it inspects the HTTP Date header sent by Lighthouse and sets its local time to match that of
the Lighthouse instance.

If a remote node is relying on an NTP server to set its own time, it still checks the HTTP Date header sent by Light-
house to affect the time synchronization, but it does not set its local time to match that of the Lighthouse instance

When enrolling via Lighthouse, an administration username and password for the node must be provided. When en-
rolling via the node, an enrollment TTokokenen must be provided. A default enrollment token can be set on the ConfigureConfigure
Nodes > Enrollment SettingsNodes > Enrollment Settings page, and individual tokens set per enrollment bundle

Note: As of Lighthouse 5.1, group-checking is not yet implemented. Consequently, the root user is the only
administrative-level user that can be used when enrolling.

Enrollment can either be a two-step, or a one-step process. The default is two-step:

01. Once enrollment starts, nodes receive their enrollment package, and establish a VPN connection to Lighthouse.

02. The node is now in the PPendingending state, and needs to be ApproApprovveded before the node will be available for access, man-
agement, or monitoring.
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This second step can be skipped when a particular enrollment bundle is used by checking the Auto-approve node check-
box when configuring an enrollment bundle.

7.2.27.2.2 Enrollment bundlesEnrollment bundles

An enrollment bundle (aka a provisioning bundle) is a downloadable file that stores provisioning information, allowing
for bulk enrollment and manipulation of remote nodes.

Applying an enrollment bundle during enrollment allows tags to be associated with nodes when they’re first enrolled,
rather than manually assigning tags after the nodes are enrolled.

This is especially useful for larger roll-outs where there will be many nodes deployed with a similar configuration and
responsibilities. If relevant Smart Groups and tags have been set up, newly enrolled nodes will be immediately visible
for the relevant users to configure and use.

7.2.37.2.3 Creating an enrollment bundleCreating an enrollment bundle

An enrollment bundle or manifest.og file contains a series of field-value pairs that an unconfigured device can use to
configure itself.

Options that can be set in manifest.og include new firmware, custom configuration scripts, opg config files, and
lighthouse enrollment details.

By default, manifest.og includes the following field-value pairs (the values are examples only):

address=192.168.88.20
api_port=4443
bundle=bne-dc
password=secret

Custom field-value pairs can be added manually (again, the field names are potential field names for a real-world, cus-
tomised file but the values following each field name are examples only):

script=configure_ports.sh
image=acm7000-3.16.6.image
external_endpoints=192.168.1.2:4444,192.168.1.3:4445

A provisioning bundle manifest.og file can be created in a Lighthouse instance as follows:

01. Select Configure Nodes > Enrollment BundlesConfigure Nodes > Enrollment Bundles

02. Click the ++ (add) button.

The Enrollment Bundle DetailsEnrollment Bundle Details dialog box presents.
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03. Enter a Name and Authentication Token for the bundle in the respective fields.

04. Select the number of Tags and Values to apply to any nodes that enroll using this enrollment bundle

05. (Optional) Check the Auto-approve node check-box.

When this is checked, a device configured using this enrollment bundle is not placed in pending mode during the
enrollment process. Instead, it is automatically approved for enrollment after it has been identified.

With the enrollment bundle named, use the Enrollment Bundle Node TEnrollment Bundle Node Tagsags to populate it with the desired name-value
pairs by:

01. Select a field name from the left-most pop-up menu.

02. Select or enter a value from the right-most pop-up menu.

03. Click the ++ (add) button to add a new pair of pop-up menus

04. Select another field name and select or enter another value.

05. Repeat until all desired name-value pairs are displayed.

06. Click the ApplyApply button.

7.2.47.2.4 Enrollment via Lighthouse WEnrollment via Lighthouse Web UIeb UI

01. Select the Add NodeAdd Node shortcut in the top menu bar to bring up the new enrollment dialog.

02. Select the Product type from the ProductProduct pop-up menu.

03. Available options in the ProductProduct pop-up menu are:

An Opengear device
A generic third party device
An Avocent ACS6000
An Avocent ACS8000
An Avocent ACS Classic
A Cisco 2900 Series
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04. To enroll an Opengear device, an Avocent ACS6000, an Avocent ACS8000, an Avocent ACS Classic, or a Cisco
2900 Series, enter the Name, Network Address, Username, and Password of the Node being enrolled.

Note: Enrolling an Avocent ACS6000, an Avocent ACS8000, an Avocent ACS Classic, or a Cisco 2900 Series requires
the device’s license to have been added as per the ‘Licensing third-party nodes before enrollment’ procedure
above. If an appropriate license has not been added to Lighthouse, the procedure will return a ‘No licenses have
been applied’ error and the node will not be added to Lighthouse.

Note: the Name field does not allow the period (aka full-stop or ‘dot’) character. Attempting to use this character will fail
with a not a valid common name error.

Note: the Username and Password fields are for the login credentials required by the remote node being enrolled. They
are notnot for the login credentials required to login to the Opengear Lighthouse instance.

04. To enroll a generic third-party device, there are three more required fields: Connection Method; Base Protocol
Port; and Port Count.

Note: the following procedure assumes the third-party device’s license has been added as per the ‘Licensing third-party
nodes before enrollment’ procedure above. If an appropriate license has not been added to Lighthouse, the pro-
cedure will return a ‘No licenses have been applied’ error and the node will not be added to Lighthouse.
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05. Choose SSH or Telnet from the Connection Method pop-up menu, as appropriate for the connection method sup-
ported by the third-party device.

06. Enter a base number in the Base Protocol Port. By default, this is set to 3000.

The Base Protocol Port number is the starting port number from which the third-party device’s invididual serial
port network port numbers will be derived.

07. Enter the number of serial ports the third-party device has in the Port Count field.

Below the Port Count field is a Serial PSerial Port Labelsort Labels section. Whatever number is entered in the Port Count field, the
Port Label x fields in this section will update to match this number in real-time.

08. Optionally, edit the labels used to identify each serial port in the Serial PSerial Port Labelsort Labels section.

09. Click ApplyApply.

Once enrolled, the console server’s details are automatically removed from the PPending Nodesending Nodes page and automatically
added to the Configure Nodes > Node Enrollment > Enrolled NodesConfigure Nodes > Node Enrollment > Enrolled Nodes page.
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Note: As of Lighthouse 5.1.0, third-party devices are added to the config server but they are not enrolled.

7.2.57.2.5 Enrollment via Node WEnrollment via Node Web UIeb UI

If the Node is situated behind a firewall, Lighthouse will not be able to initiate an enrollment: it will need to be triggered
from the Node WebUI.

To do this:

01. log into the Node WebUI.

02. select Serial & Network > LighthouseSerial & Network > Lighthouse.

03. Enter the Server Address, the Enrollment Bundle (if a specific bundle is being used), and the Enrollment Token (ei-
ther the global token or the bundle-specific token).

04. Select Apply SettingsApply Settings.

The enrollment process starts.

7.2.67.2.6 Mass Enrollment using ZTPMass Enrollment using ZTP

For mass node enrollments using ZTP, three new custom DHCP fields are handled by ZTP scripts.

These fields contain the URLURL, Bundle NameBundle Name and Enrollment PEnrollment Passwordassword used in an enrollment which is kicked off immedi-
ately after all other ZTP handling is completed. If a reboot is required because of a config file being provided the enroll-
ment will start after the reboot. Otherwise it happens immediately.

A sample configuration file, for the ISC DHCP Server, follows:

option space opengear  code width 1  length width 1;
option opengear.config-url code 1 = text;
option opengear.firmware-url code 2 = text;
option opengear.enroll-url code 3 = text;
option opengear.enroll-bundle code 4 = text;
option opengear.enroll-password code 5 = text;
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class "opengear-config-over-dhcp-test" {
match if option vendor-class-identifier ~~ "^Opengear/";
vendor-option-space opengear;
option opengear.config-url "http://192.168.88.1/config.xml";
option opengear.enroll-url "192.168.88.20";
option opengear.enroll-bundle "";
option opengear.enroll-password "default";

}

Note: the maximum amount of data allowable as DHCP options is 1200 bytes, including all overhead inherent in the
structuring of this data. Individual options are still, however, limited to 255 characters.

7.2.77.2.7 Enrollment via USB drivEnrollment via USB drivee

USB Enrollment enables the configuration of a device using a manifest file copied to a USB drive and inserted into the
unconfigured device before it first boots.

Once created (see ‘Creating an enrollment bundle’ above), manifest.og files can be downloaded from a Lighthouse
instance as follows:

01. Select Configure Nodes > Node Enrollment > Enrollment BundlesConfigure Nodes > Node Enrollment > Enrollment Bundles.

A list of extant Enrollment BundlesEnrollment Bundles presents.

02. In the ActionsActions column of the particular bundle to be used, click the downloaddownload button (a downward-pointing arrow
in a circle).

03. Depending on your browser’s configuration, a manifest.og file will either be downloaded to your local system
(likely to ~/Downloads or c:\Users\%USERNAME%\Downloads\) or your browser will present a dialogue
box asking you to specifiy which local directory the download should be copied to.

To effect an enrollment via USB drive:

01. Copy manifest.og to the root directory on a USB drive.

02. Plug the USB drive into an unconfigured and powered-down console server

03. Power the console server up.

On first boot, the device looks for a file — manifest.og — on any usb drives attached to the device and config-
ures the device based on the contents therein.
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7.37.3 The Enrolled Nodes pageThe Enrolled Nodes page

Configure Nodes > Node Enrollment > Enrolled NodesConfigure Nodes > Node Enrollment > Enrolled Nodes lists all currently enrolled nodes in the order they are enrolled to
Opengear Lighthouse 5.1.0.

It also presents details about each node (such as model, firmware version, serial number) and connection status. Con-
nection status displays either of two things:

01. Connected: Last status change x [time unit] ago.

This is the time since Opengear Lighthouse connected to the console server.

02. Disconnected: last status change x [time unit] ago

This is the time since Opengear Lighthouse disconnected from the console server.

7.47.4 Filtering pages displaFiltering pages displaying nodesying nodes
The Configure Nodes > Enrolled NodesConfigure Nodes > Enrolled Nodes page and the Configure Nodes > PConfigure Nodes > Pending Nodesending Nodes page as well as the Nodes >Nodes >
Node WNode Web UIeb UI and Nodes > Console GatewaNodes > Console Gatewayy pages can all be filtered using either the Search… text-entry field or the
Smart Groups pop-up menu.

7.4.17.4.1 Filtering using the Search fieldFiltering using the Search field

The Search… text-entry field allows for near real-time filtering of which nodes are presented. Type a string (eg ‘finance’
or ‘london’ or ‘CM7148’) and press ReturnReturn and only the nodes which include that string in their Name or Description
will be displayed.

The Search… field treats multiple search terms (ie terms delimited by the space character) as Boolean AND searches.

For example, a search on the string:

london 4.1.0

will return any nodes that have both london AND 4.1.0 in searchable fields (eg ‘london’ in the name field and ‘4.1.0’ in
the firmware version field).
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To make a search string that contains spaces into a single searched entity, enclose the string in double quotes.

For example, a search on the string:

"london east" 4.1.0

will return nodes that contain london east in the name field and 4.1.0 in the firmware version field. It will not return a
node with 4.1.0 in the firmware version field if it also only contains london in the name field.

7.4.27.4.2 Filtering using the Smart Groups pop-up menuFiltering using the Smart Groups pop-up menu

Alternatively selecting from the Select Smart Group… pop-up menu will set the page to display the sub-set of nodes that
belong to the selected group.

See Creating Smart Groups immediately below for how to create such groups.

Once a particular Smart Group has been selected, further filtering options become available. For example:

In the example above, the Configure Nodes > Node Enrollment > Enrolled NodesConfigure Nodes > Node Enrollment > Enrolled Nodes page is being filtered on the Office De-
ployments Smart Group.

It is then being further filtered to only display nodes with a:

Location of Brisbane, and a

Department other than Support.

Adding further filtering options can be done as follows:

01. Click the ++ (add) button.

An extra row of pop-up menus presents.

02. Select the desired tag from the left-most pop-up menu.

03. Select the filtering operator from middle pop-up menu.

04. Select or enter the value to be filtered against from the right-most pop-up menu.

05. Click ApplyApply..

7.57.5 Creating Smart GroupsCreating Smart Groups
Smart Groups are saved search parameters used within Lighthouse for grouping related remote nodes.

A given User Group can be linked to a particular Smart Group. When a Group is linked in this fashion, members of the
Group inherit rights over all nodes in the group based on the Group’s Role. See ‘Modifying existing Opengear Light-
house groups’ below for how to set a Group’s Role and Linked Smart Group.

Smart Groups can also be used to filter visible nodes on pages that display enrolled nodes (such as Configure Nodes >Configure Nodes >
Node Enrollment > Enrolled NodesNode Enrollment > Enrolled Nodes) to make it easier to drill down to a particular console.

Smart groups are dynamic, so as more nodes are added to the system, the filters will automatically update.

To create a Smart Group:

01. Navigate to any page which displays the Smart Group search interface, for example Configure Nodes > Node En-Configure Nodes > Node En-
rollment > Enrolled Nodesrollment > Enrolled Nodes or Manage > Node > Node WManage > Node > Node Web UIeb UI.
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02. Click on the Select Smart Group... drop-down

03. select New Smart Group.

This populates a number of new drop-downs and text boxes.

04. Click the Field to search drop-down to select a Node attribute to filter on.

These attributes include details about the device (Model, Firmware Version, Serial Number, NET1 MAC Address),
and also include any tagstags that have been configured in the system. For filtering access to devices, tags are generally
the most useful attribute to filter on. Note that when a tag is selected, the Value text box becomes a drop down
with the values for that tag.

05. Click the Operator drop-down to select the operator to apply to the Value.

Generally, IsIs is the most useful.

06. Select the Value to be matched against.

07. Click ApplyApply to see the results of the filter.

08. Click SaSavve As...e As...

09. type in a name for the search.

This Smart Group can now be used for filtering nodes for display, and for access.

7.67.6 Editing an eEditing an existing Smart Groupxisting Smart Group
To edit an existing Smart Group:

01. Select Configure Nodes > Edit Smart GroupsConfigure Nodes > Edit Smart Groups.
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02. Click the XX icon to delete an existing Smart Group.

03. Click the editedit icon to change a Smart Group’s name.

Note: As of Lighthouse 5.1, editing the parameters of an existing Smart Group cannot be done from this page.

To change the search parameters used by an exant Smart Group:

01. Navigate to a page that presents Smart Groups for filtering (eg Configure Nodes > Node Enrollment > EnrolledConfigure Nodes > Node Enrollment > Enrolled
NodesNodes).

02. Select the Smart Group which search parameters you wish to change from the Select Smart Group…Select Smart Group… pop-up menu.

03. Change the parameters (eg Tag and Operater values) as required.

04. Click the SaSavve as…e as… button.

05. Leave the Smart Group name unedited and click ApplyApply.
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The changed Smart Group will overwrite the existing Smart Group.

7.77.7 Connecting to a NodeConnecting to a Node’s web-management interface’s web-management interface
Once a node has been enrolled to Opengear Lighthouse 5.1.0 its own web-management interface can be accessed from
within the Lighthouse UI. To connect to an enrolled node’s web-management interface:

01. Select Manage > Nodes > Node WManage > Nodes > Node Web UIeb UI.

02. In the Actions column, click the Access WAccess Web UIeb UI link for the node you wish to connect to.

The web-based login for that node loads.

03. Authenticate using the username and password required by that node.

Note: at the bottom of the browser window is a visual indication that the console server session is being mediated
through Opengear Lighthouse 5.1.0. This footer also contains a link allowing for a quick return to Opengear Lighthouse
5.1.0.

7.87.8 Connecting to a NodeConnecting to a Node’s serial ports via Console Gatewa’s serial ports via Console Gatewayy
Searching for serial ports on Lighthouse can be accomplished in two ways

01. Port-centric searching via the Manage > Managed DeManage > Managed Devices > Console Gatewavices > Console Gatewayy page

02. Node-centric searching via the Manage > Node > Console GatewaManage > Node > Console Gatewayy page

Port-centric search allows filtering via the port name, and presents a flat list of ports that match the search terms, while
Node-centric search allows filtering via Smart Groups, and Node properties, as well as port names. In general, the Port-
centric searching offered via the Manage > Managed DeManage > Managed Devices > Console Gatewavices > Console Gatewayy is recommended

Port-centric searching

01. Select Manage > Managed DeManage > Managed Devices > Console Gatewavices > Console Gatewayy .

02. Find the console port you wish to access.

Do this by using the Filtering options to search for the port name. This search will live update as you type

Node-centric searching

01. Select Manage > Nodes > Console GatewaManage > Nodes > Console Gatewayy .

02. Find the console port you wish to access.

Do this by using the Filtering options to restrict the listed nodes to the particular node that hosts the console port,
or by using the Search field to search by the port’s name (aka label).

03. Click the ++ icon in the Access Console Ports row adjacent the node you wish to access.

Once the particular serial port is located, serial port access via Console GatewaConsole Gatewayy can be accomplished in two ways

01. Access via HTML5 Web Terminal

02. Access via SSH
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7.8.17.8.1 Access via HTML5 WAccess via HTML5 Web Teb Terminalerminal

To provide easy console port access, Lighthouse includes a HTML5 Web Terminal.

Note: The HTML5 Web Terminal includes native cut, copy and paste support. The terminals available on Nodes do not.

To access a console port via the Web Terminal:

01. Locate the port you wish to access using one of the search techniques discussed above.

02. Click the WWeb Teb Terminalerminal link for the particular port.

A new tab opens, containing the Web Terminal

To close an HTML5 terminal session:

01. Close the tab, or type ~. in the Web Terminal window.

7.8.27.8.2 Access via SSHAccess via SSH

To access ports via SSH, the user can either use a console chooser menu to select the node and the console port, or use a
direct SSH link from the Web UI to connect directly to the port.

To access a console port via a Direct SSH link:

01. Locate the port you wish to access using one of the search techniques discussed above.

02. Click the SSHSSH link to connect to the URL.

By default, these auto-generated links use the colon (:) as the field-delimiter. That is, the auto-generated SSH link has,
by default, the following form:

ssh://user-name:console-server-name:port-number@lighthouse-ip-address

Some web-browsers, however, treat the colon character as strictly associated with delimiting the protocol at the begin-
ning of a URI. Consequently, they don’t pass these auto-generated URIs safely.

To cater for this, the default delimiter character can be changed. To change this character:

01. Select Settings > Services > Console GatewaSettings > Services > Console Gatewayy.
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02. Enter an alternative delimited character in the Console Gateway Port Delimiter text-entry field.

The carat character — ^̂ — is the most common alternative delimiter for URIs being parsed by browsers.

To use the console chooser menu, use SSH to connect to the Lighthouse appliance, with the username format user-
name:serial. This will connect to the Lighthouse, and present a list of nodes that the user has access to.

Once the user selects a node, they are presented with a list of console ports they have access to. When one is selected,
the user is connected to that port.

For faster access, there are username format shortcuts that give more specific lists of serial ports, or direct access with-
out a menu.

username:node_name
When a valid node name is specified, a list of console ports that the user has access to on that node will be presented. If
they do not have access to that node, the connection will fail.

username:node_name:port_name
When a valid node name and port name are specified, and the user has access to that node and port, the user will be di-
rectly connected to that port. If they do not have access to that port, the connection will fail.

username:port_name
When a valid port name is specified, the user will be connected to first port with that port name found. If the user does
not have access to that port, the connection will fail.

Note: node names and port names are not case sensitive.
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7.8.37.8.3 Example Console GatewaExample Console Gateway session:y session:

$ ssh adminuser:serial@lighthouse-name-or-ip-here

1: cm71xx

Connect to remote > 0

1: Cisco Console                              2: Port 2

Connect to port > 1
router#
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8.8. Opengear Lighthouse user managementOpengear Lighthouse user management
Lighthouse 5.1 supports locally defined users, and remote users that are authenticated and authorized by AAA.

Users must be members of one or more groups. Each group has a role assigned to it, which determines the level of ac-
cess that group members will have to the system

These roles are:

RoleRole DescriptionDescription

Lighthouse
Administrator

The Lighthouse Administrator role is assigned to groups whose members need to manage and
maintain the Lighthouse appliance. Members have access to all data on the Lighthouse sys-
tem

Node Admin-
istrator

The Node Administrator role is assigned to groups that need to manage and maintain a set of
Nodes. Each group with the Node Administrator role also must have an associated Smart
Group which is evaluated to define the set of Nodes that the group members have access to.

Node User
The Node User role is assigned to groups that need to access a set of Nodes. Each group with
the Node User role also must have an associated Smart Group which is evaluated to define
the set of Nodes that the group members have access to.

Group membership can either be defined locally (for local users), or can be defined on the AAA server. Groups that are
assigned by the AAA servers must still exist locally.

8.18.1 A note on password fields in Opengear LighthouseA note on password fields in Opengear Lighthouse
However they are labelled — Password or Confirm password or other label — password fields in Opengear Lighthouse
are, in effect, write-onlywrite-only. They accept data from the clipboard or pasteboard but do not pass data out. So, all those
strong, high-entropy passwords that you, quite rightly, don’t want to either type or re-type, must be copied to your local
clipboard or pasteboard from outside Lighthouse. They can then be safely copied in to all such fields in the Lighthouse
user-interface.

8.28.2 Creating new Opengear Lighthouse groupsCreating new Opengear Lighthouse groups

To create a new Opengear Lighthouse group:

01. Select Settings > User Management > GroupsSettings > User Management > Groups

02. Click the ++ button.

03. The New Group dialog loads.

04. Enter a Group Name, Description and select a Role for the group.

05. If the Role selected is Lighthouse Administrator, members of the group will automatically be added to the ‘All

Nodes’ Linked Smart Group.
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06. If the Role selected is Node Administrator or Node User, select a Smart Group to define the nodes that the group
has access to.

Note: if a new group (or new user) is given the Lighthouse Administrator role, members of the group (or individual
users) will have access to the sudo command. In ‘under the hood’ terms, groups or users with the Lighthouse Ad-
ministrator role are added to the admin group, which is in the list of allowed sudoers. On first boot of a new
Lighthouse instance, the root user is the only member of the admin group and, consequently, the only user with
sudo access.

8.38.3 Modifying eModifying existing Opengear Lighthouse groupsxisting Opengear Lighthouse groups
To modify an existing Opengear Lighthouse group:

01. Select Settings > User Management > GroupsSettings > User Management > Groups.

02. Click Edit in the ActionsActions section of the group to be modified.

03. Make desired changes

04. Click SaSavve Groupe Group.

The Modify Group dialog allows the group’s Description, Role, and Linked Smart Group to be set and changed.
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Note: If a Group’s Role is Lighthouse Administrator, the group’s Linked Smart Group is All Nodes and this cannot be
changed. In equivalent fashion, if a Group has a Linked Smart Group other than All Nodes, the group’s Role can-
not be set to Lighthouse Administrator.

See ‘Creating Smart Groups’ above for details regarding creating and using Smart Groups.

The Modify Group dialog also allows for a group to be deleted. If a group is deleted, however, all users whe were mem-
bers of the group lose any access and administrative rights inherited from thr group.

8.48.4 Creating new Opengear Lighthouse usersCreating new Opengear Lighthouse users
To create a new Opengear Lighthouse user:

01. Select Settings > User management > LSettings > User management > Local Usersocal Users

02. Click the ++ button.

03. The New User dialog loads.

04. Enter a Username, Description, and Password.

05. Re-enter the Password in the Confirm Password field.

06. Check the Enabled check box.

07. Click Apply.

The root user — which password was reset on the initial boot of the Opengear Lighthouse VM (see ‘First boot of the
Opengear Lighthouse VM’ above) will already be listed here.

Note: as of this release, all users created in Lighthouse’s web-UI are put in the admin group by default and are, as a con-
sequence, admin-level users.

8.58.5 Modifying eModifying existing Opengear Lighthouse usersxisting Opengear Lighthouse users
To modify an existing Opengear Lighthouse user:

01. Select Settings > User management > LSettings > User management > Local Usersocal Users

02. Click Edit in the ActionsActions section of the user to be modified.

03. Make desired changes.

04. Click SaSavve Usere User.
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The Modify Users dialog allows the user’s Description to be changed and the user’s Password to be re-set. The user-
name cannot be changed. The Modify Users dialog also allows the user to be disabled, by unchecking the Enabled check
box.

Disabled users cannot login to Lighthouse using either the Web-based interface or via shell-based logins (ie
sshusername-you-disabled@lighthouse-name-or-ip will not work). The user still exists, however (the
/home/username-you-disabled directory is still extant in the Opengear Lighthouse VM file-system for example).

8.68.6 Deleting Opengear Lighthouse usersDeleting Opengear Lighthouse users
To delete an Opengear Lighthouse user completely:

01. Select Settings > User management > LSettings > User management > Local Usersocal Users

02. Click Delete in the ActionsActions section of the user to be modified.

03. Click Yes in the ConfirmationConfirmation dialog.

8.78.7 Configuring AAAConfiguring AAA
Lighthouse supports three AAA systems:

01. LDAP (Active Directory and OpenLDAP)

02. RADIUS

03. TACACS+

Authentication works much the same with each, but group membership retrieval varies. The following sections detail
the configuration settings for each provider, and explain how group membership retrieval works.

To begin:

01. Select Settings > User Management > Remote AuthenticationSettings > User Management > Remote Authentication.
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8.7.18.7.1 LDLDAP ConfigurAP Configurationation

01. Select LDAP from the Scheme drop-down box.

02. Add the Address and optionally the Port of the LDAP server to query.

03. Add the Base DN that corresponds to the LDAP system being queried.

For example, if a user’s distinguished name is cn=John Doe,dc=Users,dc=ACME,dc=com, the Base DN is
dc=ACME,dc=com

04. Add the Bind DN.

This is the distingushed name of a user with privileges on the LDAP system to perform the lookups required for re-
trieving the username of the users, and a list of the groups they are members of.

05. Add the password for the binding user

06. Add the Username Attribute.

This depends on the underlying LDAP system. Use sAMAccountName for Active Directory systems, and uid for
OpenLDAP based systems

07. Add the Group Membership Attribute.

This is only needed for Active Directory, and is generally memberOf.

Note: multiple servers can be added. The LDAP subsystem will query them in a round-robin fashion.
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8.7.28.7.2 RADIUS ConfigurRADIUS Configurationation

To configure RADIUS:

01. Select Settings > User Management > Remote AuthenticationSettings > User Management > Remote Authentication.

02. In the SettingsSettings section, select RADIUS from the Scheme pop-up menu.

03. Add the Address and optionally the Port of the RADIUS authentication server to query.

04. Add the Address and optionally the Port of the RADIUS accounting server to send accounting information to.

05. Add the Server password (Also known as the RADIUS Secret).

Note: multiple servers can be added. The RADIUS subsystem will query them in a round-robin fashion.

To provide group membership, RADIUS needs to be configured to provide a list of group names via the Framed-Filter-Id
attribute.

The following configuration snippet shows how this can be configured for FreeRADIUS

operator1 Auth-Type := System
Framed-Filter-ID = ":group_name=west_coast_admin,east_coast_user:"

Note: the Framed-Filter-ID attribute must be delimited by the colon character.

8.7.38.7.3 TTAACACACS+ ConfigurCS+ Configurationation

To configure TACACS+:

01. Select Settings > User Management > Remote AuthenticationSettings > User Management > Remote Authentication.
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02. Select TACACS+ from the Scheme pop-up menu.

03. Add the Address and optionally the Port of the TACACS+ authentication server to query.

04. Select the Login Method.

PAP is the default method. However, if the server uses DES-encrypted passwords, select Login.

04. Add the Server password (Also known as the TACACS+ Secret)

05. Add the Service. This determines the set of attributes sent back by the TACACS+ server

Note: multiple servers can be added. The TACACS+ subsystem will query them in a round-robin fashion.

To provide group membership, TACACS+ needs to be configured to provide a list of group names

The following configuration snippet shows how this can be configured for a tac_plus server.

user = operator1 {
service = raccess {

groupname = west_coast_admin,east_cost_user
}

}

To do this with Cisco ACS, see setting up permissions with Cisco ACS 5 and TACACS+ on the Opengear Help Desk.
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9.9. Lighthouse centrLighthouse central configural configurationation
Templates are a centralised way of changing the configuration for enrolled Opengear Console Server nodes by pushing
pre-defined configuration templates to selected nodes. Lighthouse 5.1 supports the creation and execution of Group
and Authentication templates.

9.19.1 Creating new group templatesCreating new group templates
Only users assigned to the Lighthouse Administrator role can access Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating >emplating >
Group TGroup Templatesemplates and create templates.

A group template contains a list of groups that are set as the list of user-defined groups on the node. Each group has a
defined role which determines what privileges group members will have.

The available roles are:

Node AdministrNode Administratorator — maps to the administrator role on the nodes.

Node UserNode User — maps to the all ports user role, and the pmshell role, on the nodes.

To create a new group template:

01. Select Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating > Group Templating > Group Templatesemplates.

02. Click the ++ (add) button.

The New Group TNew Group Templateemplate dialog loads.

03. Enter a Name and Description for a template in the TTemplate Detailsemplate Details section.

04. Click the ++ (add) button in the Set Group ListSet Group List section to add a new group.

The Group DetailsGroup Details dialog loads.

05. Enter a Group Name, a Description, and select a Role for the group.

06. Click ApplyApply.

07. Click SaSavve Te Templateemplate.
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Note: when a group template is pushed to a node, all custom groups on that node are replaced by the groups defined in
the template’s group list.

9.29.2 Modifying eModifying existing group templatesxisting group templates
The Edit Group TEdit Group Templateemplate dialog allows a template’s Description and Group List to be set and changed.

To modify an existing group template:

01. Select Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating > Group Templating > Group Templatesemplates.

02. Click EditEdit in the ActionsActions section of the template to be modified.

The Edit Group TEdit Group Templateemplate dialog presents.

03. Make changes as required.

04. Click SaSavve Te Templateemplate.

9.39.3 Deleting group templatesDeleting group templates
To delete a group template completely:
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01. Select Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating > Group Templating > Group Templatesemplates.

02. Click DeleteDelete in the ActionsActions section of the template to be removed.

The Confirmation alert box appears.

03. Click YYeses in the ConfirmationConfirmation dialog.

The group template is deleted.

9.49.4 Creating new authentication templatesCreating new authentication templates
Only users assigned to the Lighthouse Administrator role can access Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating > Au-emplating > Au-
thentication Tthentication Templatesemplates and create authentication templates.

The supported modes are Local, Radius, TACACS+ and LDAP. For example, if an authentication template is configured
to use RADIUS as an authentication source, that corresponds to RADIUSDownLocal with Use Remote Groups ticked on
the downstream node.

To create a new authentication template:

01. Select Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating > Authentication Templating > Authentication Templatesemplates.

02. Click the ++ (add) button.

The New Authentication TNew Authentication Templateemplate dialog loads.

03. Enter a Name and Description for a template in the TTemplate Detailsemplate Details section.

04. Select a desired Scheme or click the Pre-populatePre-populate button to pre-populate a template with the current Lighthouse
remote authentication configuration.
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05. Enter or update authentication settings if required.

See ‘Configuring AAA’ above for an example.

06. Click SaSavve Te Templateemplate.

Note: when an authentication template is pushed to a node, the authentication settings at that node are replaced by the
those defined in the authentication template.

Note: the authentication templates do not currently support the full list of settings that the Opengear Console Servers
support. However, templates can be applied and then additional settings configured manually.

9.59.5 Modifying eModifying existing authentication templatesxisting authentication templates
The Edit Authentication TEdit Authentication Templateemplate dialog allows the template’s Description and Authentication Settings to be set and
changed.

To modify an existing authentication template:

01. Select Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating > Authentication Templating > Authentication Templatesemplates.

02. Click EditEdit in the ActionsActions section of the template to be modified.

The Edit Authentication TEdit Authentication Templateemplate dialog presents.

03. Make required changes.

04. Click SaSavve Te Templateemplate.
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9.69.6 Deleting authentication templatesDeleting authentication templates
To delete an authentication template completely:
01. Select Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating > Authentication Templating > Authentication Templatesemplates.

02. Click DeleteDelete in the ActionsActions section of the template to be removed.

The Confirmation alert box appears.

03. Click YYeses in the ConfirmationConfirmation dialog.

The authentication template is deleted.

9.79.7 Apply TApply Templatesemplates
Users with Lighthouse Administrator privileges (ie, users with the Lighthouse Administrator role or users who are
members of groups with the Lighthouse Administrator role) can access Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating >emplating >
Apply TApply Templatesemplates and execute templates affecting any node.

Users with Node Administrator privileges (ie, users with the Node Administrator role or users who are members of
groups with the Node Administrator role) can access Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating > Apply Templating > Apply Templatesemplates
and execute templates affecting nodes in Smart Groups linked to their role.

Apply TApply Templatesemplates consists of four stages, each one a step in the overall ‘wizard’. The steps are:

01. Select Template.

02. Select Nodes.

03. Preflight.

04. Execution.

‘Preflight’ is a test run, simulating what happens if the template is pushed to the selected nodes.

To apply a template:

01. Select Configure Nodes > ConfigurConfigure Nodes > Configuration Tation Templating > Apply Templating > Apply Templatesemplates.

02. Select a template from the existing template tree.

TTemplate Detailsemplate Details populates with details from the selected template.

03. Click the NeNext — Select Nodesxt — Select Nodes button.
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The Select NodesSelect Nodes stage loads.

04. Select nodes from the list of enrolled nodes.

The screenshot above shows filtering being used to set the list of enrolled nodes to match (or closely match) the
set of nodes an administrator wishes to deal with.

Third party nodes are not supported for template execution.

05. Click the NeNext — Preflightxt — Preflight button.

06. The PreflightPreflight stage loads.

This stage auto-refreshes every 5 seconds with updated Preflight ResultPreflight Result and DetailsDetails.

After all nodes finish preflight, a success message appears and the NeNext — Push Configurxt — Push Configurationation button becomes ac-
tive.

07. Select desired nodes for template execution and click the NeNext — Push Configurxt — Push Configurationation button.

The ConfigurConfiguration Statusation Status stage loads.

This stage auto-refreshes every 5 seconds with updated Push ResultPush Result and DetailsDetails.

After all nodes finish the template push a success message appears.
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10.10. Command line toolsCommand line tools
Lighthouse 5.1.0 includes a web-based terminal. To access this bash shell instance:
01. Select Manage > Lighthouse > LManage > Lighthouse > Local Tocal Terminalerminal.

At the presented login prompt:
01. Enter an administrator’s username and press Return.

A Password: prompt appears.

02. Enter the administrator’s password and press Return.

A bash shell prompt appears.

This shell supports most standard bash commands and also supports copy-and-paste to and from the terminal.

There are also Lighthouse-specific shell-based tools available, including:

10.110.1 node-commandnode-command
The node-command tool is used to run commands on managed console servers, allowing administrators to easily run a
single CLI command in bulk, on all or on a range of their console server deployment.

Note: to run node commands, you must be authorized as an admin group user.

To get started with any of the node tools, you can get quick information on how to use it from the command line:

node-command --help

To see a list of all the registered console servers that the tool can operate on:

node-command --list-nodes

10.1.110.1.1 Example node-command OutputExample node-command Output

== node-command ID 2017-05-19T14:08:33.360164_29534 ==
14:08:33 [SUCCESS] BNE-R01-ACM7004-5 192.168.128.2:22
OpenGear/ACM7004-5 Lighthouse 3b90d826 --  Tue May 9 13:42:16 EST 2017

14:08:33 [SUCCESS] BNE-R02-IM7216 192.168.128.3:22
OpenGear/IM72xx Lighthouse 3b90d826 --  Tue Jul 5 13:42:16 EST 20167
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10.210.2 node-infonode-info
node-info is a shell-based tool for pulling more detailed information from console servers.

10.2.110.2.1 Example node-info outputExample node-info output

$ node-info -A
BNE-R01-ACM7004-5

address: 192.168.128.2
id: nodes-1
ssh port: 22
description: Brisbane Rack 1
enrollment status: Enrolled
connection status: Connected

BNE-R02-IM7216
address: 192.168.128.3
id: nodes-2
ssh port: 22
description: Brisbane Rack 2
enrollment status: Enrolled
connection status: Connected

10.310.3 node-upgrnode-upgradeade
node-upgrade is a tool for running bulk firmware upgrades on managed console servers.

By passing in required information — such as the firmware version to upgrade to, the location of the firmware image to
upgrade with, and the nodes to upgrade — via appropriate flags, node-upgrade can upgrade the firmware on multiple
console servers and report results back to STD OUT with a single command.

node-upgrade accepts seven flags as follows:

-f, --firmware-file         The path for the directory of the firmware file(s).
-v, --version               The firmware version to upgrade to.
-z, --ignore-version        Ignore firmware version warnings for upgrade.
-i, --node-index=index      Select node by config index
-n, --node-name=name        Select node by name
-a, --node-address=address  Select node by VPN address
-A, --all                   Select all available nodes

10.3.110.3.1 An eAn example node-upgrxample node-upgrade runade run

The following is an example node-uprade command. It sets /mnt/nvram/ as the directory node-upgrade looks to
for the firmware image used as the source for all the firmware upgrade attempts. Every console server being managed
from the active Lighthouse instance is targeted for an upgrade and the target console servers are set to upgrade to
firmware 4.0.0.

# node-upgrade -A -f /mnt/nvram -v 4.1.0

When run, node-upgrade returns information to STD OUT, such as the following:

Upgrading firmware for device family: ACM550X
Upgrading firmware for device family: CM71XX
Upgrading firmware for device family: CM7196
Upgrading firmware for device family: ACM7004-5
Upgrading firmware for device family: IM72XX
im7208: flashing firmware file: im72xx-4.1.0.flash
[FAILURE] acm5508: not upgraded to OpenGear/ACM5508-2 version 4.1.0.
Reason for failure: No firmware available for ACM550X device family.
[FAILURE] cm7148: not upgraded to OpenGear/CM7148-2-DAC version 4.1.0.
Reason for failure: netflash failed due to the same firmware currently
on the device.
[FAILURE] cm7196: not upgraded to OpenGear/CM7196A-2-DAC version
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4.1.0. Reason for failure: netflash failed due to the same firmware
currently on the device.
[FAILURE] acm7004: not upgraded to OpenGear/ACM7004-5-LMR version
4.1.0. Reason for failure: netflash failed due to the same firmware
currently on the device.
[SUCCESS] im7208: upgraded to OpenGear/IM7208-2-DAC-LR version 4.1.0.

node-upgrade also returns status codes 0 (success) or 1 (failure) when particular conditions are met.

Exit code 0 (success) is returned under the following conditions:

01. Success

02. Successful upgrade of all nodes.

03. No nodes selected for upgrade.

04. No firmware found in nominated directory.

Exit code 1 (failure) is returned under the following conditions:

01. Missing or invalid command line options.

02. The curent user is not authorized to execute commands on a node.

03. The specified firmware directory was invalid (ie it does not exist or is not readable).

04. At least one node upgrade failed.

10.410.4 ogadduserogadduser
ogadduser is a shell-based tool for creating users.

Basic ogadduser usage syntax is as follows:

$ ogadduser -u testuser -p mypassword -g admin

10.510.5 ogconfig-cliogconfig-cli
ogconfig-cliallows users to inspect and modify the configuration tree from the command line. It is inherently trans-
actional in nature, allowing users to ensure their configuration is correct before pushing it to the configuration server.

From a command line, as the root user, you can start the tool with:

ogconfig-cli

10.5.110.5.1 Commands to try from within the ogconfig-cli toolCommands to try from within the ogconfig-cli tool

01. help

02. get .

03. print . 2

04. print users[0].username

10.5.210.5.2 Changing a configurChanging a configuration from within ogconfig-cliation from within ogconfig-cli

From inside ogconfig-cli:

ogcfg> set system.hostname "opengear-lighthouse-new"
ogcfg> push
ogcfg> quit

To see that the change has taken effect:

$ cat /etc/hostname

A configuration change doesn’t take effect util it is pushed to the configuration server. For example, from inside
ogconfig-cli:
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ogcfg> set system.hostname "opengear-lighthouse-new-again"
ogcfg> print system.hostname
ogcfg> quit

To see that the change did not take effect:

$ cat /etc/hostname

10.5.310.5.3 ConfigurConfiguration validation from within ogconfig-cliation validation from within ogconfig-cli

Configuration is internally validated before being applied, so that an incorrect configuration cannot be accidentally set.
For example, from inside ogconfig-cli, setting an invalid ethernet link speed is rejected:

ogcfg> set system.net.physifs[0].ethernet.link_speed "1GB"
ogcfg> push
Commit failed

Messages:   String is not in the list of allowed values
Push command failed

ogcfg> quit

10.610.6 oglicdumpoglicdump
oglicdump is a shell-based tool for displaying and saving the current third-party licensing status of a Lighthouse in-
stance.

When used without a switch, oglicdump writes the current status to STD OUT.

To write this status out to a file, or in machine readable form, or as a raw license container string, or to write out a sub-
set of the licensing information (such as licenses for a given SKU), use one of the switches oglicdump supports:

-h               Displays this help.
-v               Display version information
-o <file>        File to write out to. Default is stdout.
-s <SKU>         Specific SKU code to dump out. Default is all SKU codes.
-f <feature>     Specific feature value to dump out. This is only valid in conjunction with -s.
-c               Output contacts only. This is only valid in conjunction with -s.
-m               Output machine readable, as in compact formatted, not pretty
-r               Output the raw license container strings from config.

10.710.7 sysflashsysflash
sysflash is the shell-based tool for upgrading a Lighthouse instance’s system.

Basic sysflash syntax is as follows:

# sysflash [flags] [path/to/system-image.lg_upg | Percent-encoded URL to firmware-image.lg_upg]

Image filenames cannot include spaces. And, as the syntax example above notes, URLs must be Percent-encoded.

sysflash includes eight flags which modify the standard upgrade behaviour as well as the -h or --help flag, which
returns all the available flags and their affects:

-b, --board-name <name>        Override board name (currently lighthouse-vm)
-B, --board-revision <version> Override board revision (currently 1.0)
-V, --vendor <vendor>          Override vendor (currently opengear)
-I, --no-version-check         Do not check software version for upgradability
-m, --no-migration             Do not migrate current config. Start fresh.
-v, --verbose                  Increase verbosity (may repeat)
-o, --no-boot-once             Do not modify bootloader (implies --no-reboot)
-r, --no-reboot                Do not reboot after upgrading
-h, --help                     Print this help
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10.810.8 Selecting nodes using shell-based toolsSelecting nodes using shell-based tools
There are a number of ways to select nodes (also known as console servers) as targets on which to run a command.
These can be used multiple times, or together, to select a range of console servers:

Select individually by name, address, Lighthouse VPN address or config index (as per --list-nodes output):

node-command --node-name BNE-R01-IM4248

node-command --node-address 192.168.0.33

node-command --node-index nodes-1

10.8.110.8.1 Select all nodesSelect all nodes

node-command --all

10.8.210.8.2 Running commands on selected nodesRunning commands on selected nodes

Once nodes are selected, the commands to be run for each can be given. These are run on each managed node, in paral-
lel. Any command you can run from a node shell can be run on each managed node.

Note: all commands are run as root.

For example, to check the version on two specific, configured nodes, selecting one by name and the other by index, run
the following command:

node-command --node-name BNE-R01-ACM7004-5 --node-index nodes-2 cat /etc/version

Note: when using non-trivial selection arguments, check which target nodes have been selected on your initial com-
mand pass by using the --list-nodes switch rather than the final command.

Opengear Lighthouse 5.1.0 user guide (revision 1.0.0) page 58 of 71



11.11. System upgrSystem upgradesades
A Lighthouse appliance’s system can be upgraded using a .lh_upg image file.

Note: The filename suffix .lh_upg is required.

However a system upgrade is carried out, once the upgrade is complete, the Lighthouse instance reboots. It will be un-
available during the reboot process.

11.111.1 UpgrUpgrading the system from within Lighthouseading the system from within Lighthouse
To upgrade a Lighthouse instance’s system using the Lighthouse UI:

01. Select Settings > System > System UpgrSettings > System > System Upgradeade.

02. Select the UpgrUpgrade Methodade Method (either Fetch image from HTTP/HTTPS Server or Upload Image).

If upgrading via Fetch image from HTTP/HTTPS Server:

01. Enter the URL for the system image in the Image URLImage URL text-entry field.

02. Click the PPerform Upgrerform Upgradeade button.

If upgrading via Upload Image:

01. Click the Choose fileChoose file button.

02. Navigate to the directory containing the system-upgrade-image.lh_upg file.

03. Select the system-upgrade-image.lh_upg file and press ReturnReturn.

04. Click the PPerform Upgrerform Upgradeade button.

Note: The Advanced OptionsAdvanced Options section, which expands to present an UpgrUpgrade Optionsade Options text-entry field, should only be
used if a system upgrade is being performed as part of an Opengear Support call. If a specific option is required,
the Opengear Support technician will specify it.

Once the upgrade has started, the System Upgrade page displays feedback as to the state of the process.

A system upgrade attempt will return the error System version was not higher than the current version if the selected
image file is not, in fact, a more recent version than that already installed.

11.211.2 UpgrUpgrading the Lighthouse system via the Lading the Lighthouse system via the Local Tocal Terminalerminal
Lighthouse includes a shell-based tool — sysflash— that allows a user with administrative privileges to upgrade the
instance’s system from the Local Terminal.

To upgrade Lighthouse instance’s system using the Lighthouse Local Terminal:

01. Select Manage > Lighthouse > LManage > Lighthouse > Local Tocal Terminalerminal.

02. At the [hostname] login: prompt, enter an administrator username and press ReturnReturn.

03. At the Password: prompt, enter the administrator’s password and press ReturnReturn.

To use sysflash in conjunction with a .lh_upg file available via an HTTP or HTTP server:
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01. At the Local Terminal bash shell prompt enter:

sysflash http[s]%3A%2F%2Fdomain.tld%2Fpath%2Fto%2Ffirmware-upgrade-image.lh_upg

02. Press ReturnReturn.

Note: as shown in the example URL above, URLs passed to sysflashmustmust be Percent-encoded (also known as URL
encoded).

To use sysflash in conjunction with a .lh_upg file available via the local file system:

01. At the Local Terminal bash shell prompt enter:

sysflash /path/to/system-upgrade-image.lh_upg.

02. Press ReturnReturn.

sysflash also includes several flags that allow for variations in the standard system upgrade process. For the most
part, these flags should not be used unless directed to do so by Opengear Support.

All nine flags are listed by running either of the following at a Local Terminal bash shell prompt:

01. sysflash -h or

02. sysflash --help

The same listing is presented in the sysflash entry of the Command line tools chapter above.
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12.12. TTroubleshootingroubleshooting

12.112.1 Establishing the current Lighthouse instance vEstablishing the current Lighthouse instance versionersion

12.1.112.1.1 using the web UIusing the web UI

01. click SystemSystem on the top right of the Lighthouse instance’s web UI.

02. The Details menu appears, listing the Lighthouse instance’s *Current version* and the *Hostname*.

12.1.212.1.2 via the local Lighthouse shellvia the local Lighthouse shell

01. Click Manage > Lighthouse > LManage > Lighthouse > Local Tocal Terminalerminal

02. At the [hostname] login: prompt, enter an administrator username and press ReturnReturn.

03. At the Password: prompt, enter the administrator’s password and press ReturnReturn.

04. At the bash shell prompt, enter cat /etc/version and press ReturnReturn.

05. The current Lighthouse instance’s version is returned to STD OUT. For example:

[administrator-username]@[hostname]:~# cat /etc/version
5.1.0

Note: the procedure above uses the Web UI to reach the Lighthouse Local Terminal. This is not the only way to reach
the Lighthouse shell and cat /etc/version works in any circumstance where an administrator has access to
the Lighthouse shell. For example, many of the Virtual Machine Manager applications that can run a Lighthouse
instance offer virtual console access. If this is available and an administrator logs in to the Lighthouse shell via
this console, the command string will work as expected.

12.1.312.1.3 Other information sources related to a Lighthouse instanceOther information sources related to a Lighthouse instance’s v’s versionersion

Two other command strings can be useful when specifics about a particular Lighthouse instance are needed.

Both these commands can be run by an administrator with access to a running Lighthouse instance’s bash shell.

First is cat /etc/sw*. This command concatenates the following four files to STD OUT:

/etc/sw_product
/etc/sw_variant
/etc/sw_vendor
/etc/sw_version

For example:

# cat /etc/sw*
ironman
release
opengear
5.1.0

Second is cat /etc/issue. /etc/issue is a standard *nix text file which, by default, contains system information
for presenting before the system’s login prompt. On a Lighthouse instance, etc/issue contains the vendor, the Iron-
man/Lighthouse version or the Console Server version and (optionally) the underlying hardware platform.
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Two examples, showing some of the different information presented depending on the particulars of a Lighthouse in-
stance:

# cat /etc/issue
OpenGear qemux86-64 Console Server 1.0.0 \n \l

# cat /etc/issue
Opengear Ironman 5.1.0 \n \l

12.212.2 TTechnical support reportsechnical support reports
Lighthouse 5.1.0 can generate a technical support report that includes Lighthouse configuration information and the
current system log for the Lighthouse VM.

If you contact Opengear Technical Support, the support technician may ask for this report.

12.2.112.2.1 GenerGenerate a support report via the Lighthouse interfaceate a support report via the Lighthouse interface

To generate a complete configuration and status report regarding a given Opengear Lighthouse 5.1.0 VM:

01. Select Help > THelp > Technical Support Reportechnical Support Report.

Note: Lighthouse generates this support report on demand and the report includes the current system log. This process
can take several minutes.

02. Click Download support reportDownload support report.

This downloads a PKZip archive to your local system. The archive’s filename is structured as follows:

support-[host-name]-[iso-8601-order-date-and-time-stamp].zip

It contains two files:

system.txt — the configuration information also presented in the TTechnical Support Reportechnical Support Report window.

messages— the current Opengear Lighthouse 5.1.0 VM system log.

The two files are also presented in the Support Report text box below the Download support reportDownload support report link. Because the
report includes the current system log, this will almost certainly be a long but scrollable presenation. This presentation
is, however, searchable using your web browser’s built-in search function.

12.2.212.2.2 GenerGenerate a support report via the local terminalate a support report via the local terminal

To generate a complete configuration and status report regarding a given Opengear Lighthouse 5.1.0 VM:

01. Select Manage > Lighthouse > LManage > Lighthouse > Local Tocal Terminalerminal.

02. At the [hostname] login: prompt, enter an administrator username and press ReturnReturn.

Opengear Lighthouse 5.1.0 user guide (revision 1.0.0) page 62 of 71



03. At the Password: prompt, enter the administrator’s password and press ReturnReturn.

04. At the bash shell prompt, enter

support-report -z > /tmp/support.zip

and press Return

Note: this is the recommended way of running the support-report command. The -z switch generates the same
combined file as produced by the Download support reportDownload support report link noted in the Lighthouse UI-specific procedure
above. And the redirect saves this generated PKZip file to /tmp/support.zip for retrieval at your conve-
nience.

12.312.3 Returning an Opengear Lighthouse instance to factory settingsReturning an Opengear Lighthouse instance to factory settings
To return an enrolled console server to its factory settings using Opengear Lighthouse 5.1.0:

01. Login to the Opengear Lighthouse 5.1.0 web-based interface as root.

02. Select Settings > System > Factory ResetSettings > System > Factory Reset.

03. Check the Proceed with the factory reset checkbox.

04. Click the ResetReset button.

You must login as root for this to work. Other users, even those with full admininstrative privileges, do not have the
permissions required to reset an Opengear Lighthouse 5.1.0 VM to its factory settings.

Alternatively, the following script, run from a shell, performs a full factory reset:

/usr/bin/factory_reset

As with the Lighthouse-based procedure, only root can run this script. And, again as with the Lighthouse-based proce-
dure, the script prompts for confirmation before performing the factory reset.

This procedure, and the shell script, are equivalent to logging in to console server’s web-based management interface
(see ‘Connecting to a console server’s web-management interface’ above) and doing the following:

01. Select AdministrAdministrationation

02. Check the Config Erase checkbox.

03. Click ApplyApply.

Note: returning a console server to its factory settings in this fashion does notnot un-enroll said server from the Opengear
Lighthouse 5.1.0 VM.
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13.13. TTechnical supportechnical support
Purchaser is entitled to thirty (30) days free telephone support and twelve (12) months free e-mail support (worldwide)
from date of purchase provided that the Purchaser first register their product(s) with Opengear by filling in the on-line
form http://opengear.com/registration.html.

Direct telephone, help-desk and e-mail support is available from 09:00 to 20:00, US Eastern Time (UTC -5 or UTC -4).
Other support options are at http://opengear.com/support.html.

Opengear’s standard warranty includes free access to Opengear’s Knowledge Base as well as any application notes,
white papers and other on-line resources that may become available from time to time.

Opengear reserves the right to stop support for products no longer covered by warranty.

Opengear Lighthouse 5.1.0 user guide (revision 1.0.0) page 64 of 71

http://opengear.com/registration.html
http://opengear.com/support.html
https://opengear.zendesk.com/hc/en-us


14.14. End-user license agreementsEnd-user license agreements

14.114.1 Opengear end-user license agreementOpengear end-user license agreement
READ BEFORE USING THE ACCOMPANYING SOFTWARE

YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE USING THE ACCOMPA-
NYING SOFTWARE, THE USE OF WHICH IS LICENSED FOR USE ONLY AS SET FORTH BELOW. IF YOU DO NOT
AGREE TO THE TERMS AND CONDITIONS OF THIS AGREEMENT, DO NOT USE THE SOFTWARE. IF YOU USE ANY
PART OF THE SOFTWARE, SUCH USE WILL INDICATE THAT YOU ACCEPT THESE TERMS.

You have acquired a product that includes Opengear (“Opengear”) proprietary software and/or proprietary software li-
censed to Opengear. This Opengear End User License Agreement (“EULA”) is a legal agreement between you (either an
individual or a single entity) and Opengear for the installed software product of Opengear origin, as well as associated
media, printed materials, and “online” or electronic documentation (“Software”). By installing, copying, downloading, ac-
cessing, or otherwise using the Software, you agree to be bound by the terms of this EULA. If you do not agree to the
terms of this EULA, Opengear is not willing to license the Software to you. In such event, do not use or install the Soft-
ware. If you have purchased the Software, promptly return the Software and all accompanying materials with proof of
purchase for a refund.

Products with separate end user license agreements that may be provided along with the Software are licensed to you
under the terms of those separate end user license agreements.

LICENSE GRANT. Subject to the terms and conditions of this EULA, Opengear grants you a nonexclusive right and li-
cense to install and use the Software on a single CPU, provided that, (1) you may not rent, lease, sell, sublicense or lend
the Software; (2) you may not reverse engineer, decompile, disassemble or modify the Software, except and only to the
extent that such activity is expressly permitted by applicable law notwithstanding this limitation; and (3) you may not
transfer rights under this EULA unless such transfer is part of a permanent sale or transfer of the Product, you transfer
at the same time all copies of the Software to the same party or destroy such materials not transferred, and the recipi-
ent agrees to this EULA.

No license is granted in any of the Software’s proprietary source code. This license does not grant you any rights to
patents, copyright, trade secrets, trademarks or any other rights with respect to the Software.

You may make a reasonable number of copies of the electronic documentation accompanying the Software for each
Software license you acquire, provided that, you must reproduce and include all copyright notices and any other propri-
etary rights notices appearing on the electronic documentation. Opengear reserves all rights not expressly granted
herein.

INTELLECTUAL PROPERTY RIGHTS. The Software is protected by copyright laws, international copyright treaties, and
other intellectual property laws and treaties. Opengear and its suppliers retain all ownership of, and intellectual proper-
ty rights in (including copyright), the Software components and all copies thereof, provided however, that (1) certain
components of the Software, including SDT Connector, are components licensed under the GNU General Public License
Version 2, which Opengear supports, and (2) the SDT Connector includes code from JSch, a pure Java implementation
of SSH2 which is licensed under BSD style license. Copies of these licenses are detailed below and Opengear will pro-
vide source code for any of the components of the Software licensed under the GNU General Public License upon re-
quest.

EXPORT RESTRICTIONS. You agree that you will not export or re-export the Software, any part thereof, or any process
or service that is the direct product of the Software in violation of any applicable laws or regulations of the United
States or the country in which you obtained them.

U.S. GOVERNMENT RESTRICTED RIGHTS. The Software and related documentation are provided with Restricted
Rights. Use, duplication, or disclosure by the Government is subject to restrictions set forth in subparagraph (c) (1) (ii) of
the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c) (1) and (2) of
the Commercial Computer Software – Restricted Rights at 48 C.F.R. 52.227-19, as applicable, or any successor regula-
tions.

TERM AND TERMINATION. This EULA is effective until terminated. The EULA terminates immediately if you fail to
comply with any term or condition. In such an event, you must destroy all copies of the Software. You may also termi-
nate this EULA at any time by destroying the Software.

GOVERNING LAW AND ATTORNEY’S FEES. This EULA is governed by the laws of the State of Utah, USA, excluding its
conflict of law rules. You agree that the United Nations Convention on Contracts for the International Sale of Goods is
hereby excluded in its entirety and does not apply to this EULA. If you acquired this Software in a country outside of the
United States, that country’s laws may apply. In any action or suit to enforce any right or remedy under this EULA or to
interpret any provision of this EULA, the prevailing party will be entitled to recover its costs, including reasonable attor-
neys’ fees.

ENTIRE AGREEMENT. This EULA constitutes the entire agreement between you and Opengear with respect to the
Software, and supersedes all other agreements or representations, whether written or oral. The terms of this EULA can
only be modified by express written consent of both parties. If any part of this EULA is held to be unenforceable as writ-
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ten, it will be enforced to the maximum extent allowed by applicable law, and will not affect the enforceability of any
other part.

Should you have any questions concerning this EULA, or if you desire to contact Opengear for any reason, please con-
tact the Opengear representative serving your company.

THE FOLLOWING DISCLAIMER OF WARRANTY AND LIMITATION OF LIABILITY IS INCORPORATED INTO THIS
EULA BY REFERENCE. THE SOFTWARE IS NOT FAULT TOLERANT. YOU HAVE INDEPENDENTLY DETERMINED
HOW TO USE THE SOFTWARE IN THE DEVICE, AND OPENGEAR HAS RELIED UPON YOU TO CONDUCT SUFFI-
CIENT TESTING TO DETERMINE THAT THE SOFTWARE IS SUITABLE FOR SUCH USE.

LIMITED WARRANTY Opengear warrants the media containing the Software for a period of ninety (90) days from the
date of original purchase from Opengear or its authorized retailer. Proof of date of purchase will be required. Any up-
dates to the Software provided by Opengear (which may be provided by Opengear at its sole discretion) shall be gov-
erned by the terms of this EULA. In the event the product fails to perform as warranted, Opengear’s sole obligation shall
be, at Opengear’s discretion, to refund the purchase price paid by you for the Software on the defective media, or to re-
place the Software on new media. Opengear makes no warranty or representation that its Software will meet your re-
quirements, will work in combination with any hardware or application software products provided by third parties,
that the operation of the software products will be uninterrupted or error free, or that all defects in the Software will be
corrected.

OPENGEAR DISCLAIMS ANY AND ALL OTHER WARRANTIES, WHETHER EXPRESS OR IMPLIED, INCLUDING
WITHOUT LIMITATION, ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. OTHER THAN AS STATED HEREIN, THE ENTIRE RISK AS TO SATISFACTORY QUALITY, PERFORMANCE,
ACCURACY, AND EFFORT IS WITH YOU. ALSO, THERE IS NO WARRANTY AGAINST INTERFERENCE WITH YOUR
ENJOYMENT OF THE SOFTWARE OR AGAINST INFRINGEMENT. IF YOU HAVE RECEIVED ANY WARRANTIES RE-
GARDING THE DEVICE OR THE SOFTWARE, THOSE WARRANTIES DO NOT ORIGINATE FROM, AND ARE NOT
BINDING ON, OPENGEAR.

NO LIABILITY FOR CERTAIN DAMAGES. EXCEPT AS PROHIBITED BY LAW, OPENGEAR SHALL HAVE NO LIABILITY
FOR COSTS, LOSS, DAMAGES OR LOST OPPORTUNITY OF ANY TYPE WHATSOEVER, INCLUDING BUT NOT LIM-
ITED TO, LOST OR ANTICIPATED PROFITS, LOSS OF USE, LOSS OF DATA, OR ANY INCIDENTAL, EXEMPLARY SPE-
CIAL OR CONSEQUENTIAL DAMAGES, WHETHER UNDER CONTRACT, TORT, WARRANTY OR OTHERWISE ARIS-
ING FROM OR IN CONNECTION WITH THIS EULA OR THE USE OR PERFORMANCE OF THE SOFTWARE. IN NO
EVENT SHALL OPENGEAR BE LIABLE FOR ANY AMOUNT IN EXCESS OF THE LICENSE FEE PAID TO OPENGEAR
UNDER THIS EULA. SOME STATES AND COUNTRIES DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABIL-
ITY FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS LIMITATION MAY NOT APPLY TO YOU.
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14.214.2 GNU generGNU general public license (al public license (GPL), vGPL), version 2ersion 2
Version 2, June 1991

Copyright © 1989, 1991 Free Software Foundation, Inc.,
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

PreamblePreamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU
General Public License is intended to guarantee your freedom to share and change free software—to make sure the
software is free for all its users. This General Public License applies to most of the Free Software Foundation’s software
and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered
by the GNU Lesser General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to
make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that
you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free pro-
grams; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surren-
der the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or
if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the
rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them
these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal
permission to copy, distribute and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands that there is no war-
ranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know
that what they have is not the original, so that any problems introduced by others will not reflect on the original au-
thors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors
of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we
have made it clear that any patent must be licensed for everyone’s free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATIONTION

1. This License applies to any program or other work which contains a notice placed by the copyright holder saying it
may be distributed under the terms of this General Public License. The “Program”, below, refers to any such pro-
gram or work, and a “work based on the Program” means either the Program or any derivative work under copy-
right law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications
and/or translated into another language. (Hereinafter, translation is included without limitation in the term “modi-
fication”.) Each licensee is addressed as “you”.

Activities other than copying, distribution and modification are not covered by this License; they are outside its
scope. The act of running the Program is not restricted, and the output from the Program is covered only if its con-
tents constitute a work based on the Program (independent of having been made by running the Program).
Whether that is true depends on what the Program does.

2. You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provid-
ed that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer
of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any
other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protec-
tion in exchange for a fee.

3. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program,
and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also
meet all of these conditions:

a. You must cause the modified files to carry prominent notices stating that you changed the files and the date of
any change.
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b. You must cause any work that you distribute or publish, that in whole or in part contains or is derived from
the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of
this License.

c. If the modified program normally reads commands interactively when run, you must cause it, when started
running for such interactive use in the most ordinary way, to print or display an announcement including an
appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a war-
ranty) and that users may redistribute the program under these conditions, and telling the user how to view
a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an an-
nouncement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived
from the Program, and can be reasonably considered independent and separate works in themselves, then this Li-
cense, and its terms, do not apply to those sections when you distribute them as separate works. But when you
distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole
must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus
to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you;
rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the
Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based
on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of
this License.

4. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form
under the terms of Sections 1 and 2 above provided that you also do one of the following:

a. Accompany it with the complete corresponding machine-readable source code, which must be distributed un-
der the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

b. Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more
than your cost of physically performing source distribution, a complete machine-readable copy of the corre-
sponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily
used for software interchange; or,

c. Accompany it with the information you received as to the offer to distribute corresponding source code. (This
alternative is allowed only for noncommercial distribution and only if you received the program in object
code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable
work, complete source code means all the source code for all modules it contains, plus any associated interface
definition files, plus the scripts used to control compilation and installation of the executable. However, as a spe-
cial exception, the source code distributed need not include anything that is normally distributed (in either source
or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the exe-
cutable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offer-
ing equivalent access to copy the source code from the same place counts as distribution of the source code, even
though third parties are not compelled to copy the source along with the object code.

5. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License.
Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically termi-
nate your rights under this License. However, parties who have received copies, or rights, from you under this Li-
cense will not have their licenses terminated so long as such parties remain in full compliance.

6. You are not required to accept this License, since you have not signed it. However, nothing else grants you permis-
sion to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not
accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you
indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modi-
fying the Program or works based on it.

7. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a
license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions.
You may not impose any further restrictions on the recipients’ exercise of the rights granted herein. You are not
responsible for enforcing compliance by third parties to this License.

8. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to
patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict
the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute
so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a
consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-
free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only
way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the
section is intended to apply and the section as a whole is intended to apply in other circumstances.
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It is not the purpose of this section to induce you to infringe any patents or other property right claims or to con-
test validity of any such claims; this section has the sole purpose of protecting the integrity of the free software
distribution system, which is implemented by public license practices. Many people have made generous contribu-
tions to the wide range of software distributed through that system in reliance on consistent application of that
system; it is up to the author/donor to decide if he or she is willing to distribute software through any other sys-
tem and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

9. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted
interfaces, the original copyright holder who places the Program under this License may add an explicit geographi-
cal distribution limitation excluding those countries, so that distribution is permitted only in or among countries
not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

10. The Free Software Foundation may publish revised and/or new versions of the General Public License from time
to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new
problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License
which applies to it and “any later version”, you have the option of following the terms and conditions either of that
version or of any later version published by the Free Software Foundation. If the Program does not specify a ver-
sion number of this License, you may choose any version ever published by the Free Software Foundation.

11. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are differ-
ent, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation,
write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the
two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and
reuse of software generally.

NO WNO WARRANTYARRANTY

12. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM,
TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE
COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY
OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WAR-
RANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE
QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFEC-
TIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

13. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT
HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMIT-
TED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR
CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING
BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY
YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS),
EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONSEND OF TERMS AND CONDITIONS

How to Apply These THow to Apply These Terms to Yerms to Your New Progrour New Programsams

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve
this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most
effectively convey the exclusion of warranty; and each file should have at least the “copyright” line and a pointer to
where the full notice is found.

one line to give the program’s name and a brief idea of what it does.
CopCopyright © yyright © year name of authorear name of author

This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
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You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software Foundation,
Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright © year name of author Gnomovision
comes with ABSOLUTELY NO WARRANTY; for details
type ‘show w’. This is free software, and you are welcome
to redistribute it under certain conditions; type ‘show c’
for details.

The hypothetical commands ‘show w’ and ‘show c’ should show the appropriate parts of the General Public License. Of
course, the commands you use may be called something other than ‘show w’ and ‘show c’; they could even be mouse-
clicks or menu items—whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer”
for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest
in the program ‘Gnomovision’
(which makes passes at compilers) written
by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a
subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is
what you want to do, use the GNU Lesser General Public License instead of this License.
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15.15. ServiceService

15.115.1 Standard warrStandard warrantyanty
Opengear, Inc., its parent, affiliates and subsidiaries, (collectively, “Opengear”) warrant your Opengear product to be in
good working order and to be free from defects in workmanship and material (except in those cases where the materi-
als are supplied by the Purchaser) under normal and proper use and service for the period of four (4) years from the
date of original purchase from an Authorized Opengear reseller. In the event that this product fails to meet this warran-
ty within the applicable warranty period, and provided that Opengear confirms the specified defects, Purchaser’s sole
remedy is to have Opengear, in Opengear’s sole discretion, repair or replace such product at the place of manufacture,
at no additional charge other than the cost of freight of the defective product to and from the Purchaser. Repair parts
and replacement products will be provided on an exchange basis and will be either new or reconditioned. Opengear will
retain, as its property, all replaced parts and products. Notwithstanding the foregoing, this hardware warranty does not
include service to replace or repair damage to the product resulting from accident, disaster, abuse, misuse, electrical
stress, negligence, any non-Opengear modification of the product except as provided or explicitly recommended by
Opengear, or other cause not arising out of defects in material or workmanship. This hardware warranty also does not
include service to replace or repair damage to the product if the serial number or seal or any part thereof has been al-
tered, defaced or removed. If Opengear does not find the product to be defective, the Purchaser will be invoiced for said
inspection and testing at Opengear’s then current rates, regardless of whether the product is under warranty.
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